Issue 122009 - Hyperlink migration Word under MacOS
Summary: Hyperlink migration Word under MacOS
Status: CLOSED DUPLICATE of issue 31267
Alias: None
Product: Writer
Classification: Application
Component: open-import (show other issues)
Version: 3.4.1
Hardware: Mac OS X 10.8
: P3 Normal (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-06 10:11 UTC by Paul HENRY
Modified: 2017-03-29 17:47 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Document with hyperlinks that point to local files. (71.00 KB, application/msword)
2016-11-05 19:52 UTC, bogdan.birnicu
no flags Details
Screenshot with the error message. (93.15 KB, image/png)
2016-11-05 20:37 UTC, bogdan.birnicu
no flags Details
Test result for OO version 4.1.3 (98.45 KB, image/png)
2016-11-07 08:01 UTC, bogdan.birnicu
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Paul HENRY 2013-04-06 10:11:20 UTC
With documents created with Microsoft Word 97-2004 containing more than hundred "Hypertext" links, I can't use these when I open those files under OOo Writer. I get the message : "No browser has been detected by OpenOffice.org in the system…" I must recreate the hyperlinks under OOo Writer. The link created with MS Word appear in the bar of links of OOo but are slightly different from those recreated under OOo : "Volumes" appearing at the head of those, just after "file:///, is lacking in MS Word links. But adding that does not resolve the problem. All attempts to find a solution using recommandations given on the forum have been unsuccessfull. Given that I would like to migrate completly to OOo, that I have many MS word files with a quantity of "Hypertext" links, that it would be extremely fastidious and time wasting to recreate all those links under OOo Writer, I would very very thankfull to anyone who help me to solve the problem which might be encountered by other users of OOo migrating from MS Word.
Paul HENRY
Comment 1 Ariel Constenla-Haile 2013-04-06 13:22:05 UTC
(In reply to comment #0)
> With documents created with Microsoft Word 97-2004 containing more than
> hundred "Hypertext" links, I can't use these when I open those files under
> OOo Writer. 

Can you attach one of the original documents?

> I get the message : "No browser has been detected by
> OpenOffice.org in the system…" 

I couldn't find these string in the source code. Can you attach a screen shot?

> I must recreate the hyperlinks under OOo
> Writer. The link created with MS Word appear in the bar of links of OOo but
> are slightly different from those recreated under OOo : "Volumes" appearing
> at the head of those, just after "file:///, is lacking in MS Word links. But
> adding that does not resolve the problem.

From your description, I understand that the links created by MS Word are pointing to files on the file system. Are these links relative in MS Word, or do the use full, absolute paths?
Comment 2 bogdan.birnicu 2016-11-05 19:48:28 UTC
I was able to reproduce the behaviour described in the initial bug report. Below is the description of my approach:

Configuration details:
*MacBook Air, macOS Sierra, version 10.12
*OpenOffice version 3.4.1
*PC, Windows 10.
*Microsoft Word version 2007


Test scenario:
Use Open Office to open a file generated with Microsoft Word containing more than 100 hyperlinks. Check if the hyperlinks work.

Steps to reproduce:
1. Use Microsoft Word to create a document containing 110 hyperlinks that link to a local file. A link example was: ../Desktop/Rise.wmv
2. Save document using .doc (97/2000/XP) format;
3. Move the document to a MacBook machine;
4. Open the document with Open Office;
5. Press command + click on a link.

Expected result: the file was opened, or an error message is displayed stating that the file does not exist or that the path is incorrect.

Actual result: the following error message is displayed: OpenOffice.org could not find a web browser on your system. Please check your Desktop Preferences or install a web browser (for example, Mozilla) in the default location requested during the browser installation.

Right-clicking on the hyperlink then on "edit hyperlink" shows that OO sees the link as: file:///Users/MyUsername/Desktop/Desktop/Rise.wmv


Follow-up testing:

Test 2: 
I have changed the link type to point to a .doc file. The link was: ../Desktop/TestDoc.doc
I have performed the rest of the steps in the same manner as above.

The error message that appeared on the screen was: /Users/MyUsername/Desktop/Desktop/TestDoc.doc does not exist


Test 3: 
I have only added 1 link in the document. The result did not change => the behaviour of the app is not influenced by the number of hyperlinks.


Test 4:
I have used Microsoft Word to create a document containing hyperlinks pointing to websites (eg. www.google.com).
I have performed the same sequence of steps as in the initial test. 
Result: the links worked as intended and the website was opened in the default browser.
Comment 3 bogdan.birnicu 2016-11-05 19:52:00 UTC
Created attachment 85851 [details]
Document with hyperlinks that point to local files.
Comment 4 bogdan.birnicu 2016-11-05 20:37:41 UTC
Created attachment 85852 [details]
Screenshot with the error message.
Comment 5 Peter 2016-11-06 20:52:05 UTC
I appreciate your effort. But I do not believe any dev will bother with 3.4.1 Version of Open Office.

Can you repeat the test on Apache Open Office 4.1.3?
That would be awesome and I would be at least very greatfull if you could do this.

Thanks for your efforts!

All the best
Peter
Comment 6 bogdan.birnicu 2016-11-07 08:00:20 UTC
I have tried the same tests as in my previous comment and got the same exact results. Will attach a screenshot with the issue.
Comment 7 bogdan.birnicu 2016-11-07 08:01:33 UTC
Created attachment 85853 [details]
Test result for OO version 4.1.3
Comment 8 oooforum (fr) 2016-11-14 13:59:15 UTC
For me, not specific to Mac system.
Relative hyperlinks are imported as static links.

A .doc document saved in c:\temp
./my_file.txt is converted by AOO in file://c:/temp/my_file.txt

Same problem with export filter reported in issue 31267
Comment 9 oooforum (fr) 2017-03-29 09:38:09 UTC
According to my previous comment

*** This issue has been marked as a duplicate of issue 31267 ***