Issue 122056 - [sidebar] Empty panels in some Writer-based document types (XML forms, db forms/reports)
[sidebar] Empty panels in some Writer-based document types (XML forms, db for...
Status: RESOLVED FIXED
Product: General
Classification: Code
Component: ui
4.0.0-dev
All All
: P3 normal (vote)
: 4.0.0
Assigned To: Oliver-Rainer Wittmann
:
Depends on:
Blocks: [sidebar]
  Show dependency treegraph
 
Reported: 2013-04-14 19:13 UTC by Ariel Constenla-Haile
Modified: 2013-05-14 13:27 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
Database document with a form and a report (537.66 KB, application/vnd.sun.xml.base)
2013-04-14 19:13 UTC, Ariel Constenla-Haile
no flags Details
Screenshot - text selected while editing DB form (248.44 KB, image/png)
2013-04-27 17:45 UTC, Ariel Constenla-Haile
no flags Details
Screenshot - graphic selected while editing DB form (246.48 KB, image/png)
2013-04-29 21:18 UTC, Ariel Constenla-Haile
no flags Details
Patch adding com.sun.star.sdb.TextReportDesign (2.77 KB, patch)
2013-05-07 06:26 UTC, Ariel Constenla-Haile
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description Ariel Constenla-Haile 2013-04-14 19:13:06 UTC
Created attachment 80535 [details]
Database document with a form and a report

Open the attached database document
It contains a form and a report
Right-click on them and select "Edit"
The sidebar property panel is empty, whether you select text, a drawing, a graphic, a form control.
Comment 1 r4zoli 2013-04-14 19:55:32 UTC
No data in Navigator window in XML and database forms, reports.

The problem with Navigator window similar to the property window.
Comment 2 Ariel Constenla-Haile 2013-04-14 20:14:27 UTC
(In reply to comment #1)
> No data in Navigator window in XML and database forms, reports.
> 
> The problem with Navigator window similar to the property window.

You are right, I'll change the bug subject.

F9 and F11 display both old navigator and styles working fine. But may be another bug: when moving the old navigator/styles floating window, in order to dock them on the left, there is no docking area indicator, the windows can not be docked; I could only dock them with Ctrl + left-mouse-click.
Comment 3 Andre 2013-04-15 15:58:07 UTC
The reason for the missing panels is that the document editor is a Writer but the document claims to be a "FormDocument" (or something similar).  The sidebar is registered (and thus shown) for Writer, Draw/Impress, Calc.  The display of decks and panels depends on the current context.  Property and navigator deck but say "any".  This matches the FormDocument.  All property panels and the navigator panel have a more fine grained context patter, that does not match FormDocument.  The result: you can see the sidebar and the property and navigator decks but none of their panels.

There are two ways to fix this: hide the sidebar or show the panels.
Comment 4 Andre 2013-04-23 12:38:28 UTC
As far as I understand the bug description this issue is caused by the same root cause as 122051: different variants of Writer documents have internally different names.  Not all of these where listed in the sidebar code as being Writer documents.  I have added the variants for Web, XML, Forms and master documents for issue 122051.

*** This issue has been marked as a duplicate of issue 122051 ***
Comment 5 Ariel Constenla-Haile 2013-04-26 01:11:32 UTC
Fixed by Andre in revision 1470918
Comment 6 Ariel Constenla-Haile 2013-04-27 17:45:20 UTC
Created attachment 80601 [details]
Screenshot - text selected while editing DB form

The property panel is still empty
Comment 7 Ariel Constenla-Haile 2013-04-27 17:47:02 UTC
(In reply to comment #0)
> Created attachment 80535 [details]
> Database document with a form and a report
> 
> Open the attached database document
> It contains a form and a report
> Right-click on them and select "Edit"
> The sidebar property panel is empty, whether you select text, a drawing, a
> graphic, a form control.

This is still reproducible on Linux

@r4zoli: can you reproduce on Windows with the latest Dev. Snapshot (revision 1476029)?
Comment 8 Ariel Constenla-Haile 2013-04-29 21:18:55 UTC
Created attachment 80611 [details]
Screenshot - graphic selected while editing DB form
Comment 9 Ariel Constenla-Haile 2013-04-29 21:20:24 UTC
Reopening.
Not fixed on current trunk, following the steps in the bug Description
Comment 10 r4zoli 2013-04-30 08:41:14 UTC
(In reply to comment #7)
> (In reply to comment #0)
> > Created attachment 80535 [details]
> > Database document with a form and a report
> > 
> > Open the attached database document
> > It contains a form and a report
> > Right-click on them and select "Edit"
> > The sidebar property panel is empty, whether you select text, a drawing, a
> > graphic, a form control.
> 
> This is still reproducible on Linux
> 
> @r4zoli: can you reproduce on Windows with the latest Dev. Snapshot
> (revision 1476029)?

This is still reproducible on Windows, too.
Comment 11 SVN Robot 2013-04-30 12:36:12 UTC
"af" committed SVN revision 1477593 into trunk:
122056: Added another Writer variant to sidebar context handling.
Comment 12 Andre 2013-04-30 12:38:24 UTC
I had added four writer variants and still managed to forget the one described in the bug description.

Added another variant:
com.sun.star.sdb.FormDesign.
Comment 13 Ariel Constenla-Haile 2013-05-07 06:26:13 UTC
Created attachment 80648 [details]
Patch adding com.sun.star.sdb.TextReportDesign

There is still a Writer-based module missing, see http://wiki.openoffice.org/wiki/Office_modules_since_OpenOffice.org_2.3
Comment 14 Ariel Constenla-Haile 2013-05-07 06:27:50 UTC
(In reply to comment #0)
> Created attachment 80535 [details]
> Database document with a form and a report
> 
> Open the attached database document
> It contains a form and a report

Still missing Writer based reports.
Reopening.
Comment 15 Oliver-Rainer Wittmann 2013-05-14 12:18:20 UTC
reviewing and integrating Ariel's patch.

Ariel's patch looks good --> I will apply it on trunk.
Comment 16 Oliver-Rainer Wittmann 2013-05-14 12:41:15 UTC
minor adjustment of <EnumContext::GetCombinedContext_DI(...)> needed - also for com.sun.star.sdb.FormDesign
Comment 17 SVN Robot 2013-05-14 13:26:32 UTC
"orw" committed SVN revision 1482326 into trunk:
122056: adding another Writer variant for sidebar context handling
Comment 18 Oliver-Rainer Wittmann 2013-05-14 13:27:55 UTC
applied patch with minor adjustment on trunk for AOO 4.0