Issue 122087 - [Sidebar]Text and Paragraph panel not display when input text in new created textbox
Summary: [Sidebar]Text and Paragraph panel not display when input text in new created ...
Status: CLOSED FIXED
Alias: None
Product: Calc
Classification: Application
Component: editing (show other issues)
Version: 4.0.0-dev
Hardware: All All
: P3 Normal (vote)
Target Milestone: 4.0.0
Assignee: Oliver-Rainer Wittmann
QA Contact:
URL:
Keywords:
Depends on:
Blocks: [sidebar]
  Show dependency treegraph
 
Reported: 2013-04-18 09:50 UTC by Li Feng Wang
Modified: 2013-05-18 14:43 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Li Feng Wang 2013-04-18 09:50:42 UTC
build:r1413470

steps:
1)new a Calc
2)new a textbox
3)enter text to textbox, and check text and paragragh panel at the same time.

defect:
Actual result:There is no text and paragragh panel, can display when focus out of textbox, then back to edit mode.
Expect result: text and paragragh panel can display when entering text.
Comment 1 Oliver-Rainer Wittmann 2013-04-25 13:35:39 UTC
I can not reproduce the described behavior in my local build (revision 1471348) and in the current snapshot build (revision 1468069) under Windows 7

I performed the following steps:
- create new spreadsheet document
- in Drawing toolbar choose Text
- create text box using mouse
--> cursor is directly located inside newly created text box and the property panels Text and Paragraph are available.

Li Feng Wang:
Please confirm that the defect is no longer reproducible. Thanks in advance.
Comment 2 Oliver-Rainer Wittmann 2013-04-26 09:04:03 UTC
Now, I can reproduce it.

It only happens when creating a text box without having created and selected other drawing objects.
Comment 3 Oliver-Rainer Wittmann 2013-04-26 09:08:25 UTC
damn - sorry for the typo

(In reply to comment #2)
> Now, I can reproduce it.
> 
> It only happens when creating a text box without having created and selected
> other drawing objects.

It only happens when creating a text box with having created and selected other drawing objects before.
Comment 4 Oliver-Rainer Wittmann 2013-04-26 12:22:50 UTC
fixed in trunk for AOO 4.0
Comment 5 Oliver-Rainer Wittmann 2013-04-26 12:30:18 UTC
root cause for this issue is related to the one of bug 122156
--> fix has been with one code change - see revision 1476164
Comment 6 DanielAlvaro 2013-05-18 14:43:46 UTC
Hello,

I reproduced this issue with your steps with A00 4.0

Text and Paragraph panel in display when I create the new textbox and when  I write  also into the texbox. 


I'll close this bug but If you have any problem you can reopen it.

Regards,

Daniel Alvaro