Issue 122139 - [sidebar]can't undo font size setting in spreadsheet.
Summary: [sidebar]can't undo font size setting in spreadsheet.
Status: CLOSED IRREPRODUCIBLE
Alias: None
Product: Calc
Classification: Application
Component: editing (show other issues)
Version: 4.0.0-dev
Hardware: All All
: P3 Normal (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks: [sidebar]
  Show dependency tree
 
Reported: 2013-04-23 06:29 UTC by Du Jing
Modified: 2017-05-20 09:58 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Du Jing 2013-04-23 06:29:57 UTC
Trunk build: r1413470

steps:
1.new a spreadsheet
2.focus on a cell,and keep in editing status
3.input some text in a cell and set size 36 by sidebar
4.undo

defect:
can't restore to default font size by undo.
Comment 1 liuyixuan.527 2013-04-24 06:20:22 UTC
Same behavior with Symphony.
You could undo by follow steps:
1. input text in cell 
2. Choose the text and change text size
3. Keep edit mode and Undo

If exiting edit mode and undo, undo doesn't work
Comment 2 Armin Le Grand 2013-04-30 14:34:37 UTC
ALG: cannot reproduce, works well, with and without taking the focus away from text edit.
Comment 3 Oliver-Rainer Wittmann 2013-05-03 10:08:32 UTC
I can not reproduce the described defect in current snapshot build:

The following works fine (on my side):
- scenario A:
-- new spreadsheet
-- insert text into a cell
-- cursor located at end of inserted text (no text selected)
-- change font size in text property panel (or formatting toolbar)
-- Undo
---> font size back to previous value

- scenario B:
-- new spreadsheet
-- insert text into a cell
-- select some text or the complete text
-- change font size in text property panel (or formatting toolbar)
-- Undo (Ctrl-Z or toolbar button)
---> font size back to previous value

- scenario C:
-- new spreadsheet
-- insert text into a cell
-- select some text or the complete text
-- change font size in text property panel (or formatting toolbar)
-- leave cell edit mode
-- Undo
---> font size back to previous value

resolving issue as not reproducible