Issue 122156 - [sidebar] properties panel refresh incorrectly sometime
[sidebar] properties panel refresh incorrectly sometime
Status: CLOSED FIXED
Product: Impress
Classification: Application
Component: ui
4.0.0-dev
All Windows 7
: P2 major (vote)
: 4.0.0
Assigned To: Oliver-Rainer Wittmann
Shenfeng Liu
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-24 03:31 UTC by Shenfeng Liu
Modified: 2013-05-07 14:48 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: 4.0.0
Developer Difficulty: ---


Attachments
screenshot for the sidebar refresh scenario 1. (56.94 KB, image/png)
2013-04-24 03:31 UTC, Shenfeng Liu
no flags Details
screenshot for the sidebar refresh scenario 2. (251.47 KB, image/png)
2013-04-24 03:33 UTC, Shenfeng Liu
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Shenfeng Liu 2013-04-24 03:31:08 UTC
Created attachment 80588 [details]
screenshot for the sidebar refresh scenario 1.

Scenario 1:
(1) Create a blank presentation
(2) click into a text box, and notice that the properties sidebar will show the Text and Paragraph related properties.
(3) Switch to another application, and switch back, to trigger a refresh.
(4) Issue: the focus is still in the text box, but the properties sidebar shows the slide layout properties. (see attachment)
* This issue can not always be reproduced, but has big chance to happen in my machine. Maybe it is related to timeout or some thing during the refresh.

Scenario 2:
(1) Create a blank presentation
(2) Click into a text box, and notice that the properties sidebar will show the Text and Paragraph related properties.
(3) Click "X" on top-left corner to try to close the application, a dialog popup to prompt you to save modified document;
(4) Issue: Please notice the selection changed from inside of the text box to the text box object itself, but the Properties panel become Layouts of the slide.
(5) Click Cancel, still the issue in step (4).
* This issue is 100% reproducible on my machine.

My build is r1467226 .
Comment 1 Shenfeng Liu 2013-04-24 03:33:05 UTC
Created attachment 80589 [details]
screenshot for the sidebar refresh scenario 2.
Comment 2 Oliver-Rainer Wittmann 2013-04-25 13:57:52 UTC
First, one remark for the future:
Please submit one issue for each problem.

ad Scenario 1:
I can not reproduce the described behavior in my local build (revision 1471348) and in the current snapshot build (revision 1468069) under Windows 7.

ad Scenario 2:
The text edit mode is left when the user wants to close the current document. The same happens when the user hits the Escape key to leave the test edit mode.
It looks like that the wrong context has been notified.

ad Shenfeng Liu:
I will use this issue to fix the defect described in scenario 2.
Once you have a reproducible scenario for the defect described in scenario 1, I propose to submit a new issue.
Thanks in advance.

--> working on fix for correct sidebar panels when leaving the text edit mode in Impress/Draw via Escape key or by closing the document via Close button
Comment 3 Oliver-Rainer Wittmann 2013-04-25 15:29:29 UTC
The described defect (scenario 2) also occurs in Draw, but I did not observe it in Writer.
Comment 4 Shenfeng Liu 2013-04-26 04:54:07 UTC
Agree for this defect to focus on Scenario 2.
I will try the latest build, and will open a separated defect for Scenario 1 if I still can reproduce it.
Comment 5 SVN Robot 2013-04-26 12:22:55 UTC
"orw" committed SVN revision 1476164 into trunk:
122156 122087: correct context notification regarding the text edit mode for ...
Comment 6 Oliver-Rainer Wittmann 2013-04-26 12:24:07 UTC
fixed on trunk for AOO 4.0
Comment 7 Oliver-Rainer Wittmann 2013-04-29 08:48:03 UTC
fix causes regression:
- Calc: in text edit mode of certain drawing object text and paragraph property panels are not working correct - most of the controls are disabled.

root cause:
wrong <SfxShell> becomes active by the fix
Comment 8 SVN Robot 2013-04-29 12:32:56 UTC
"orw" committed SVN revision 1476999 into trunk:
122156 122087: correct context notification regarding the text edit mode for ...
Comment 9 Oliver-Rainer Wittmann 2013-04-29 12:33:56 UTC
fix corrected on trunk for AOO 4.0
Comment 10 Yurggent Alfredo Chable Torrez 2013-05-03 20:03:42 UTC
this has beeb solved.

I have tested with Windows 7 and AOO 4.0.0
Regars.
Comment 11 Shenfeng Liu 2013-05-07 14:48:54 UTC
Verified on build  Rev. 1478648, and it is fixed. So close it.