Issue 122178 - [sidebar] Unable to re-size the sidebar
Summary: [sidebar] Unable to re-size the sidebar
Status: RESOLVED FIXED
Alias: None
Product: General
Classification: Code
Component: ui (show other issues)
Version: 4.0.0-dev
Hardware: All All
: P3 Normal (vote)
Target Milestone: 4.0.0
Assignee: Andre
QA Contact:
URL:
Keywords: regression
: 122146 122148 122164 (view as issue list)
Depends on:
Blocks: [sidebar]
  Show dependency tree
 
Reported: 2013-04-27 03:12 UTC by Ariel Constenla-Haile
Modified: 2013-07-11 13:56 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Screenshot - Linux with gnome2 (232.08 KB, image/png)
2013-04-27 03:21 UTC, Ariel Constenla-Haile
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Ariel Constenla-Haile 2013-04-27 03:12:47 UTC
Current Dev. Snapshot.
This bug happens application-wide.
Test on Writer:

- New Writer document

a) the sidebar bar cannot be re-sized
b) there is no auto-hide button
Comment 1 Ariel Constenla-Haile 2013-04-27 03:14:45 UTC
This is a regression from previous Developer Snapshot
Comment 2 Ariel Constenla-Haile 2013-04-27 03:21:42 UTC
Created attachment 80597 [details]
Screenshot - Linux with gnome2

Note that there is no split window auto-hide button, and the controls of the paragraph properties panel are too wide for the sidebar width.
Comment 3 Ariel Constenla-Haile 2013-04-27 03:23:37 UTC
Steps to bring sidebar resizing and auto-hide button back:

- New Writer document
- the sidebar cannot be resized, there is no auto-hide button
- Undock the sidebar
- Redock the sidebar
- now the sidebar can be resized, and there is auto-hide button
Comment 4 jmpoo 2013-04-29 06:30:58 UTC
Looks like a duplicate of Bug 122164
Comment 5 Andre 2013-04-29 11:17:43 UTC
This is caused by my failed attempt to fix a compiler warning.

In the constructor of SidebarChildWindow there is a call to SfxDockingWindow::Initialize().  This call should be made a the docking window child of the new SidebarChildWindow.  My fix (rev 1469765 for issue 121960) rerouted that call to its parent window.  I fixed that with rev. 1476921 as for issue 122082.  The fix is simple and I was editing this file anyway, so I did not open a separate issue for that.

Setting this issue to fixed and marking issue 122164 as duplicate.
Comment 6 Andre 2013-04-29 11:18:59 UTC
*** Issue 122164 has been marked as a duplicate of this issue. ***
Comment 7 Andre 2013-04-29 12:11:51 UTC
*** Issue 122148 has been marked as a duplicate of this issue. ***
Comment 8 Andre 2013-04-29 12:29:05 UTC
*** Issue 122146 has been marked as a duplicate of this issue. ***