Issue 122195 - add UNO support for 64bit OSX
Summary: add UNO support for 64bit OSX
Status: CLOSED FIXED
Alias: None
Product: General
Classification: Code
Component: code (show other issues)
Version: 4.0.0-dev
Hardware: Mac Mac OS X, all
: P3 Normal (vote)
Target Milestone: 4.1.0
Assignee: hdu@apache.org
QA Contact:
URL:
Keywords:
Depends on:
Blocks: 121715
  Show dependency tree
 
Reported: 2013-04-30 12:13 UTC by hdu@apache.org
Modified: 2017-05-20 10:35 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description hdu@apache.org 2013-04-30 12:13:21 UTC
OpenOffice and its successors use the "UNO framework" [1] for intra- and inter-process communication. It has some unique benefits that come at a price e.g. when an underlying platform evolves and even more if a new platform is targeted. This task tracks the addition of the 64bit UNO bridge for OSX.

[1] http://wiki.openoffice.org/wiki/Uno
Comment 1 SVN Robot 2013-04-30 12:28:59 UTC
"hdu" committed SVN revision 1477588 into trunk:
#i122195# fix OSX64 UNO bridge's callVirtualMethod() for high optimization le...
Comment 2 SVN Robot 2013-04-30 12:29:30 UTC
"hdu" committed SVN revision 1477590 into trunk:
#i122195# fix OSX64 UNO bridge's privateSnippetExecutor() for high optimizati...
Comment 3 SVN Robot 2013-04-30 12:32:01 UTC
"hdu" committed SVN revision 1477591 into trunk:
#i122195# fix build problems in the OSX64 UNO bridge
Comment 4 SVN Robot 2013-05-08 17:54:12 UTC
"hdu" committed SVN revision 1480379 into branches/rejuvenate01:
#i122195# add UNO support for 64bit OSX
Comment 5 SVN Robot 2013-05-08 18:14:36 UTC
"hdu" committed SVN revision 1480384 into branches/rejuvenate01:
#i122195# add VCL support for 64bit OSX>=10.7
Comment 6 SVN Robot 2013-05-08 18:20:01 UTC
"hdu" committed SVN revision 1480387 into branches/rejuvenate01:
#i122195# quicktime support is no longer available in OSX SDKs>=10.7
Comment 7 SVN Robot 2013-05-08 18:22:04 UTC
"hdu" committed SVN revision 1480388 into branches/rejuvenate01:
#i122195# add 64bit support for the MacSpellCheck
Comment 8 SVN Robot 2013-05-08 18:55:20 UTC
"hdu" committed SVN revision 1480405 into branches/rejuvenate01:
#i122195# change configure to allow XCode4 MacOSX builds
Comment 9 SVN Robot 2013-05-13 09:39:47 UTC
"hdu" committed SVN revision 1481752 into branches/rejuvenate01:
#i122195# add missing map for UNO's purple-environment
Comment 10 SVN Robot 2013-08-13 13:02:40 UTC
"hdu" committed SVN revision 1513468 into branches/rejuvenate01:
#i122195# XContentEnumerationAccess is needed in UNO bootstrapping
Comment 11 SVN Robot 2013-10-29 08:14:09 UTC
"jsc" committed SVN revision 1534063 into branches/rejuvenate01:
#122195# change cppu env, comid from generic cxx to s5abi (System 5 AMD64 ABI)
svnbz message delay caused by perl problems after Bugzilla 4.4.1 update
Comment 12 SVN Robot 2013-10-29 08:14:22 UTC
"hdu" committed SVN revision 1534099 into branches/rejuvenate01:
#i122195# adjust bridge's build.lst to the renamed directory
svnbz message delay caused by perl problems after Bugzilla 4.4.1 update
Comment 13 SVN Robot 2013-10-29 08:14:25 UTC
"hdu" committed SVN revision 1534099 into branches/rejuvenate01:
#i122195# adjust bridge's build.lst to the renamed directory
svnbz message delay caused by perl problems after Bugzilla 4.4.1 update
Comment 14 SVN Robot 2013-10-29 08:14:31 UTC
"hdu" committed SVN revision 1534099 into branches/rejuvenate01:
#i122195# adjust bridge's build.lst to the renamed directory
svnbz message delay caused by perl problems after Bugzilla 4.4.1 update
Comment 15 SVN Robot 2013-10-29 08:14:35 UTC
"hdu" committed SVN revision 1534099 into branches/rejuvenate01:
#i122195# adjust bridge's build.lst to the renamed directory
svnbz message delay caused by perl problems after Bugzilla 4.4.1 update
Comment 16 SVN Robot 2013-10-29 08:14:37 UTC
"hdu" committed SVN revision 1534098 into branches/rejuvenate01:
#i122195# adjust bridge for jsc's cxx->s5abi rename for OSX 64bit
svnbz message delay caused by perl problems after Bugzilla 4.4.1 update
Comment 17 SVN Robot 2013-11-12 08:36:15 UTC
"hdu" committed SVN revision 1540968 into branches/rejuvenate01:
#i122195# adapt the purpenvhelper to jsc's cxx->s5abi rename for OSX 64bit
Comment 18 SVN Robot 2013-12-02 09:42:08 UTC
"hdu" committed SVN revision 1546938 into trunk:
#i122195# XContentEnumerationAccess is needed in UNO bootstrapping
Comment 19 SVN Robot 2013-12-10 17:29:43 UTC
"hdu" committed SVN revision 1549902 into branches/rejuvenate01:
#i122195# provide proper type_info for UNO exceptions on OSX 64bit
Comment 20 SVN Robot 2013-12-10 18:53:57 UTC
"hdu" committed SVN revision 1549925 into trunk:
#122195# change cppu env, comid from generic cxx to s5abi (System 5 AMD64 ABI)
Comment 21 SVN Robot 2013-12-10 19:22:21 UTC
"hdu" committed SVN revision 1549940 into trunk:
#i122195# provide proper type_info for UNO exceptions on OSX 64bit
Comment 22 SVN Robot 2013-12-11 06:53:04 UTC
"hdu" committed SVN revision 1550058 into trunk:
#i122195# adapt bridges build.lst to renamed bridge
Comment 23 SVN Robot 2013-12-12 09:29:47 UTC
"hdu" committed SVN revision 1550381 into trunk:
#i122195# fix leak when handling exceptions in the UNO bridge for OSX 64bit
Comment 24 SVN Robot 2013-12-12 10:08:54 UTC
"hdu" committed SVN revision 1550389 into trunk:
#i122195# provide a uno_purpenvhelpers map file for the OSX 64bit UNO bridge
Comment 25 SVN Robot 2014-01-22 13:51:35 UTC
"hdu" committed SVN revision 1560350 into trunk:
#i122195# extend macosx gbuild makefile for clang-compiler