Issue 122262 - Cannot select text in tables using the keyboard
Cannot select text in tables using the keyboard
Product: Writer
Classification: Application
Component: editing
All All
: P3 Normal (vote)
: 4.0.0
Assigned To: Oliver-Rainer Wittmann
: accessibility, regression
Depends on:
  Show dependency treegraph
Reported: 2013-05-09 08:45 UTC by Andrea Pescetti
Modified: 2013-06-02 16:00 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Note You need to log in before you can comment on or make changes to this issue.
Description Andrea Pescetti 2013-05-09 08:45:27 UTC
Do the following in AOO400m1 in a new Writer document:
1) Table - Insert - Create a 2x2 table
2) Write some text in a cell
3) Try to select the text with Shift+Left/Right Arrow

Expected result:
the text is selected

Actual result:
the table width is reduced/enlarged

Regression wrt 3.4.1.
Comment 1 Rainer Bielefeld 2013-05-09 09:10:42 UTC
Reproducible with server installation of  "AOO 4.0.0-Dev – English UI / German locale [AOO400m1(Build:9700) - Rev. 1479897 (2013-05-09)]" on WIN7 Home Premium (64bit)", own separate user profile: 

In tables <Shift+Arrow> does the action what should be done by <Alt+Arrow>
Already in Rev. 1457992 Rev.1457606
Comment 2 Oliver-Rainer Wittmann 2013-05-30 15:40:54 UTC
taking over.

seems to be a regression of the changes for bug 121236.
Comment 3 SVN Robot 2013-05-31 14:05:43 UTC
"orw" committed SVN revision 1488232 into trunk:
122262: correct handling of Shift-<arrow key> for bigger steps movement of ob...
Comment 4 Oliver-Rainer Wittmann 2013-05-31 14:08:49 UTC
fixed on trunk for AOO 4.0
Comment 5 Andrea Pescetti 2013-06-02 16:00:48 UTC
Thank you Oliver, verified fixed in the latest daily build. Marking VERIFIED.