Issue 122346 - AOO doesn't recognize installed printers
Summary: AOO doesn't recognize installed printers
Alias: None
Product: General
Classification: Code
Component: ui (show other issues)
Version: 4.0.0
Hardware: All Windows XP
: P2 Normal with 1 vote (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
: 122826 (view as issue list)
Depends on:
Reported: 2013-05-19 16:59 UTC by blnsfu
Modified: 2017-05-20 11:55 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Note You need to log in before you can comment on or make changes to this issue.
Description blnsfu 2013-05-19 16:59:28 UTC
Even though a printer is installed, openoffice doesn't recognize that there is one, so I cannot print from calc or write.
Comment 1 Edwin Sharp 2013-05-22 10:34:44 UTC
Printer make and model?
Is printing possible from other applications?
Comment 2 blnsfu 2013-05-27 09:45:23 UTC
I believe the printer ia a Canon, but I cannot confirm this as the problem is occurring on a friend's computer, and he's away. IAC, the printer is installed in Windows XP; I believe the make and model are not relevant.

Yes, he can print from other applications. For example, he can save his spreadsheet as a pdf and print it with Adobe Acrobat.
Comment 3 Edwin Sharp 2013-05-27 12:13:11 UTC
Please try a reset of user profile:
Comment 4 blnsfu 2013-05-29 12:35:42 UTC
I have reset the user profile as requested, but it made no difference.

Other info: the printer is a Canon MP220 series and it is the default printer.

When I right-click on the printer icon on the menubar, this message is displayed:
'Print File Directly(Canon MP220 series Printer)'.

When I try to print by clicking on the print icon, a message box is displayed saying 'No Default Printer selected' and inviting me to choose another printer.

Selecting Printer Setup from the File pulldown menu results in a dialog box that apparently is intended to allow you to select a printer, but the cursor cannot be moved to the Name field, and the down arrow at the right end of the Name field is grayed out, as is the Properties button.
Comment 5 Edwin Sharp 2013-05-29 15:31:18 UTC
This is strange.
Sorry, I can't think of another solution.
Comment 6 blnsfu 2013-05-29 17:21:01 UTC
So where do we go from here?
Comment 7 Edwin Sharp 2013-05-29 17:43:22 UTC
I will request help in the mailing list.
Comment 8 Edwin Sharp 2013-05-29 18:15:58 UTC
Help from Regina Henschel:

"It is possible, that something is wrong with the installation of the 
printer. He should use the original driver from the manufacturer of the 
printer. If there are drivers in several languages, the user should use 
the English one. It it possible to "install" the printer twice, but of 
cause the user can delete the printer before installing it again. It is 
not necessary to make it the default printer.

All that is in XP not in AOO."
Comment 9 Rob Weir 2013-05-29 19:22:58 UTC
Is this a local printer or a network printer?
Comment 10 blnsfu 2013-05-30 07:07:58 UTC
Printer installation problems seem very unlikely to me since all other applications on the system print without any problems. IAC, he did use the manufacturer's CD when installing it, and he also used the English language.

It is a local printer, connected via USB.
Comment 11 blnsfu 2013-06-21 14:33:28 UTC
It's been three full weeks now since anyone has done anything about this problem.

Surely you've had enough time to look into the code and find out why the help text for the print icon displays the correct name of the default printer, while the print function itself thinks no printers are installed.

Is that it? Are you going to leave the status of this bug UNCONFIRMED forever?
Comment 12 Edwin Sharp 2013-06-21 14:54:27 UTC
I confirm this bug without personally being able to verify it just to make sure it will be checked.

@blnsfu: version 4.0 will be released on July 16th and hopefully it will work better for you.
I apologize if you feel the bug was neglected. Looking at the code is beyond my capability. I help only in confirming bugs and running test cases.
Comment 13 blnsfu 2013-06-25 06:02:47 UTC
I understand your position, but I assumed you would be able to have a developer look at the code. I have worked in support and I know how these things are.

I will wait for release 4.0


Comment 15 blnsfu 2013-07-16 08:35:18 UTC
OK, I tried the RC version of 4.0.0. It caused my system to hang completely: I had to power cycle my laptop to recover. I tried it three times; I was able to bring up the Calc screen, but that was all.

How do I uninstall it? It is unknown to "Add or Remove Programs", and I can find no uninstall program.
Comment 16 Edwin Sharp 2013-07-16 14:40:30 UTC
Installation successful on Win XP SP 2 Fujitsu Amilo A1650G AMD Turion 352 MHZ 384MB RAM
Apache OpenOffice correctly detects printer HP Officejet J6400 series
Control panel - Add or remove programs - OpenOffice 4.0.0 appears in currently installed programs.
Comment 17 blnsfu 2013-07-17 16:02:25 UTC
I reinstalled 4.0.0 over top of my original install. It installed successfully without any errors. My system is a Dell Vostro running Windows XP SP3. It has an Intel Duo cpu T8300 @ 2.4 GHz and 3GB of RAM. OO does not appear under "Add or Remove Programs".

When I started OO. it gave me a message that it wanted to install version 2010.3.16 of "English spelling and hyphenation dictionaries and thesaurus" even though I had that version already installed. It asked did I want to replace the one I had installed; I replied "No": it said "Fatal error" and OO did not start. 

I started OO again. The above message did not appear. In the main OO window, I selected Spreadsheet. Another window appeared with an empty spreadsheet appeared. My system locked up before I could do anything.

On subsequent restarts I selected Spreadsheet several times and Text Document once. Each time my system locked up and I had to power cycle and reboot it.

BTW, this system is not the one where the printer recognition problem occurred. The status of this problem is definitely not RESOLVED. You need to let the customer make that determination. I am marking it REOPENED. 

Could it be that having two processors is the problem?
Comment 18 Edwin Sharp 2013-07-25 05:35:37 UTC
*** Issue 122826 has been marked as a duplicate of this issue. ***
Comment 19 Raphael Bircher 2013-09-20 05:57:37 UTC
Hi at all

This issue will be realy hard to takle. We use this issue to collect the informations.

@binssfu Do you have Windows XP 32 or 64 bit?

Comment 20 blnsfu 2013-09-30 12:32:10 UTC
Sorry, I haven't checked for a response for some time.

Yes, it will be doubly hard because it's not my machine that has the problem. The guilty machine belongs to a computer illiterate friend. He's running Windows XP; not sure whether it's Home or Pro. The printer is a Canon MP220 and it's the default printer, but I doubt if the make and model are relevant.

I would begin with this observation: if I hold the mouse cursor over the print icon in the toolbar, the help text displays the correct printer identification; but if I left-click on the print icon, OO says there is no default printer, and there are no printers installed to choose from. Clearly both scenarios require the code to retrieve the name of the default printer from the registry, but in the second case, the code does something different. So the first question in my mind is "What is that difference?"

I hope that helps.
Comment 21 blnsfu 2014-02-28 16:20:29 UTC
I have raised the priority since it is almost a year since I opened it and as far as I can tell, nothing has been done to even investigate this problem.
Comment 22 blnsfu 2014-03-08 14:47:11 UTC
Duplicate incident 122826 is a report of this symptom in 4.0.0.