Issue 122368 - nbintegration: Blanks or Colons in path seem unsupported under windows
Summary: nbintegration: Blanks or Colons in path seem unsupported under windows
Status: CLOSED FIXED
Alias: None
Product: App Dev
Classification: Unclassified
Component: sdk (show other issues)
Version: 3.4.1
Hardware: PC Windows 7
: P3 Normal
Target Milestone: 4.1.1
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-22 13:42 UTC by danielkulesz
Modified: 2017-05-20 09:32 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---
jsc: 4.1.1_release_blocker+


Attachments
Error message in wizard (45.83 KB, image/png)
2013-05-22 13:43 UTC, danielkulesz
no flags Details
Error message during build (2.65 KB, text/plain)
2013-05-22 13:44 UTC, danielkulesz
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description danielkulesz 2013-05-22 13:42:40 UTC
I have tried the nbintegration with Netbeans in the following configuration:

Windows: 7 (64bit)
OpenOffice: 3.4.1
OpenOffice SDK: 3.4.1
Netbeans: 7.3
Netbeans Integration: 3.0.2 (obtained from Carl Marcum's Repository at http://people.apache.org/~cmarcum/devtools/ )

Installing OOo to the normal location puts the installed files in the following directory:

"C:\Program Files (x86)\OpenOffice.org 3\"

Then I tried creating a new OpenOffice.Calc AddIn. Already the wizard welcomed me with the error message shown in the first attachment.

When trying to export the project to an OXT file, I got the following error:

Spurious filename '(x86)\OpenOffice.org'

(see the second attachment for the full output)

As a workaround, I copied the contents of the OOo3-installation to another folder (c:\ooo3copy) and with this location, it works flawlessly. It seems like either the blank or the colon is causing this issue.
Comment 1 danielkulesz 2013-05-22 13:43:15 UTC
Created attachment 80717 [details]
Error message in wizard
Comment 2 danielkulesz 2013-05-22 13:44:01 UTC
Created attachment 80718 [details]
Error message during build
Comment 3 Ariel Constenla-Haile 2013-05-22 19:16:24 UTC
(In reply to comment #0)
> 
> "C:\Program Files (x86)\OpenOffice.org 3\"

This might be not related to the NetBeans plug-in in particular, but a more general problem.

Did you try to set up the SDK environment?
You can find instructions inside the SDK folder.
If you can set up the environment, please test if it works with some of the SDK Java examples that have custom IDL, for example 

examples/DevelopersGuide/Components/JavaComponent/
Comment 4 jsc 2014-06-10 13:17:27 UTC
It's a problem of the used preprocessor ucpp which don't accept spaces or brackets in include paths.

It can fixed to convert such paths in the windows short form with ~ ... of course for windows only.
Comment 5 SVN Robot 2014-06-10 13:18:32 UTC
"jsc" committed SVN revision 1601629 into trunk:
#122368# convert inc paths into short form on windows to avoid problem with ucpp
Comment 6 jsc 2014-06-10 13:19:00 UTC
Fixed on trunk
Comment 7 jsc 2014-06-18 09:58:26 UTC
grant showstopper flag.

The fix will solve a problem with the idlc/ucpp compiler on Windows when the office/SDK is installed in the default location where the path contains spaces. It solves a problem that occurs when using the NetBeans plugin and make it unusable. The fix is minimal and will affect the idlc only.
Comment 8 SVN Robot 2014-06-18 09:59:32 UTC
"jsc" committed SVN revision 1603387 into branches/AOO410:
#122368# merge fix from trunk to solve path issue with ucpp
Comment 9 Oliver Brinzing 2014-06-18 10:21:22 UTC
.
Comment 10 Steve Yin 2014-07-25 05:01:57 UTC
Verified on AOO411m3(build 9772)