Issue 122420 - Can't Copy and Paste Hyperlink on Mac
Can't Copy and Paste Hyperlink on Mac
Status: RESOLVED FIXED
Product: Impress
Classification: Application
Component: editing
4.0.0-dev
All All
: P3 normal (vote)
: 4.0.0
Assigned To: Armin Le Grand
:
: 121020 (view as issue list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-30 03:45 UTC by liuping
Modified: 2013-07-12 12:30 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description liuping 2013-05-30 03:45:25 UTC
Build Version: AOO400ml(Build:9700) -Rev 14846779
Platform: Mac OS

1. New a slide in presentation 
2. Input hyperlink ,such as www.google.com
4. Select hyperlink and paste in the same slide

Issue:
Fail to paste hyperlin
Comment 1 Armin Le Grand 2013-05-31 12:58:19 UTC
ALG: COuld not reproduce. I used Insert/Hyperlink from the Menu, added a link, clicked 'Apply' -> text object with link is created on slide. Deselect -> hyperlink works, opens browser. Select again (using tab), copy/paste -> new textbox created, moved a little bit, deselected -> link works.
Starting slideshow, both links work.
Branch two days ago, r1487406.
Comment 2 Armin Le Grand 2013-06-04 09:07:13 UTC
ALG: Jsc showed me that it happens as described when you activate TextEdit mode, directly type a hyperlink and do copy/paste after it was automatically detected, all without leaving the edit mode.

New desription:
- New Draw/Impress
- Activate or create Text object to be in text edit mode
- Type hyperlink, let it autodetect (gray background)
- Select it as text, copy/paste -> not pasted
Comment 3 Armin Le Grand 2013-06-04 09:16:15 UTC
ALG: Obiously double/related to #121020#
Comment 4 Armin Le Grand 2013-06-05 14:56:19 UTC
ALG: Preparing updated mac build to check...
Comment 5 Armin Le Grand 2013-06-05 14:57:00 UTC
ALG: Argh, wrong task, please ignore comment 4
Comment 6 Armin Le Grand 2013-06-05 15:06:07 UTC
ALG: Grepping...
Comment 7 Armin Le Grand 2013-06-06 11:02:13 UTC
ALG: Checked, worked in AOO3.4.1 r1372282. Must have to do with clipboard changes due to support alpha-channeled bitmaps, debugging...
Comment 8 Armin Le Grand 2013-06-06 11:37:26 UTC
ALG: It's a regression caused by #120481# where openOfficeToSystemFlavor was split to openOfficeToSystemFlavor and internalOpenOfficeToSystemFlavor. Not in all ceses where openOfficeToSystemFlavor was called is internalOpenOfficeToSystemFlavor called. Adding to call it in OSXTransferable::getTransferData solves the problem. To do so I have to make internalOpenOfficeToSystemFlavor public and call it there. Refining code...
Comment 9 Armin Le Grand 2013-06-06 11:54:23 UTC
ALG: Checked combinations; it needs to be called in AquaClipboard::flushClipboard() and in OSXTransferable::getTransferData. Still dependent from if internalOpenOfficeToSystemFlavor has to be used a bool is set. Preparing change...
Comment 10 Armin Le Grand 2013-06-06 12:16:50 UTC
ALG: Applied changes, checked, works. Comitted, done.
Comment 11 Armin Le Grand 2013-06-06 12:18:30 UTC
*** Issue 121020 has been marked as a duplicate of this issue. ***
Comment 12 SVN Robot 2013-06-06 12:21:04 UTC
"alg" committed SVN revision 1490250 into trunk:
i122420 Re-activated the internal OpenOfficeToSystemFlavor