Issue 122471 - The Lookup Gesture looks up the wrong word
Summary: The Lookup Gesture looks up the wrong word
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: code (show other issues)
Version: 3.3.0 or older (OOo)
Hardware: Mac Mac OS X, all
: P3 Normal (vote)
Target Milestone: 4.1.1
Assignee: hdu@apache.org
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-05 09:32 UTC by hdu@apache.org
Modified: 2017-05-20 10:35 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---
jsc: 4.1.1_release_blocker+


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description hdu@apache.org 2013-06-05 09:32:57 UTC
OSX supports many touchpad gestures one of which is the "Lookup Gesture":
A three finger tap does a lookup of the highlighted word or the one under the cursor. OSX 10.8 uses a three finger double-tap instead.

Then a popup will show details about the word from the OSX Dictionary, Thesaurus, Glossary and eventually also extracts from Wikipedia.

The problem is, that AOO 3.4.x up to today's trunk version only the first word will be looked up regardless of the text highlight or the cursor position.
Comment 1 SVN Robot 2014-06-25 11:40:59 UTC
"hdu" committed SVN revision 1605355 into trunk:
#i122471# make the Mac lookup feature handle the correct word
Comment 2 hdu@apache.org 2014-06-25 11:44:05 UTC
Fixed with the commit above. This nice Mac feature works now and the fix is small and risk-less, so it may be a candidate for the bugfix release.
Comment 3 jsc 2014-06-25 11:47:52 UTC
grant showstopper flag, fix is available and uncritical
Comment 4 SVN Robot 2014-06-25 11:51:19 UTC
"hdu" committed SVN revision 1605360 into branches/AOO410:
#i122471# make the Mac lookup feature handle the correct word
Comment 5 hdu@apache.org 2014-06-25 11:55:34 UTC
The fix has been merged for the AOO 4.1.1 target too.
Comment 6 hdu@apache.org 2014-08-19 12:19:55 UTC
Verified on OSX 10.9 with AOO411rc3 in an en-US locale.