Issue 122475 - Error message when trying to load a jpeg into impress document
Summary: Error message when trying to load a jpeg into impress document
Alias: None
Product: Impress
Classification: Application
Component: open-import (show other issues)
Version: 3.4.1
Hardware: All All
: P3 Normal (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Depends on:
Reported: 2013-06-05 15:11 UTC by Norm
Modified: 2017-05-20 11:55 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

screen print of error message (239.50 KB, application/octet-stream)
2013-06-05 15:11 UTC, Norm
no flags Details
Corrupt .jpg file used in replication (588.91 KB, image/jpeg)
2013-06-15 03:47 UTC, Arto Suominen
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Norm 2013-06-05 15:11:25 UTC
Created attachment 80782 [details]
screen print of error message

I get an error message of 'Graphics Filter Not Found' when trying to insert a picture into an Impress document.  I have attached a screen print of that error message.  The jpeg picture was created using a scan fro a Brother MFC-6490CW printer scanner.  I can send that picture under separate cover.
Comment 1 Ariel Constenla-Haile 2013-06-05 15:18:50 UTC
(In reply to Norm from comment #0)
> Created attachment 80782 [details]
> screen print of error message
> I get an error message of 'Graphics Filter Not Found' when trying to insert
> a picture into an Impress document.

How are you inserting the picture?
From menu Insert - Picture - From File..., or from menu Insert - Picture - Scan - Request?
Comment 2 Norm 2013-06-10 13:14:31 UTC
I have tried it several ways including using the insert button on the bottom toolbar, from file; I have tried to copy and paste it, I have tried to use the Title only template and use the center button both with a jpeg picture and a pdf , none of which has worked obviously.  I have also tried to re-save it in several different formats.  When copying and pasting I just get a generic JPEG copy or the same for PDF.
Comment 3 Armin Le Grand 2013-06-10 13:29:15 UTC
ALG: Which OperationSystem are you using? This is not reproducable on Win7 neither wit AOO3.4.1 nor with current trunk version. Didi you try different jpeg pics or does it only happen with a single one? If, we would need the picture, please.
Comment 4 Norm 2013-06-10 13:48:31 UTC
I am using a Macbook Pro, OSX 10.8.3  .  I also had the problem in Windows 7 but copied and re-saved the photo, then I copied and pasted in to an Impress slide and it worked.

I am sharing the photo in Google Drive with as it is too big to send, hope that works.
Comment 5 Armin Le Grand 2013-06-10 14:06:43 UTC
ALG: Thanks, not really. eMail arrives, but needs a login/pwd to google which I don't have. Hopefully you find another place...
Comment 6 papayes 2013-06-12 10:19:01 UTC
MacOsX 10.8.4
Win8 Pro

AOO400m2(Build9701) REV 1489073

I do not reproduce.
Even with a photo .jpg of 7,14 Go !

It is always better to copy and paste all the future elements of a presentation (charts, drawings, images) in a New folder before inserting them.
Comment 7 Arto Suominen 2013-06-15 03:44:50 UTC
I was able to reproduce this. The cause may be different from the original report, but the error message is indeed the same. 

Looking at the screenshot attached to the original report, I saw that there were already several slides and images in the presentation. That led me to the conclusion that a particular image might be causing the error. I may be wrong in this assumption, but I believe it is worth considering to be the cause.

It would help immensely if the original reporter would attached the .jpg he used.
If that file indeed is corrupt, this issue should be considered a lower priority.
I Tested on Windows 8 Pro, OpenOffice 3.4.1 (AOO341m1(Build:9593) – Rev. 1372282).

I used a corrupted .jpg file which I had made by editing a .jpg in Wordpad. I have attached the file I used, and listed here are the steps to replicate the issue:

1.	Download the attachment, “corrupted_image.jpg”.
2.	Create a new presentation, either by using the wizard or [File]->[New]->[Presentation].
3.	From the top menu, click [Insert]->[Picture]->[From File…].
4.	Select the file mentioned in step 1, and click “Open”.
	-Alternatively, you can copy-paste the image into the presentation, or use other ways of inserting.

I believe all corrupted image files will get the same result. I verified this by also corrupting other images, large and small.
To create a corrupted image, you can follow these steps:

1.	Download a .jpg file, or use an existing one on your computer.
2.	Open the file in Wordpad or another text editor.
3.	Remove a few lines of text from the contents.
4.	Save the file.
Comment 8 Arto Suominen 2013-06-15 03:47:13 UTC
Created attachment 80857 [details]
Corrupt .jpg file used in replication
Comment 9 Armin Le Grand 2013-06-17 08:19:50 UTC
ALG: Hi Arto, thanks for checking this out, what a good idea. I will use the added file and take another look.
Comment 10 Armin Le Grand 2013-06-17 08:29:45 UTC
ALG: CHecked on windows and I get the mentioned 'Graphics Filter Not Found' error. I also cannot open with any other app, thus I think we are doing the right thing; maybe we could extend to do as e.g. Paint and show a little bit more information (2nd sentence in the Paint comment, a good sentence)

Gimp: Opening 'C:\Users\IBM_ADMIN\Downloads\corrupted_image.jpg' failed: JPEG image plug-In could not open image

Paint: Paint cannot read this file. This is not a valid bitmap file, or its format is currently not supported.

Paint.NET: There was an error opening the file.

@Norm: You write that you saved the picture in different formats, thus it had to be opened by some application. Which application at all can open that picture? Could you try again to put it e.g. on DropBox under the mentioned account, I have not yet got it.
Thanks in advance!