Issue 122509 - curves in wmf picture show additional crossing lines with small and normal Zoom
curves in wmf picture show additional crossing lines with small and normal Zoom
Status: RESOLVED FIXED
Product: Writer
Classification: Application
Component: viewing
3.4.1
PC Windows 7
: P3 normal (vote)
: 4.0.0
Assigned To: Armin Le Grand
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-09 18:26 UTC by Regina Henschel
Modified: 2013-07-12 16:44 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
Textdocument with embedded .wmf picture. (41.90 KB, application/vnd.oasis.opendocument.text)
2013-06-09 18:26 UTC, Regina Henschel
no flags Details
Extracted WMF (11.06 KB, application/octet-stream)
2013-06-10 10:56 UTC, Rainer Bielefeld
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Regina Henschel 2013-06-09 18:26:14 UTC
Created attachment 80811 [details]
Textdocument with embedded .wmf picture.

Open the attached document. It contains in the upper part an embedded .wmf picture and in the lower part .png references.

I get artifacts on the red and blue line since AOo3.4.1. The display in OOo3.2.1 was correct. The error exists in the same way in Draw.
Comment 1 Edwin Sharp 2013-06-10 09:02:17 UTC
Can you please provide details on the source of the curve?
The added noise is not present in .wmf at 3.2.1?
Comment 2 Rainer Bielefeld 2013-06-10 10:56:06 UTC
Created attachment 80814 [details]
Extracted WMF

Already reproducible with server installation of  "AOO 3.4.0 – German UI / German locale [AOO340m1(Build:9590) - Rev.1327774]" on WIN7 Home Premium (64bit)", own separate user profile

The problem is limited to writer, as you can see with attachment:
1. Copy file  200001C800001F4400001F440EDD65A0.wmf in WIN files xplorer
   with <control + c>
2. Open new Writer document from AOO Start Center
3. Click into document and <control + v>
   > Picture will be inserted
   Unexpectedly document shows short lines across the graphs

New Test 
1. Copy file  200001C800001F4400001F440EDD65A0.wmf in WIN files xplorer
   with <control + c>
2. Open new Draw document from AOO Start Center
3. Click into document and <control + v>
   > Picture will be inserted
   Everythign is ok

Also Calc menu 'Insert -> Picture from file' shows correct graphs
Comment 3 Rainer Bielefeld 2013-06-10 11:00:37 UTC
Also LibO 4.0.3 (WIN) shows that problem, wa OK with LibO 3.3.0 - what ever that might mean.
Comment 4 Rainer Bielefeld 2013-06-10 11:05:58 UTC
the problem is Zoom related, for me the strange crossing lines disappear somewhere between Zoom 200% ... 400%
Comment 5 Regina Henschel 2013-06-10 11:33:19 UTC
Edwin: The .wmf-file has been generated by MuPad3.1, a computer algebra system. View was OK in OOo3.2.1.

Rainer: It depends on scaling (Properties > Crop) too.
Comment 6 Armin Le Grand 2013-06-10 12:11:52 UTC
ALG: Indeed, errors in writer.
@rainerbielefeld: Of couse the same. 4.0 was rebased on AOO3.4.1 code.
AFAIK the difference is that for Writer graphic objects the paint uses the metafile directly in VCL while DrawingLayer graphic objects use primitives. Taking a look...
Comment 7 Armin Le Grand 2013-06-10 12:13:30 UTC
ALG: Workaround: Open(insert graphic to Draw/Impress/Calc, copy/paste to Writer -> all is well whan it's a Drawinglayer graphic object.
Comment 8 Armin Le Grand 2013-06-10 12:16:33 UTC
ALG: Metafile has 456 actions, could we have a reduced version somehow? CanMuPad3.1 create something reduced? No labels, no grid, maybe?
Comment 9 Armin Le Grand 2013-06-10 12:45:43 UTC
ALG: Okay, went the hard way and could identify a single action which causes the problem (#372). Debugging leads to a typo error in basegfx (!) where 'fOne(10.0);' is defined which is obviously wrong. That typo pretty only could lead to errors when a pure '10' was compared, so only when VCL was rendering metafiles directly (because there are integer coordinates used) and the line in question is 3,-1 as a vector which gives a scalar of exactly 10.
Nice catch, correcting, comitting, done.
Comment 10 Armin Le Grand 2013-06-10 12:48:29 UTC
ALG: BTW: Zooming in reveals that MuPad3.1 creates single line pieces, the gaps between them are missing. Creating a polygon path would be much better (but would not have revealed this error).