Issue 122583 - Some black lines in AOO 3.4. document shown grey
Summary: Some black lines in AOO 3.4. document shown grey
Status: CLOSED DUPLICATE of issue 122109
Alias: None
Product: Draw
Classification: Application
Component: formatting (show other issues)
Version: 4.0.0-dev
Hardware: All All
: P3 Normal (vote)
Target Milestone: ---
Assignee: Armin Le Grand
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-25 05:23 UTC by Rainer Bielefeld
Modified: 2017-05-20 09:59 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Sample Document (18.62 KB, application/vnd.oasis.opendocument.graphics)
2013-06-25 05:23 UTC, Rainer Bielefeld
no flags Details
First Sample Document saved again from OOo 3.1.1 (18.19 KB, application/vnd.oasis.opendocument.graphics)
2013-11-03 15:41 UTC, Rainer Bielefeld
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Rainer Bielefeld 2013-06-25 05:23:46 UTC
Created attachment 80907 [details]
Sample Document

Steps how to reproduce Reproducible with  "AOO 4.0.0-Dev – English UI / German locale [AOO400m2(Build:9701)  -  Rev. 1495357
Rev.1495357  2013-06-23]" on WIN7 Home Premium (64bit)", Common 4.0-dev User Profile:

1. open attached SampleFrom341.odg with AOO 3.4.1 check line color for element
   with text "WT-BW in it and shower head
   should be black 
2. Check "Default Style" line color, is black.
3. Check "Object without fill Style" line color, is black.
10. close document without changes, reopen with AOO 4.0-dev
11. check line color for element with text "WT-BW in it and shower head
    Bug: grey 6 lines
12. Check "Default Style" line color, is black as it should be.
13. Check "Object without fill Style" line color, 
   Bug: is "grey 6" instead of  "black."

This one prolly is related to or even DUP of "Bug 122109 - In Documents from OOo (or AOO 3.4) Default Style line color "black" changes to "grey 6""
Comment 1 Ariel Constenla-Haile 2013-06-26 03:54:52 UTC
This might be related to bug 121448
Setting the expert on CC
Comment 2 Armin Le Grand 2013-06-26 10:18:43 UTC
ALG: Right, Ariel, it seems to be related to bug 121448. Not every execution path constructing a pool did call SetDrawingLayerPoolDefaults(), but historically should have, so this was a correction. The used define (COL_DEFAULT_SHAPE_STROKE) always was on gray, so there may be more situations now where the pool default is gray, not black (as can be seen when no object is selected and default line color was not yet changed).
But the pool default should have no influence here at all; the objects have the style 'Object without fill'. That style has *no* parent; normally all styles have parent 'Default', I do not know how this was created, thats the reason the pool default shows through. Normally, when the parent would be 'Default', the black line setting in 'Default' would be used.
To check, open styles dialog (F11), choose 'Hierarchical' at bottom, select shower head (enter or ungroup before). When selecting the shower head the style is shown in the dialog, it's 'Object without fill' as expected, but it has no parent. You can D&D it to be a child of 'Default', then all is okay again.
The reason all styles should have the default parent 'Default' is exactly to have this fallback for saved files, a style without parent is an error. I know no way to create a style that has no parent.
So we need to know two things:
- How was a style without parent created?
- Should styles without parent be corrected at load time?
Comment 3 Armin Le Grand 2013-06-26 10:19:04 UTC
ALG: Grepping.
Comment 4 Rainer Bielefeld 2013-11-03 15:41:58 UTC
Created attachment 81870 [details]
First Sample Document saved again from OOo 3.1.1

I did some tests with Sample document 2013-06-25 07:23 CEST

Already Reproducible with 
* server installation of  " AOO 4.0.0-Dev  – English UI / German locale [AOO400m1(Build:9700) - Rev. 1457992 – Rev.1457606  ((2013-03-19))]" on German WIN7 Home Premium (64bit)", own separate user profile

It seems that very tricky conditions are required to make the problem appear. Saving sample document from 3.1.1 heals the problem (see new attachment).

Saving again form OOo 3.4 will not make reappear the problem
Comment 5 Rainer Bielefeld 2013-11-03 18:08:11 UTC
Found no differences, so DUP of "Bug 122109 - In Documents from OOo (or AOO 3.4) Default Style line color "black" changes to "grey 6""

*** This issue has been marked as a duplicate of issue 122109 ***