Issue 122645 - new and edited files unable to be saved
Summary: new and edited files unable to be saved
Alias: None
Product: General
Classification: Code
Component: ui (show other issues)
Version: 3.4.1
Hardware: PC Windows Vista
: P3 Major (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Keywords: needmoreinfo
Depends on:
Reported: 2013-06-29 21:03 UTC by david.cranch
Modified: 2013-07-02 05:09 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

Multi-page spreadsheet, comprising ledgers and miscellaneous stuff. (182.50 KB, application/octet-stream)
2013-07-01 13:59 UTC, david.cranch
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description david.cranch 2013-06-29 21:03:15 UTC
Attempt to save/save as new Writer and Calc files as [filename] yields message:
"Error saving the document Untitled1:
[pathname][filename] does not exist"
Then clicking OK two times yields message:
"Error saving the document Untitled1:
Write error"
The file could not be written".

Loading, editing, then attempting to save an existing file yields the message:
"Error saving the document [filename]
Write error
The file could not be written"

It appears to make no difference if the format of the attempted save file, or the loaded file, is OpenOffice or Microsoft.
Comment 1 Edwin Sharp 2013-07-01 12:25:41 UTC
Please attach file that can not be saved as.
Comment 2 david.cranch 2013-07-01 13:59:18 UTC
Created attachment 80970 [details]
Multi-page spreadsheet, comprising ledgers and miscellaneous stuff.

After my original post here, I have discovered that I cannot print documents.  The reported errors specify either no installed printer or no default printer.  Printers are obviously installed, and I have ensured there is a default printer.  I can, however, successfully send a test page to a printer.
I mention that as it may indicate some fundamental problem with I/O.
Comment 3 Edwin Sharp 2013-07-01 16:46:50 UTC
Thank you.

Attachment opens and saves OK in Rev. 1491860 Debian.
Attachment prints OK with HP Officejet J6413.

Try to reset use profile:

Please specify printer details and if printing from other applications is OK.
Comment 4 david.cranch 2013-07-01 23:52:28 UTC
Before receiving your last, I ran the System File Checker from  It claimed to find some corrupt files and put them right.  There was no observable change.
Then, as you suggested, I renamed the \user file.  No observable change.
Then I renamed extensions.pmap and extensions (db file).  No observable change.
The printer is a Lexmark X4650 with a wifi connection.  Pretty reliable.
I've noticed different kinds of anomalous printing behaviour and summarise as follows:
1. .doc documents, both those imported by downloading from email and those output by OpenOffice (a) after loading and attempting to print: message "No default printer found.  Please choose a printer and try again."  After choosing, the document printed OK; (b) on right-clicking the filename in IE and clicking 'Print': pop-up window: "Save the file as...".
2. .odt documents (a) attempt to load the file into OpenOffice gives message "Write Error.  The file could not be written".  Nothing appears to happen when the OK is clicked; (b) on right-clicking the filename in IE and clicking 'Print' : nothing appears to happen.
3. attempting to print an email (in gmail) yields an invitation to 'Select printer'.  The only option is Microsoft XPS Document Writer.
I will try to have a look at the profile.
Regards, David
Comment 5 Edwin Sharp 2013-07-02 05:09:38 UTC
Thank you.

Bug confirmed based on similarity to bug 122346.

I suggest roll back to a previous version that worked for you till release of version 4.0 later this month.