Issue 122723 - CRASH when copy paste
Summary: CRASH when copy paste
Status: RESOLVED FIXED
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: 4.0.0-dev
Hardware: PC Windows 7
: P3 Major (vote)
Target Milestone: 4.0.0
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-07-11 15:10 UTC by Rainer Bielefeld
Modified: 2013-07-11 16:43 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Sample Document (14.84 KB, text/plain)
2013-07-11 15:10 UTC, Rainer Bielefeld
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Rainer Bielefeld 2013-07-11 15:10:57 UTC
Created attachment 81050 [details]
Sample Document

Steps how to reproduce with  "AOO 4.0.0-Dev – English UI / German locale -  AOO400m3(Build:9702)  -  Rev. 1499347  2013-07-08]" on WIN7 Home Premium (64bit)", own separate user profile:

1. Open attached document from AOO Start Center
2. In section "Bereich4" click before word "Auftragsdatum"
   > Caret flashes before word
3. <Shift+Click> behind variable "Lieferjahr" at end of section
   > All variables definition area selectec
4. <Control+C> for 'Copy'
5. <Control+V> for 'Paste'
   CRASH (or at least AOO stops responding)

This problem is not reproducible with all my dev versions, for example works fine with  "AOO 4.0.0-Dev – German UI / locale [AOO400m2(Build:9701)  -  AOO400m2(Build:9701)  -  Rev. 1497734 Rev.1496828  2013-06-28]" on WIN7 Home Premium (64bit)", Common 4.0-dev User Profile
Comment 1 Armin Le Grand 2013-07-11 15:31:03 UTC
ALG: Could not reproduce on fresh pro build of AOO400 branch on rev 1501717, after paste (no selection change done between (4) and (5)) all is as expected - as before.
Comment 2 Rainer Bielefeld 2013-07-11 15:37:02 UTC
No Crash with 3.4.1, so REGRESSION

I will try latest build ASAP
Comment 3 Rainer Bielefeld 2013-07-11 16:43:10 UTC
So it is, no longer reproducible with  "AOO 4.0.0-Dev – German UI / German locale  [AOO400m3(Build:9702)  -  Rev. 1502004]" on WIN7 Home Premium (64bit)", Common 4.0-dev User Profile.

So I close this one