Issue 122765 - %WRITERCOMPATIBILITYVERSIONOOO11 is not replaced in help file
Summary: %WRITERCOMPATIBILITYVERSIONOOO11 is not replaced in help file
Status: RESOLVED FIXED
Alias: None
Product: Writer
Classification: Application
Component: help (show other issues)
Version: 4.0.0-dev
Hardware: All All
: P3 Normal (vote)
Target Milestone: 4.1.11
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
: 59796 124909 (view as issue list)
Depends on:
Blocks:
 
Reported: 2013-07-17 06:46 UTC by hanya
Modified: 2021-05-30 00:37 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: 4.1.10
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description hanya 2013-07-17 06:46:33 UTC
%WRITERCOMPATIBILITYVERSIONOOO11 word is shown in 
Compatibility page of Writer's help file.

No replacement is there for %WRITERCOMPATIBILITYVERSIONOOO11 in main_transform.xsl.
Comment 1 Matthias Seidel 2020-06-01 18:47:55 UTC
*** Issue 124909 has been marked as a duplicate of this issue. ***
Comment 2 Matthias Seidel 2021-05-25 12:45:47 UTC
Fixed in trunk with:
https://github.com/apache/openoffice/commit/d41ee0266177f78402fcbaf77c4dd09e31710b40

Cherry-picked for AOO42X with:
https://github.com/apache/openoffice/commit/0d0a8a7e47d7b2e4f88e85a81bef1ed1bf222b87

Normally, we should get WRITERCOMPATIBILITYVERSIONOOO11 from
/main/instsetoo_native/util/openoffice.lst

But this hasn't changed in years, so I decided to replace it with a fixed string for now.

Credits go to Czesław Wolański for his valuable hint.
Comment 3 Matthias Seidel 2021-05-25 13:23:15 UTC
Cherry-picked for AOO41X.
Comment 4 Matthias Seidel 2021-05-30 00:37:06 UTC
*** Issue 59796 has been marked as a duplicate of this issue. ***