Issue 122780 - FREEZE when Click 'Insert Section -> Insert' dialog is incorrectly activated by 'Edit -> paste'
Summary: FREEZE when Click 'Insert Section -> Insert' dialog is incorrectly activated ...
Alias: None
Product: General
Classification: Code
Component: ui (show other issues)
Version: 4.0.0-dev
Hardware: Mac Mac OS X, all
: P3 Major (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Keywords: needmoreinfo
Depends on:
Reported: 2013-07-18 10:02 UTC by fanyuzhen
Modified: 2014-05-27 10:03 UTC (History)
10 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---
jsc: 4.0.0_release_blocker-


Note You need to log in before you can comment on or make changes to this issue.
Description fanyuzhen 2013-07-18 10:02:26 UTC
1. Open Writer
2. Click menu Edit -> Paste(it is enabled incorrectly)

Actual result: it pops up Insert Section dialog, when click "Insert", it is hung
Expected result: menu Edit -> Paste( is disabled as default

1. I reproduce it several times in both RC1, revision 1502185  on Windows and RC2, revision 1503704 on Mac, but I cannot always reproduce it.
2. Document this issue in Bugzilla, if any one can reproduce it every time, please help to update exact steps.
Comment 1 jsc 2013-07-18 10:59:31 UTC
I tried it with RC 2 on Mac and can't reproduce this. In general it is valid to have paste enabled when the clipboard is filled. In my test case the text from the clipboard  is pasted in my new document and everything is fine.

It probably depends on what you have in the clipboard and we need further information but I don't think it is a showstopper.

But I am willing to change the showstopper flag if we come to the conclusion that it is a serious and reproducable problem
Comment 2 jsc 2013-07-18 11:01:57 UTC
can't reproduce with the given information
Comment 3 Armin Le Grand 2013-07-18 12:10:15 UTC
ALG: Tried on mac RC2, could not reproduce, also a little bit unclear what to do. From what I understood I tried:
- copy something from a nother app to clipboard
- start AOO4 RC2, new Writer
- menu Edit/paste
-> clipboard content gets inserted as expected, no errors, no hang.
Comment 4 Armin Le Grand 2013-07-18 12:18:18 UTC
ALG: Same on Linux: Could not reproduce.
Comment 5 Raphael Bircher 2013-07-18 12:57:46 UTC
Hi at all

I'm not able at the moment to reproduce it. But I woudn't give up so easy. If I click paste on RC2 whithout have same content in the clipbord, nothing happend. If I have samething in the clipbord, it works correct.

Mac OS 10.7

Greetings Raphael
Comment 6 papayes 2013-07-18 16:04:25 UTC
RC2 with MacOsX 10.8.4 

can't reproduce with the given information

AOO 400 rev. 1503704 (2013-07-16)
The RC1 version was deleted. 
Installed  with ctrl pushed and right click > Enter on  ""
Tested with or without the personal file in "Application Support"

Tested with Copy of image .pnp, text, graph
and Menu : Edit > Paste 
on a New Writer or 
or in old Writer

No problem.
Comment 7 tintin60 2013-07-18 19:02:32 UTC

MacIntel 10.6.8
AOO 400m3 Build-9702 - Rev. 1503704
Can't reproduce, neither by right clic > Paste nor Edit > Paste (Text or picture).

Comment 8 Steve Yin 2013-07-24 09:07:10 UTC
Reproducible issue:

The menu items "Paste" and "Paste Special..." are enabled even the system clipboard is empty.

I did some investigation and found 2 possible reasons now:

1. The Mac system clipboard may contains some content's format information, but no real content. In such case, the functions "IsPasteAllowed" and "IsPasteSpecialAllowed" will get "true" return values.
2. The menu items "Paste" and "Paste Special..." cannot be disabled on Mac.
Comment 9 edoardopanfili 2013-07-25 11:33:24 UTC
OS X 10.8.4
AOO400m3(Build:9702)  -  Rev. 1503704
2013-07-16 14:51:10 (Tue, 16 Jul 2013)

1- start up the mac
2- open openoffice
3- open writer from startup dialog

"Paste" and "paste special" are enabled but if I click on both nothing happens (this is correct, the clipboard is empty).
Comment 10 Rainer Bielefeld 2014-05-26 17:47:37 UTC
NOT reproducible with  server installation of "AOO 4.0.0 Final – German UI / German locale - [AOO400m3(Build:9702) - Rev. 1505643 2013-07-23]" on German WIN7 Home Premium (64bit)", own separate user profile: 'Edit -> Paste (Special)' not active with empty clipboard.

S(a) till a problem for you?
(b) Why do your think "it is enabled incorrectly" in step 2? Because you 
    launched AOO directly after Mac has booted?
(c) How did you check that clipboard really is empty?
(d) did you check with blank new user profile?
Comment 11 Rainer Bielefeld 2014-05-26 17:52:02 UTC
Reduced importance because not many users seem to be affected
Comment 12 papayes 2014-05-27 10:03:46 UTC
osX 10.9.3 and AOO 4.1.0
Still not reproduced,
but is that is installed?
and its contents are emptied it?
It could contain a corrupt element that would cause the problem.