Issue 122921 - Old Impress files cannot be edited in Impress 4.0.0
Summary: Old Impress files cannot be edited in Impress 4.0.0
Status: CLOSED DUPLICATE of issue 123003
Alias: None
Product: Impress
Classification: Application
Component: editing (show other issues)
Version: 4.0.0
Hardware: PC All
: P3 Major (vote)
Target Milestone: ---
Assignee: Armin Le Grand
QA Contact:
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-07-31 22:34 UTC by Steve Cooper
Modified: 2017-05-20 10:06 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Sample Impress document to demonstrate text selection bug (17.64 KB, application/vnd.oasis.opendocument.presentation)
2013-07-31 22:34 UTC, Steve Cooper
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Steve Cooper 2013-07-31 22:34:53 UTC
Created attachment 81223 [details]
Sample Impress document to demonstrate text selection bug

Impress 4.0.0 appears to have a serious bug in text selection when working with old Impress files.

A sample file that demonstrates the bug is attached. I'm not sure which version of Impress originally created this file, but it was probably 2.0 or earlier.

Try selecting any of the text on the slide. Impress starts to select the text, but then quickly deselects it. Selecting with the mouse or with the keyboard has the same problem.

Strangely, even text boxes newly created in this document have the same problem.

The text selection works without problem on Impress 3.4.1.

The bug has been confirmed on Windows 7 64-bit and Windows XP 32-bit.

I tried saving a copy of the file, thinking that might cause Impress to update the file type. That had no effect. 

However, I tried another save technique, which did produce results: Save the file as "MS Powerpoint 97/2000/XP (.ppt)", but then choose to "Keep Current Format". This produces a .ppt file whose text can be edited without problem.

However, due to the imperfect conversion from .odp to .ppt format (?), the .ppt file's layout differs from the original .odp just enough to cause text flow/layout problems. (This is not exhibited in the attached file, but occurs in larger files I am dealing with.)
Comment 1 Ariel Constenla-Haile 2013-07-31 22:48:23 UTC
Confirmed on Linux 64 bit

Workaround: select all slides on the left Slide Pane, and drag them to another new Impress document.
Comment 2 Armin Le Grand 2013-08-29 16:33:04 UTC
ALG: Probably double to #123003#
Comment 3 Armin Le Grand 2013-09-03 10:39:57 UTC
ALG: Corrected owner
Comment 4 Armin Le Grand 2013-09-04 13:21:23 UTC
ALG: Setting to duplicate

*** This issue has been marked as a duplicate of issue 123003 ***