Issue 123192 - Word Count Dialog: last digit truncated at the right
Summary: Word Count Dialog: last digit truncated at the right
Status: RESOLVED FIXED
Alias: None
Product: Writer
Classification: Application
Component: ui (show other issues)
Version: 4.0.1-dev
Hardware: All Windows, all
: P3 Minor with 1 vote (vote)
Target Milestone: 4.1.8
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
: 127363 (view as issue list)
Depends on:
Blocks:
 
Reported: 2013-09-05 16:56 UTC by Akriti
Modified: 2019-10-20 16:30 UTC (History)
12 users (show)

See Also:
Issue Type: PATCH
Latest Confirmation in: 4.1.7
Developer Difficulty: ---


Attachments
word count screenshot (467.74 KB, image/jpeg)
2013-09-08 07:06 UTC, Edwin Sharp
no flags Details
win8 (191.73 KB, image/png)
2013-09-13 15:11 UTC, Akriti
no flags Details
Word Count Screenshot on Windows 8, 7, and XP (229.90 KB, image/jpeg)
2013-09-25 01:21 UTC, Krissada Dechokul
no flags Details
Proposed patch to avoid increment Right position for right aligned (847 bytes, patch)
2014-01-31 12:08 UTC, hanya
no flags Details | Diff
Word Count Screenshot on Windows 10 (5.17 KB, image/png)
2018-12-01 12:50 UTC, Matthias Seidel
no flags Details
Word Count Screenshot on Windows 10 with patch (5.27 KB, image/png)
2018-12-02 11:11 UTC, Matthias Seidel
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Akriti 2013-09-05 16:56:16 UTC
Open Writer-> Enter a some lines of text. Goto Tools-> Select Word Count option.
Its observed that the last digit of the count number is slightly cut from the right side
Comment 1 Edwin Sharp 2013-09-08 07:06:51 UTC
Created attachment 81477 [details]
word count screenshot
Comment 2 Edwin Sharp 2013-09-08 07:07:28 UTC
Can not reproduce.

Rev. 1520602 Win 7
Comment 3 Akriti 2013-09-13 15:11:15 UTC
Created attachment 81537 [details]
win8
Comment 4 Akriti 2013-09-13 15:12:02 UTC
Defect is reproducible in r1521921 WIN 8
Comment 5 Shenfeng Liu 2013-09-23 14:23:54 UTC
I confirmed on my Win 7 and Win 8. It looks like that 1 column of the pixels are cut out.
Comment 6 Krissada Dechokul 2013-09-25 01:21:28 UTC
Created attachment 81641 [details]
Word Count Screenshot on Windows 8, 7, and XP

Summary: I successfully replicated this bug on Windows 8 Professional (Build 9200), but not on Windows 7 Professional (Build 7601: Service Pack 1) or Windows XP Pro (Build 2600: Service Pack 3).

I replicated this bug using OpenOffice version 4.0.1-dev [branch AOO401 (rev 1523756)] on Windows 8 Professional.

Below are the steps that I took:
1. Open the OpenOffice Writer
2. Add some text into the document
3. Select the text
4. Go to the Tools menu, then select Word Count option

I attempted the same steps on both Windows 7 Pro and Windows XP Pro, however, both were displaying the word count correctly (no problem). Please see the attachment.

Note: Word Count is probably a function that people would use frequently and a lot of users would probably already have Windows 8 installed on their machine. It would be pretty annoying for users to see this error repeatedly every time they use this function. So fixing this bug is desirable.
Comment 7 Rainer Bielefeld 2014-01-20 17:51:39 UTC
Reproducible with "AOO 4.0.1   – German UI / German locale  [Rev. 1524958 2013-09-20 11:40:29]" on  German WIN7 Home Premium (64bit)", “historic”  4.0  User Profile used for all  predecessor versions

Additional info:
----------------
(a) problem does not depend on menu 'Tools -> Options -> View -> Scale'
(b) I did not any other AOO setting what can heal that problem, but might be
    related to OS scale settings or system font or whatever
Comment 8 Rainer Bielefeld 2014-01-20 18:28:53 UTC
(c) I tried WIN System-Settings view
    * 100%
    * 125% (my normal setting)
    * 150%
   I think that the problem is a little more visible with 100% and a little less
   with 150%, but that was a very small effect.
Comment 9 Rainer Bielefeld 2014-01-20 18:53:29 UTC
(d) For me that started with sever installation of "OOo 3.3.0 English UI /
   German locale [OOO330m20 (Build 9567)]" on WIN7  Home Premium  (64bit) DE 
(e) was still ok with sever installation of "OOo 3.2.1 English UI /
    German locale [OOO320m18 (Build 9502)]" on WIN7 Home Premium  (64bit) DE 
(f)  Already reproducible with  Pre-3.4.0 (OOo 3.3.0), but because of crippled  
     Version selector (Bug 123063) no useful info can be contributed
Comment 10 hanya 2014-01-25 16:25:30 UTC
This truncation is happen if the fixed text control is aligned to right. 
Make a label on the dialog editor, input "W" or "0" as label, 
they are truncated if right aligned. Thin character such as 1 or l looks not 
truncated but the spacing at the end of the right side might be bad.
The same happen on Xubuntu 12.04 Xfce 4.10 and AOO 4.0.1.
Comment 11 hanya 2014-01-31 08:53:30 UTC
When I compared rectangle of the control and the calculated area for the text aligned to right 
as Rectangle value in Control::DrawControlText method, 
Right value of the calculate text area is 1px larger than the Right value of the control.
At the end of OutputDevice::GetTextRect method, Right value is incremented in 
the following line: 
> aRect.Right()++; // #99188# get rid of rounding problems when using this rect later
This should not done for right aligned text it seems. 
#99188# seems not match with the current issue number.
Comment 12 hanya 2014-01-31 12:08:33 UTC
Created attachment 82449 [details]
Proposed patch to avoid increment Right position for right aligned

The line to increment Right position can be merged in the above part to 
calculate Right position for each alignments.
Comment 13 Andrea Pescetti 2014-03-16 21:04:51 UTC
For the record, I can't reproduce the problem either before of after hanya's patch on Linux. So some developers using Windows should verify and commit the patch.
Comment 14 Prashant L Rao 2015-01-14 12:43:53 UTC
This problem still exists in OpenOffice 4.1.1 on Windows 8.1.
Comment 15 oooforum (fr) 2017-05-04 15:23:58 UTC
*** Issue 127363 has been marked as a duplicate of this issue. ***
Comment 16 Matthias Seidel 2018-12-01 12:50:25 UTC
Created attachment 86556 [details]
Word Count Screenshot on Windows 10
Comment 17 Matthias Seidel 2018-12-02 11:11:09 UTC
Created attachment 86559 [details]
Word Count Screenshot on Windows 10 with patch
Comment 18 Matthias Seidel 2018-12-02 11:36:30 UTC
Fixed in r1847988:

i123192 - Word Count Dialog: last digit truncated at the right

Patch by: hanya

Thank you for your contribution!
Comment 19 Matthias Seidel 2019-10-19 10:26:37 UTC
Committed to AOO418 with:

580337070b8e737894370d6796856e30ebef7361
Comment 20 Marcus 2019-10-20 16:30:46 UTC
Changed milestone due to comment #19