Issue 123409 - Images in background cause crash when saving to pdf/a
Summary: Images in background cause crash when saving to pdf/a
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: save-export (show other issues)
Version: 4.0.0
Hardware: All All
: P3 Normal (vote)
Target Milestone: 4.1.0
Assignee: hdu@apache.org
QA Contact: Clarence GUO
URL:
Keywords:
: 122928 123452 123486 124660 (view as issue list)
Depends on:
Blocks:
 
Reported: 2013-10-02 13:47 UTC by potassium19
Modified: 2014-04-11 09:18 UTC (History)
11 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: 4.0.1
Developer Difficulty: ---


Attachments
Document (192.51 KB, application/vnd.oasis.opendocument.text)
2013-10-03 18:59 UTC, potassium19
no flags Details
Image (180.62 KB, image/jpeg)
2013-10-03 19:01 UTC, potassium19
no flags Details
reduced bugdoc (20.51 KB, application/vnd.oasis.opendocument.text)
2013-10-04 10:17 UTC, hdu@apache.org
no flags Details
check whether the search actually found anything (663 bytes, patch)
2013-10-04 10:18 UTC, hdu@apache.org
orw: review+
Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description potassium19 2013-10-02 13:47:45 UTC
When saving a document to pdf format, the program stopped responding, and Windows automatically closed it. I found the cause to be an image which I had set to background arragement. When I changed the arrangement, the file saved.

A similar problem on LINUX systems was reported. Here is the link if it helps:
https://issues.apache.org/ooo/show_bug.cgi?id=121088
Comment 1 Edwin Sharp 2013-10-03 18:22:21 UTC
Format - Page... - Background - As Graphic
Export Directly as PDF
No crash

AOO401m5(Build:9714)  -  Rev. 1523756
2013-09-16 20:50:21 (Mo, 16 Sep 2013)
Win 7
Comment 2 potassium19 2013-10-03 18:57:35 UTC
My apologies - it's not the arrangement, it's the wrap.
When I right click on the image, and select Wrap>In Background, it then crashes when I save to pdf.
I will attach a couple of files, if that helps.
Comment 3 potassium19 2013-10-03 18:59:55 UTC
Created attachment 81695 [details]
Document

An example document which does not save as pdf
Comment 4 potassium19 2013-10-03 19:01:02 UTC
Created attachment 81696 [details]
Image

THis is the Image I attached. The problem seems to occur regardless of image file format, however.
Comment 5 Edwin Sharp 2013-10-03 19:04:31 UTC
Thank you.
Still no crash.
Comment 6 Prosper Uniger 2013-10-03 22:11:36 UTC
steps to reproduce:
* open new writer file
* insert image (tried .jpg, .png and .wmf)
* select image
* right click, wrap - to background
* export as pdf
* select "PDF/A-1a"
* export

-> crash

AOO401m5(Build:9714)  -  Rev. 1524958
2013-09-20 11:40:29 (Fr, 20 Sep 2013)
Windows Vista

please change status
Comment 7 potassium19 2013-10-03 22:25:24 UTC
(In reply to Prosper Uniger from comment #6)
Thanks for checking that. I'm new here, so what status should it be?
Comment 8 Edwin Sharp 2013-10-04 07:11:14 UTC
Thank you Prosper for clarifying.
Now crash.
Comment 9 hdu@apache.org 2013-10-04 10:17:04 UTC
Created attachment 81698 [details]
reduced bugdoc
Comment 10 hdu@apache.org 2013-10-04 10:18:23 UTC
Created attachment 81699 [details]
check whether the search actually found anything
Comment 11 hdu@apache.org 2013-10-10 07:19:40 UTC
*** Issue 123452 has been marked as a duplicate of this issue. ***
Comment 12 hdu@apache.org 2013-10-10 07:27:27 UTC
*** Issue 122928 has been marked as a duplicate of this issue. ***
Comment 13 Oliver-Rainer Wittmann 2013-10-10 09:10:15 UTC
I reproduced the crash in AOO 4.0.0 and AOO 4.0.1, but not in AOO 3.4.1, AOO 3.4.0 and OOo 3.2.0.

It looks like that <rFrmTagIdMap> is not filled as expected.
Herbert and myself assume that this was already the case in former OpenOffice versions, but due to the used stlport the access to the invalid iterator does not cause a crash.
Comment 14 Oliver-Rainer Wittmann 2013-10-10 09:15:23 UTC
Comment on attachment 81699 [details]
check whether the search actually found anything

reviewed
--> approving suggested fix.
Comment 15 SVN Robot 2013-10-10 09:20:38 UTC
"hdu" committed SVN revision 1530891 into trunk:
#i123409# prevent invalid iterator dereference in SwTaggedPDFHelper::CheckReo...
Comment 16 hdu@apache.org 2013-10-10 09:24:06 UTC
Fixed with the commit above. Thanks for finding and isolating the bug and for reviewing my patch suggestion.
Comment 17 Armin Le Grand 2013-10-11 10:19:50 UTC
ALG: Checked with fresh  Rev. 1530891, works well, is fixed.
Comment 18 Oliver-Rainer Wittmann 2013-10-11 10:31:24 UTC
revert Armin's field changes.
Comment 19 Ariel Constenla-Haile 2013-10-16 16:46:19 UTC
*** Issue 123486 has been marked as a duplicate of this issue. ***
Comment 20 Clarence GUO 2014-02-27 09:34:23 UTC
Verified on AOO Rev 1571942 en-US, no crash now, so change the status to verified
Test ENV: Win7 professional 64 bit SP1, Chinese version.
Comment 21 Clarence GUO 2014-04-03 05:17:14 UTC
Verified with trunk build Rev. 1582712, fixed.
Comment 22 Oliver-Rainer Wittmann 2014-04-11 09:18:58 UTC
*** Issue 124660 has been marked as a duplicate of this issue. ***