Issue 123486 - Export to PDF/A-1A crash
Summary: Export to PDF/A-1A crash
Status: CLOSED DUPLICATE of issue 123409
Alias: None
Product: Writer
Classification: Application
Component: save-export (show other issues)
Version: 4.0.1
Hardware: PC Windows, all
: P3 Critical (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-10-16 15:40 UTC by riccardo.arzenton
Modified: 2013-10-16 16:46 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
File that crash if you try to export in PDF/A-1A (23.50 KB, application/msword)
2013-10-16 15:40 UTC, riccardo.arzenton
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description riccardo.arzenton 2013-10-16 15:40:51 UTC
Created attachment 81773 [details]
File that crash if you try to export in PDF/A-1A

If you try to export to PDF/A-1A the attached document, openoffice crashes inesorably.


I think that the problem is in the first frame, the one where you find the text "il Direttore generale all’organizzazione, 
personale, sistemi informativi e telematica
MARIO ROSSI"

If you delete that frame, exporting to PDF/A-1A does not crash.

I have lots of document similar to this one and in my company we MUST export to PDF/A-1A Standard.


There is a particular property of that frame that mess with OpenOffice?
What do you suggest for fixing this issue?

Thanks in advance
Comment 1 jsc 2013-10-16 15:47:34 UTC
I tried to reproduce on MacOS with the released AOO 4.0.1 version.

load the attached sample file -> export to PDF/A-1a -> no crash

Can't reproduce on MacOS
Comment 2 jsc 2013-10-16 15:48:30 UTC
on which platform are you working? Provide as much as possible information when you submit bugs.
Comment 3 riccardo.arzenton 2013-10-16 15:50:12 UTC
The bug is on Win7 and XP.

I have not tried on Mac or Linux.
Comment 4 Ariel Constenla-Haile 2013-10-16 16:25:31 UTC
This might be duplicated of Bug 123409

@riccardo: If you check "PDF/A-1a", it will crash (because this option also checkes "Tagged PDF").
In order to avoid the crash:
a) make sure "PDF/A-1a" is NOT checked
b) make sure "Tagged PDF" is NOT checked

Does this avoid your crash?
Comment 5 Ariel Constenla-Haile 2013-10-16 16:46:19 UTC
(In reply to Ariel Constenla-Haile from comment #4)
> This might be duplicated of Bug 123409

yes, it is.

> @riccardo: If you check "PDF/A-1a", it will crash (because this option also
> checkes "Tagged PDF").
> In order to avoid the crash:
> a) make sure "PDF/A-1a" is NOT checked
> b) make sure "Tagged PDF" is NOT checked
> 
> Does this avoid your crash?

Yes, it does.

*** This issue has been marked as a duplicate of issue 123409 ***