Issue 123497 - Color Palette Modify Button - does not save modifications
Summary: Color Palette Modify Button - does not save modifications
Alias: None
Product: General
Classification: Code
Component: ui (show other issues)
Version: 4.0.1
Hardware: PC Windows 8, 8.1
: P3 Major (vote)
Target Milestone: 4.1.0
Assignee: Armin Le Grand
QA Contact:
Keywords: regression
Depends on:
Reported: 2013-10-19 00:07 UTC by GurOOo
Modified: 2017-05-20 10:35 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Note You need to log in before you can comment on or make changes to this issue.
Description GurOOo 2013-10-19 00:07:18 UTC
To view defect using Writer:
01)  Open or start new document.
02)  Add shape (square, circle, etc.)
03)  Right-click on shape
04)  Select 'Area...'
05)  Left-click on 'Colors' tab
06)  Left-click any color on grid 
     (i.e. Black - R:000 G:000 B:000)
07)  Change the color using the RGB selectors 
     at the right (i.e. Red - R:255 G:100 B:100)
08)  Left-click the 'Modify' button
     Note that the color on the grid 
     indicates that it has been modified
09)  Left-click the 'OK' button at the bottom
     of the dialog window

ERROR message window appears:
   The color was modified without saving.
   Modify the selected color or add a new color.
      [ Modify ]   [  Add  ]   [ Cancel ]

10)  Left-click the 'Modify' button.
     Note that upon returning to the document,
     the shape color is the unmodified color.

Returning to the Area > Color section shows the color on the grid has not being modified.

Modifying the name does fine.
When modifying the name and color, only the name is modified.

Going to 'Tools' > 'Options' > 'Colors' without using the shape/area interface results in the same bug but without the error message.

'Add' does save both a new name and color but the color cannot be modified once it has been added.

Due to physical limitations, modifying the .soc file is not an option.

Hope this helps.  Screen shots, though not likely needed, are available upon request.
Comment 1 kellybellis 2013-10-19 08:53:43 UTC
Nice report - and I can confirm this in OO v4.0.1, , it's been driving me crazy! 

Only recourse is to delete / create separately named new color.

In earlier posts, tutorials, wikis, etc., there was shown an open folder and save icon - where did they go? Having them available makes perfect sense; removing them doesn't. Please consider returning the options to save and import palettes.

Particulars on build:
AOO401m5(Build:9714)  -  Rev. 1524958
2013-09-20 11:40:29 (Fr, 20 Sep 2013)
Comment 2 Regina Henschel 2013-10-19 12:45:11 UTC
The error can be seen in the other modules and in Tools>Options>OpenOffice>Colors as well. Modifying worked in OOo3.4.1
Comment 3 Regina Henschel 2013-10-19 13:07:19 UTC
With a little search in my builds I find:
It is OK in r1476029.
It fails in r1481886.

r1481886 is a debug build here and it shows the errors:

Error: libxml2 error
Document is empty
Line: 1
Column: 1 From File c:/AOO_2013_05_10/trunk/main/unoxml/source/dom/documentbuilder.cxx at Line 303

Error: libxml2 error
Start tag expected, '<' not found
Line: 1
Column: 1 From File c:/AOO_2013_05_10/trunk/main/unoxml/source/dom/documentbuilder.cxx at Line 303

But I don't know, whether that is related to this issue.

All on Windows 7.
Comment 4 Regina Henschel 2013-10-19 13:50:26 UTC
Modifications on self-made bitmaps are not stored too. Modifications on gradients are stored, no error there.
Comment 5 Armin Le Grand 2013-10-25 11:44:14 UTC
ALG: Somehow the change gets lost, checking...
Comment 6 Armin Le Grand 2013-10-25 11:52:06 UTC
ALG: Indeed the bitmap pattern editor exchanges fg/bg colors each time it gets chnaged (even when saying OK without change, but not when saying cancel). STrange, looks as if save and init use colors differently (there are only two anyways, but these get exchanged)...
Comment 7 Armin Le Grand 2013-10-25 15:58:50 UTC
ALG: Checked the code and found that this was wrong for Bitmap, Color and LineEnd. In all cases, the 'modify' functionality did modify all UI stuff, but not the entry in the corresponding XPropertyList. Interestingly this is done for gradients and hatches. The whole mechanism with XPropertyList/XPropertyEntry needs more rework.
Checking if I found the correct errors...
Comment 8 Armin Le Grand 2013-10-25 16:23:13 UTC
ALG: Okay, found correct problems, checked that these are solved.

@Regina: Maybe we need an own error for the bitmap pattern thingy, better than to mit with this one, what do you think?
Comment 9 Regina Henschel 2013-10-28 08:44:53 UTC
I have created bug 123564 for the wrong colors in the foreground and background list.

Modifying works correctly now in r1535772.

BTW: I wonder, why the commit r1535772 was not reflected to this issue.
Comment 10 Armin Le Grand 2013-10-28 09:48:07 UTC
ALG: Herbert may know, setting him on CC...
@Herbert: The commit was not added to this task, you are the magic man for this...
Comment 11 2013-10-28 15:41:05 UTC
(In reply to Armin Le Grand from comment #10)
> @Herbert: The commit was not added to this task, you are the magic man for
> this...

The svnbot sees a "<ProtocolError for 500 Internal Server Error>", which is probably related to the recent bugzilla update to 4.4.1...
Comment 12 SVN Robot 2013-10-29 08:14:58 UTC
"alg" committed SVN revision 1535772 into trunk:
i123497 corrected modify implementations for bitmap, lineend and color
svnbz message delay caused by perl problems after Bugzilla 4.4.1 update
Comment 13 liuping 2014-02-26 06:55:22 UTC
verify AOO410m1(Build:9750)  -  Rev. 1570848
Rev.1570848 on windows7 ,pass