Issue 123795 - variable names should not confuse vcl Windows and cocoa NSWindows
Summary: variable names should not confuse vcl Windows and cocoa NSWindows
Alias: None
Product: General
Classification: Code
Component: code (show other issues)
Version: 3.4.0
Hardware: All Mac OS X, all
: P4 Normal (vote)
Target Milestone: 4.1.0
QA Contact:
Depends on:
Reported: 2013-12-02 15:58 UTC by
Modified: 2014-02-06 15:05 UTC (History)
1 user (show)

See Also:
Issue Type: TASK
Latest Confirmation in: ---
Developer Difficulty: ---


Note You need to log in before you can comment on or make changes to this issue.
Description 2013-12-02 15:58:31 UTC
VCL's Window type and Cocoa's NSWindow type are quite different. Naming variables as if they were the same introduces gratuitous complexity for debugging stacks where the different types are both used. This should be cleaned up. The naming of variables of the related NSView type should be adjusted too.
Comment 1 SVN Robot 2013-12-02 16:10:30 UTC
"hdu" committed SVN revision 1547078 into trunk:
#i123795# variable names should not confuse vcl Window and cocoa NSWindow types
Comment 2 2013-12-02 16:12:38 UTC
Fixed with the commit above.
Comment 3 SVN Robot 2014-02-06 14:14:28 UTC
"hdu" committed SVN revision 1565258 into trunk:
#i123795# add a windowForParent() method for AquaA11yWrapper
Comment 4 SVN Robot 2014-02-06 15:05:55 UTC
"hdu" committed SVN revision 1565295 into trunk:
#i123795# amend r1565258's commit with its missing part