Issue 123855 - Small Greek symbols start with capital letter, but should be all small letters, as in English
Summary: Small Greek symbols start with capital letter, but should be all small letter...
Status: CLOSED FIXED
Alias: None
Product: Native-Lang
Classification: NLC
Component: de (show other issues)
Version: 4.0.1
Hardware: PC Windows, all
: P3 Normal
Target Milestone: 4.2.0
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-14 17:28 UTC by Regina Henschel
Modified: 2018-12-01 15:54 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: 4.1.0-dev
Developer Difficulty: Simple


Attachments
Screenshots with comments (188.13 KB, application/vnd.oasis.opendocument.graphics)
2013-12-16 06:02 UTC, Rainer Bielefeld
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Regina Henschel 2013-12-14 17:28:17 UTC
In Math the English strings for small Greek letters have all small letters. The German translation has put the first letter in capital. But they should be in small letters too, as it has been from the beginning of OpenOffice.

The error was introduced around June 2013.
Comment 1 Rainer Bielefeld 2013-12-16 06:00:55 UTC
(a) Reproducible with "AOO 4.0.1   – German UI / German locale  [Rev. 1524958 2013-09-20 11:40:29]" on  German WIN7 Home Premium (64bit)", “historic”  4.0  User Profile used for all  predecessor versions

(b) NOT reproducible with  "AOO 4.0.1 – Swedish UI / German locale  [AOO401m3(Build:9712)  -  Rev. 1520285 2013-09-05 13:52:01]" on German German WIN7 Home Premium (64bit)", Common 4.0-dev User Profile

(c) still worked fine with sever installation of  "AOO 4.0.0-Dev – German UI / German locale - [AAOO400m3(Build:9702)  -  Rev. 1513120  2013-08-13]" on German WIN7 Home Premium (64bit)", own separate user profile. So the problem might have been introduced some later than Regina thinks.

(d) not only a blemish, "%Gamma" works and will be shown as Greek letter,
    "%gamma" shown as "%gamma" in fromula.

(e) works fine with 4.0.1 RC3 SV and FR User Interface, what might indicate that
    the problem is "German only".

(f) Still Reproducible with server installation of "AOO 4.1.0-Dev – 
    German  UI / German locale - [AOO410m1(Build:9750)  -  Rev. 1537508 - 
    2013-11-02]" on German WIN7 Home Premium (64bit)", own separate user profile.
Comment 2 Rainer Bielefeld 2013-12-16 06:02:17 UTC
Created attachment 82107 [details]
Screenshots with comments
Comment 3 Rainer Bielefeld 2013-12-16 09:22:05 UTC
(g) Good news, no interoperability problems between languages, German
    Language Formulas can be opened with English UI AOO and vice versa
Comment 4 jsc 2014-03-05 11:03:10 UTC
yes it is changed in the German translation.

See Pootle https://translate.apache.org/de/aoo40/translate/starmath/#search=RID_UI_SYMBOL_NAMES&sfields=source,target,locations

I suggest that somebody review the translation on Pootle for the next translation update
Comment 5 Mechtilde 2018-12-01 15:54:15 UTC
the last translation is in the code now
Comment 6 Mechtilde 2018-12-01 15:54:33 UTC
=> closed