Issue 123864 - Add MacOS version check to verify dependencies before using/installing the office or language pack
Summary: Add MacOS version check to verify dependencies before using/installing the of...
Status: CLOSED FIXED
Alias: None
Product: Installation
Classification: Application
Component: code (show other issues)
Version: 4.1.0-dev
Hardware: All Mac OS X, all
: P3 Normal (vote)
Target Milestone: 4.1.0
Assignee: jsc
QA Contact:
URL:
Keywords:
Depends on:
Blocks: 122301
  Show dependency tree
 
Reported: 2013-12-16 15:39 UTC by jsc
Modified: 2017-05-20 10:35 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Screenshot of MacOS version check (65.92 KB, image/png)
2013-12-16 15:39 UTC, jsc
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description jsc 2013-12-16 15:39:49 UTC
Created attachment 82113 [details]
Screenshot of MacOS version check

Starting with AOO 4.1 we will support only MacOS 10.7 or newer because of a new dependency to a libc++ that was introduced with 10.7 first.

To avoid confusion by our users who try to run this version on older versions we add a system version check that informs the user before the office is installed or executed. The same check is added for language packs.

See for example the attached screenshot how the notification will look like. But keep in mind that we will finally check against version 10.7.0 and not 10.8.0 as in this screenshot. This was only used to check the feature on local 10.7 system.
Comment 1 SVN Robot 2013-12-17 14:31:28 UTC
"jsc" committed SVN revision 1551548 into branches/rejuvenate01:
#123864# add os version check
Comment 2 jsc 2013-12-17 14:33:07 UTC
fixed on related branch
Comment 3 Oliver-Rainer Wittmann 2014-02-10 11:51:57 UTC
@Jürgen, Herbert: Has the fix been integrated into trunk?
Comment 4 SVN Robot 2014-02-10 12:12:21 UTC
"hdu" committed SVN revision 1566588 into trunk:
#123864# add version check for OSX 10.7