Issue 123899 - CRASH when Insert row
Summary: CRASH when Insert row
Status: CLOSED DUPLICATE of issue 123166
Alias: None
Product: Calc
Classification: Application
Component: editing (show other issues)
Version: 4.0.1
Hardware: All Windows 8, 8.1
: P3 Normal (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-21 05:50 UTC by peterB
Modified: 2017-05-20 09:52 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Sheet that causes the crash (24.19 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-12-21 05:51 UTC, peterB
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description peterB 2013-12-21 05:50:32 UTC
Try and insert a line pretty much anywhere in the attached sheet and OO crashes.

eg: cursor to A122 and do Insert | Row

The sheet is cut down from a larger one which I use fairly regularly, and have certainly inserted rows into (at this location) not too long ago.
Comment 1 peterB 2013-12-21 05:51:24 UTC
Created attachment 82143 [details]
Sheet that causes the crash
Comment 2 Rainer Bielefeld 2013-12-21 11:06:52 UTC
NOT reproducible with "AOO 4.0.1   – German UI / German locale  [Rev. 1524958 2013-09-20 11:40:29]" on  German WIN7 Home Premium (64bit)", “historic”  4.0  User Profile used for all  predecessor versions

Probably a DUP of "Bug 123166 - CRASH when Insert>row in particular way in particular document"
Comment 3 peterB 2013-12-21 18:17:41 UTC
Hmmm. I can reproduce it on both my UK English, Win 8.0 Pro, 4.0.1 machines.

Let me know if there are any logs or other info I can supply!
Comment 4 Edwin Sharp 2013-12-22 13:47:06 UTC
Can not reproduce
AOO410m1(Build:9750)  -  Rev. 1551264
2013-12-17_04:10:52 - Rev. 1551455
Debian
Comment 5 peterB 2013-12-22 20:01:48 UTC
I've now tried on an XP running 4.0.1 and have also removed and reinstalled 4.0 on one Windows 8.0 PC.

The XP does not crash. The 4.0/8.0 does.

So, it looks like a Win 8.x specific problem.
Comment 6 Rainer Bielefeld 2014-01-17 15:54:24 UTC
With "AOO 4.0.1   – German UI / German locale  [Rev. 1524958 2013-09-20 11:40:29]" on  German WIN7 Home Premium (64bit)", “historic”  4.0  User Profile used for all  predecessor versions
I gambled a while around in the document a lot of times closed (without saving) and reopening, and 2 times I was able to get a crash.

This one probably is a DUP of "Bug 123166 - CRASH when Insert>row in particular way in particular document", where experience was that the problem was not 100% reproducible for any user.

@reporter:
Please feel free to reopen this Bug if you find evidence that we have an independent issue here  (for example because the fix for the other bug does not work for you).

*** This issue has been marked as a duplicate of issue 123166 ***
Comment 7 peterB 2014-02-25 20:46:00 UTC
I can confirm that a work-around is to remove all manual row breaks stops the problem (as per https://issues.apache.org/ooo/show_bug.cgi?id=123166).

But, of course, this is still a bug, since I need the manual breaks ;-)
Comment 8 peterB 2014-05-02 15:04:48 UTC
Just to confirm that my problem is indeed fixed in 4.1

Many thanks indeed :-)