Issue 123910 - The reference in validation condition change to #REF! in exported xls file
Summary: The reference in validation condition change to #REF! in exported xls file
Status: CLOSED FIXED
Alias: None
Product: Calc
Classification: Application
Component: save-export (show other issues)
Version: 4.1.0-dev
Hardware: All All
: P3 Major (vote)
Target Milestone: 4.1.0
Assignee: Clarence GUO
QA Contact: liuping
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-23 09:31 UTC by fanyuzhen
Modified: 2017-05-20 10:35 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: 4.1.0-dev
Developer Difficulty: ---


Attachments
sample (8.35 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2013-12-24 02:54 UTC, Clarence GUO
no flags Details
fix patch (1.41 KB, patch)
2013-12-26 01:50 UTC, Clarence GUO
no flags Details | Diff
Fix patch (2.84 KB, patch)
2013-12-30 05:50 UTC, Clarence GUO
clarence.guo.bj: review?
Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description fanyuzhen 2013-12-23 09:31:35 UTC
This defect is migrated from Symphony defect as below:

Sym3_5489	[L3][Concord 21394]the reference in validation condition change to #REF! in exported xls file
Comment 1 Edwin Sharp 2013-12-23 20:22:29 UTC
Steps to reproduce?
Comment 2 Clarence GUO 2013-12-24 02:54:51 UTC
Created attachment 82155 [details]
sample
Comment 3 Clarence GUO 2013-12-24 02:56:04 UTC
Save the xlsx as ods, reopen ods, save ods as xls, check the validation condition of cell E5, it is changed from =SUM(A1:C3) to =SUM(#REF!)
Comment 4 Edwin Sharp 2013-12-24 08:10:10 UTC
Thank you.
Greater than SUM(A1:C3) turns into greater than SUM(#REF!#REF!:#REF!#REF!) when save as ods.

AOO410m1(Build:9750)  -  Rev. 1551264
2013-12-17_04:10:52 - Rev. 1551455
Debian
Comment 5 Clarence GUO 2013-12-26 01:50:20 UTC
Created attachment 82165 [details]
fix patch
Comment 6 Clarence GUO 2013-12-26 01:52:06 UTC
Comment on attachment 82165 [details]
fix patch

The root cause is when OOX parse the validation conditions, the source cell has not been set to the condition.
Comment 7 SVN Robot 2013-12-27 05:30:11 UTC
"steve_y" committed SVN revision 1553626 into trunk:
Bug 123910 - The reference in validation condition change to #REF! in exporte...
Comment 8 Steve Yin 2013-12-27 05:32:22 UTC
Integrated the patch from Clarence to trunk
Comment 9 hdu@apache.org 2013-12-29 08:27:57 UTC
The change above breaks the build. All buildbots report:
main/oox/source/xls/worksheethelper.cxx:1079: error: 'const struct oox::xls::ValidationModel' has no member named 'msRef'
Comment 10 Clarence GUO 2013-12-30 05:50:52 UTC
Created attachment 82187 [details]
Fix patch

Add a new patch of fix the build break
Comment 11 SVN Robot 2013-12-30 05:52:37 UTC
"steve_y" committed SVN revision 1554147 into trunk:
Bug 123910 - The reference in validation condition change to #REF! in exporte...
Comment 12 SVN Robot 2014-01-02 11:19:29 UTC
"orw" committed SVN revision 1554790 into trunk:
123910: removing duplicate code
Comment 13 Oliver-Rainer Wittmann 2014-02-10 09:39:28 UTC
@Clarence: Is this issue solved already?
Comment 14 Clarence GUO 2014-02-11 01:49:21 UTC
@Oliver
Yes, I verified against snapshot build AOO410m1(Build:9750)  -  Rev. 1560773, it's resolved.
Comment 15 Oliver-Rainer Wittmann 2014-02-11 09:14:42 UTC
@Clarence: Thx for the info.
Comment 16 liuping 2014-02-26 00:37:59 UTC
verify AOO410m1(Build:9750)  -  Rev. 1570848
Rev.1570848 on windows7 ,Pass