Issue 123932 - CRASH when insert 'Vertical Text' box
Summary: CRASH when insert 'Vertical Text' box
Status: CLOSED FIXED
Alias: None
Product: Calc
Classification: Application
Component: editing (show other issues)
Version: 4.1.0-dev
Hardware: PC Windows 7
: P3 Major (vote)
Target Milestone: 4.1.0
Assignee: Armin Le Grand
QA Contact: zhaoshzh
URL:
Keywords: crash, regression
Depends on:
Blocks:
 
Reported: 2013-12-30 08:14 UTC by liuping
Modified: 2017-05-20 10:35 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
stopworking.jpg (30.80 KB, image/jpeg)
2013-12-30 08:14 UTC, liuping
no flags Details
Backtrace (49.47 KB, text/x-log)
2014-01-21 12:18 UTC, hanya
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description liuping 2013-12-30 08:14:07 UTC
Created attachment 82189 [details]
stopworking.jpg

Build Info: AOO410m1(Build:9750)  -  Rev. 1548193

Step:	
1.Launch AOO and New a spreadsheet
2.Insert a text box from Toolbars(Vertical text)and click text box

Issue:
Openoffice stop working ,refer stopworking.jpg
Comment 1 Rainer Bielefeld 2014-01-04 08:32:37 UTC
Additional Info:
----------------
(a) You need to enable menu 'Tools -> Options -> Language Settings -> Languages
    -> Shwo UI elements for Asian writings' to get the 'Vertical Text' Icon
    visible in 'Drawing Toolbar'
(b) Still reproducible with server installation of "AOO 4.1.0-Dev – 
    English  UI English locale - [AOO410m1(Build:9750)  -  Rev. 1554205 - 
    2014-01-01]" on German WIN7 Home Premium (64bit)", 
    own separate user profile.
(c) Already reproducible with server installation of "AOO 4.1.0-Dev – 
    English  UI / German locale - [AOO410m1(Build:9750)  -  Rev. 1525917 - 
    2013-09-25]" on German WIN7 Home Premium (64bit)", 
    own separate user profile.	
(d) Was still ok with server installation of "AOO 4.1.0-Dev – English  UI / 
    German locale - [AOO410m1(Build:9750)  -  Rev. 1523968 - 2013-09-18]" 
    on German WIN7 Home Premium (64bit)", own separate user profile.
(e) I think this one is a 4.1 release blocker
Comment 2 hanya 2014-01-21 12:18:59 UTC
Created attachment 82331 [details]
Backtrace

Not only with Calc, I met crash when I draw vertical text shape on Writer.
And also, when I choose slide layout having vertical text box on Impress, crashed.

This might be related to bug 115391.
The attached backtrace by gdb is part of the stacktrace. Because it roops 
among in several functions.
Comment 3 Armin Le Grand 2014-01-23 15:49:03 UTC
Just tried, vertical text objects work in Draw and Impress, but crash in Writer and Calc.
Comment 4 Armin Le Grand 2014-01-27 17:57:48 UTC
Taking a look...
Comment 5 Armin Le Grand 2014-01-27 21:00:05 UTC
Its a loop around SdrTextObj::AdaptTextMinSize(), trying to find out why it happens in Writer and Calc, but not in Draw/Impress...
Comment 6 Armin Le Grand 2014-01-27 21:13:57 UTC
SetVerticalWriting was triggered again and again in TextProperties::ItemChange since SdrTextObj::AdaptTextMinSize() did use the whole SdrObject's ItemSet to set items again, in that set the item was not yet set, so vertical writing was switched on/off all the time. It does not happen in Draw/Impress since there the SdrTextObj is prepared differently.
To prevent that, I changed SdrTextObj::AdaptTextMinSize() to use an empty ItemSet to only modify the items which need to be changed, so SvxWritingModeItem will not be touched. Works as expected (all four main apps checked), preparing commit...
Comment 7 SVN Robot 2014-01-27 21:14:39 UTC
"alg" committed SVN revision 1561850 into trunk:
i123932 Init only needed items in
Comment 8 Armin Le Grand 2014-01-27 21:15:01 UTC
Comitted, done.
Comment 9 zhaoshzh 2014-02-27 02:56:54 UTC
fixed on AOO410m1(build:9750) - rev:1566593
Comment 10 fanyuzhen 2014-02-27 10:28:49 UTC
Change status per Shao Zhi Zhao's comment 9