Issue 123993 - [sidebar]:In documents with Drawing Scale rotating objects (shapes, raster pictures, ...) shifts objects hundreds of cm away
Summary: [sidebar]:In documents with Drawing Scale rotating objects (shapes, raster pi...
Status: CLOSED FIXED
Alias: None
Product: Draw
Classification: Application
Component: editing (show other issues)
Version: 4.0.1
Hardware: PC All
: P3 Normal with 2 votes (vote)
Target Milestone: 4.1.0
Assignee: Armin Le Grand
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-01-08 00:11 UTC by j.tronel
Modified: 2017-05-20 10:35 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: 4.1.0-dev
Developer Difficulty: ---


Attachments
Patch to use UIScale to calculate rotate x and y (1.61 KB, patch)
2014-01-30 05:47 UTC, hanya
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description j.tronel 2014-01-08 00:11:23 UTC
Hello,

-- Open a new Draw document
-- Choose options : unit metre, scale 1:50
-- Draw a Rectangle
-- Using sidebar, set it to Position 1m 1m ; Size 2m 3m
-- Rotation with sidebar : 90 degrees

Rectangle disappears and position shows curious values
on my system, hori -24m vert 222m !!!

Might be a badly scaled centre of rotation?
Comment 1 Edwin Sharp 2014-01-08 06:55:01 UTC
As given in description.

AOO410m1(Build:9750)  -  Rev. 1555399
2014-01-06_04:13:46 - Rev. 1555657
Debian
Comment 2 hanya 2014-01-30 05:47:52 UTC
Created attachment 82434 [details]
Patch to use UIScale to calculate rotate x and y

Values for SID_ATTR_TRANSFORM_ROT_X and Y should be calculated to match with 
the current UIScale.
Comment 3 Armin Le Grand 2014-01-31 22:01:23 UTC
Will have a look...
Comment 4 Armin Le Grand 2014-01-31 22:21:41 UTC
Thanks hanya, the right place and the reason identified. I have allowed to change the patch a bit, committing...
Comment 5 SVN Robot 2014-01-31 22:23:08 UTC
"alg" committed SVN revision 1563305 into trunk:
i123993 When executing rotation actions from the Sidebar PosSizePropertyPanel...
Comment 6 Armin Le Grand 2014-01-31 22:23:39 UTC
Okay, done. Thanks again, hanya!
Comment 7 Armin Le Grand 2014-01-31 22:30:06 UTC
One note: In aw080 the UIScale is already a double, still the Items will be integer.
Comment 8 Rainer Bielefeld 2014-02-11 05:16:12 UTC
Was still reproducible with "AOO 4.0.1 – German UI / German locale [Rev. 1524958 2013-09-20 11:40:29]" on German WIN7 Home Premium (64bit)", “historic” 4.0 User Profile used for all predecessor versions
and Attachment from "LibO Bug#74812 - Rotate via sidebar not working properly":

Selecting rectangle in document and rotating with 'Sidebar -> Position and Size -> Rotation = 45°' made shape disappear out of view, reason is changed 
position X=-1200cm, Y=2400cm. Modifying position to 1/1 brought object back to focus.

Fix VERIFIED with server installation of "AOO 4.1.0-Dev – English UI / German locale - [AOO410m1(Build:9750) - Rev. 1565724 - 2014-02-09]" on German WIN7 Home Premium (64bit)", own separate user profile and above mentioned sample document