Issue 124041 - All objects gone after Math object editing, saving, quiting, re-open
Summary: All objects gone after Math object editing, saving, quiting, re-open
Status: CONFIRMED
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: 4.0.1
Hardware: Mac OS X 10.9
: P3 Normal with 2 votes (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-01-17 12:11 UTC by lauhub
Modified: 2014-06-19 17:13 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description lauhub 2014-01-17 12:11:01 UTC
I was editing a math formula (trying to insert a newline which could not work). As the newline insertion did not work and noticing that the Math toolbar did not appear, I saved my doc, exited AOO and then reopen it.
Surprise: almost all objects (math formulas) were replaced by a red text (Object XX).

I am using Mac, so I could not try to reproduce this on another platform.

I had also another similar bug while copying images from Draw in tables.

I attach two documents: one which is corrupted and the second I restore from a backup. With time lost to redo the stuff I had done meanwhile.
Comment 2 lauhub 2014-01-17 12:24:14 UTC
I had the same problem one week ago.

I was inserting images inside a table (copy/paste from Draw) and then: all math formulas gone !

Below links to attachements:
The corrupted one:
https://www.dropbox.com/s/ra8q8j5m0xk6pap/Cours%20-%20R%C3%A9gulation%20Asservissements%20Corrupted.odt

The backup and corrected document:
https://www.dropbox.com/s/6oyizjgcbvwotg8/Cours%20-%20R%C3%A9gulation%20Asservissements%203.odt
Comment 3 Oliver Brinzing 2014-01-17 17:36:25 UTC
i can confirm this kind of bug on win xp oo32 if one insert some calc cell ranges (copy/paste) into writer documents. sometimes all calc ole objects are gone after saving the writer document...
Comment 4 lauhub 2014-01-20 15:00:13 UTC
A question: does previous version (3.4.1) show the same issue ? Or is it only for 4.x ?
Should I downgrade, because I prefer stability against features? Loosing my document may involve several days of work to be lost.
Comment 5 Rainer Bielefeld 2014-02-11 16:57:18 UTC
This is not a valid bug report!

I did my tests with OOo 2.0.2 because I can't open documents with 4.0.1 (WIN), what will crash.

(a) I compared the linked pictures in both documents from Comment 1, they are 
    identical. So the problem Can't be a broken link.
(b) Replacing the links to the pictures in both documents to an existing picture 
    will work, shows picture. So it seems that there is nothing completely 
    broken.
(c) Very astonishing is that in Comment 2 we have 2 documents.odt,  what
    in reality are HTML-documents (simply open with a simple text editor like
    Wordpad).
(d) Same like (c) with Documents in comment 2
(e) currently the report tells that it might cause problems if users damage
    documents wantonly        ;-)
(f) of course I will do some further investigation, for example why these 
    documents crash my AOO 4.0.1, but this one is report currently is INVALID
    / WONTFIX, no realistic possibility to reproduce reporter's problems
    with valid documents.

@lauhub:
I close this one, but that does not mean that we will not do further investigations. As a first step please you should do your own investigations why you have .html documents with .odt name extensions. Might be "Bug 93905 IN OS File Dialog: missing file name extension when "Save As..." with 'auto-extension' for file names ending with registered file name extension"

For any new bug oyu want to report please consider that it is not enough to tell what you observe. It is necessary that you tell all necessary information how we can reproduce your observations.

After some steps we might come to level that we can investigate the initial problem "Lost Objects" (if it really does exist with valid documents).

@brinzing
Is there already a report for the problems your observe?
Comment 6 Oliver Brinzing 2014-02-11 18:28:40 UTC
i cannot remember writing a bug report. i have seen some corrupted files, but i was not able to reproduce this kind of issue till now.
Comment 7 lauhub 2014-02-12 13:44:52 UTC
Wow, I am surprised. Well I use intensively AOO since 5 months now (after having trashed LibreOffice because of lack of stability), and I am also a little bit upset with the time I spent because of several crashes and trying to write a bug report.

I do not want to have an argument with anyone of you, but I feel disapointed by the fact that, instead of trying to really resolve the bug, it is simply closed without any investigation.

And I read "This is not a valid bug report" !

I am so sorry to inform you that I am a valid office-software user. And, as a former software developer, I understand what you mean when you do all of this (closing the bug because you do not have enough information, asking for complete information to reproduce the bug).

But as a "normal" end user, I don't. Just imagine what someone who, trying to help and knowing nothing to software development practice, and trying to use a so common office tool which crashed so often (yes, really often compared to other ones I tested), yes just imagine what this end user will think.

He will just think it is not worth the time he spent just trying to help. Nor the time to use this software. He will demand to his hierarchy: please install MSOffice on my laptop. And if he is at home, he will just install it (even if he as not bought it).

When you say: "I did my tests with OOo 2.0.2 because I can't open documents with 4.0.1 (WIN)" then you cannot deduce that the problem comes from my links nor deduce anything from that, nor close the bug.

To use my links, you have to click (not right click) on them to open a web page and then (on that web page) click on the download button. You must not right-click and select "Save target as" because it will save to your disk a HTML document with an odt extension.

At last, I hope that adding the information below will make my bug report "valid":

b) see all the valid links in the previous messages.

c) Edit a lot of formulas, copy paste a lot of images from Draw and after some hours, it may crash.

e) open a document, do a lot of work pasting OLE, images from Draw, bitmap images, cells from Calc

f4) Mac OS X 10.9.1 french language
f5) AOO401m5(Build:9714)  -  Rev. 1524958
2013-09-20 11:07:55 (Fri, 20 Sep 2013)
French localization
f6) none
f7) Launched AOO from the Mac OS X LaunchPad. Create a new document from the AOO main menu
f8) did not find the instructions for Mac and have not the time to search.
f9) I don't know

I reset the Status to Unconfirmed

If you want that future bug reports contain the information above, just add fields into the bug report creation form !

And please, keep thinking as "End User" !
Comment 8 Andre 2014-02-12 16:38:22 UTC
@lauhub: Thanks for the bug report.  I was able to download the ODTs (although it would be better to have them attached to this issue because external links tend to go away after some time).  I was also able to reproduce the (a?) crash:

1. load the bug doc
2. scroll down two or three pages
-> crash (not always, but reliably enough to get an idea as to the cause)

I saw the crash in ImplFontCharMap::GetGlyphIndex, vcl/source/gdi/impfont.cxx:170, where a negative index is used to access the maGlyphIds array.

I am just not sure that this is the same crash that is described in the bug description.


@Rainer Bielefeld: This bug report is valid enough for me.  The links in comment2 go to dropbox download pages that provide the actual download links.
Comment 9 lauhub 2014-02-13 08:30:06 UTC
@andre Thank you for your answer.

I did not notice that there w
Comment 10 lauhub 2014-02-13 08:35:49 UTC
(continuing the previous post that was mistakenly posted)

Actually I have no crash when just opening the document and scrolling down (on MacOSX 10.9.1).

May be is it something else.

I also noticed that AOO became slower when pasting/copying after some hours of use. Quiting and reopening (to prevent crashes) makes the number of crashes decrease when editing.

It looks like a memory leak or something like that. Are all of the symptoms linked together ? I can't say.
Comment 11 Andre 2014-02-13 09:07:44 UTC
There are a number of problems described by this issue that may be independent and could/should go into their own issues:

- Saving and reloading of math formulas (OLEs) breaks those formulas (original bug description)

- Crash when I load the (broken) bugdoc.

- Copy and paste Calc cells to Writer (as OLE). Cells are broken after save and reload.

- AOO gets slower after hours of work.


The crash is easiest to reproduce.  Fixing it is a prerequisite for looking at the other bugs.
Comment 12 Andre 2014-02-13 09:12:14 UTC
More details about the crash.  It is only reproducible with the latest builds.  It can be reproduced on at least two machines with Windows7.  The crash is triggered by the arrow before text (toujours VRAI) on page 22 (or so).  Trigger the crash by searching for the text or by just waiting (a couple of seconds) for the background formatting to process the text.
Comment 13 Richard G. Mills 2014-06-19 17:13:36 UTC
This is true in Windows 7, also.  I do a table with a 6 or 7 simple formulas in 7 or 8 cells, and they are all gone when I reopen the document the next day.  The numbers from the previous day are there, but the formulas have disappeared, so the changing the variables does not affect the results.  This makes OpenOffice Writer table formulas useless.  I see many complaints and no solutions in the forums, as well.