Issue 124064 - Document with Chart for lots of values causes CRASH with message "Fatal Error - Bad Allocation"
Summary: Document with Chart for lots of values causes CRASH with message "Fatal Error...
Status: UNCONFIRMED
Alias: None
Product: Calc
Classification: Application
Component: open-import (show other issues)
Version: 4.0.1
Hardware: PC Windows 7
: P3 Normal (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-01-21 07:36 UTC by Rainer Bielefeld
Modified: 2014-05-08 20:22 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Rainer Bielefeld 2014-01-21 07:36:36 UTC
Steps how to reproduce Reproducible with "AOO 4.0.1 – German UI / German locale [Rev. 1524958 2013-09-20 11:40:29]" on German WIN7 Home Premium (64bit)", “historic” 4.0 User Profile used for all predecessor versions:

1. From AOO Start Center open <http://people.apache.org/~regina/Bug_122822_and_121058_CloudLarge_60000Values.ods>
   Bug: Crash with message "Fatal Error - Bad Allocation"

Additional info:
----------------
(a) Crash already mentioned in "Bug 122822 - Correct viewing of XY-, Column- 
    and Line-Charts limited to 10000 records + 1 Heading row" (Comment#28)
(b) Already reproducible with
* server installation of "AOO 4.1.0-Dev – English UI / German locale - 
  [AOO410m1(Build:9750) - Rev. 1530680 - 2013-10-11]" 
  on German WIN7 Home Premium (64bit)", own separate user profile.
* AOO 4.0.1  – EU UI / German locale [Rev. 1524958 2013-09-20 11:40:29]"
  on German WIN7 Home Premium (64bit)", own User Profile	
* (May be) server installation of "AOO 3.4.1 – German UI 
  / German locale [AOO341m1(Build:9593) - Rev.1372282]" 
  on German WIN7 Home Premium (64bit)", own separate user profile? Crashes 
  without message, might be something different!
(c) Was still ok with
* server installation of  "AOO 4.1.0-Dev – English UI / German locale - 
  [AOO410m1(Build:9750) - Rev. 1516435 2013-08-24]" on German WIN7 
   Home Premium (64bit)", own separate user profile. (Chart looks wrong)
* server installation of  "AOO 4.0.0-Dev – English UI / German locale -
  [AOO400m3(Build:9702) - Rev. 1511231 2013-08-08]" on German WIN7 
   Home Premium (64bit)", own separate user profile.
   (but shows chart completely wrong)
*  server installation of " AOO 4.0.0-Dev – English UI / German locale 
   [AOO400m1(Build:9700) - Rev. 1457992 – Rev.1457606 ((2013-03-19))]"
   on German WIN7 Home Premium (64bit)", own separate user profile
   (but shows chart completely wrong)
* 3.3.0
* 2.0.2
(d) Still Reproducible with server installation of "AOO 4.1.0-Dev – SV UI
    / German locale - [AOO410m1(Build:9750) - Rev. 1558977 - 2014-01-18]"
    on German WIN7 Home Premium (64bit)", own separate user profile.
(e) No Crash with 4.0.0 Final

@Regina, @Armin:
You might be interested?
Comment 1 wdritschilo 2014-05-08 20:22:13 UTC
Editing slows down until program stops. Bad allocation error appears both on trying to save and sporadically. Recovery neither recovers nor shows window for reporting crash