Issue 124179 - New InputFields for UserFields don't update automatically
Summary: New InputFields for UserFields don't update automatically
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: ui (show other issues)
Version: 4.1.0-dev
Hardware: PC Windows, all
: P3 Major (vote)
Target Milestone: 4.1.0
Assignee: Oliver-Rainer Wittmann
QA Contact: Shenfeng Liu
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2014-02-04 11:12 UTC by jmpoo
Modified: 2017-05-20 10:35 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
UserField AOO 4.1.0 dev (11.83 KB, application/vnd.oasis.opendocument.text)
2014-02-04 11:12 UTC, jmpoo
no flags Details
UserField AOO 4.0.1 (10.63 KB, application/vnd.oasis.opendocument.text)
2014-02-04 11:13 UTC, jmpoo
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description jmpoo 2014-02-04 11:12:19 UTC
Created attachment 82495 [details]
UserField AOO 4.1.0 dev

AOO 4.1.0 r156 3305, de, default options

Open Writer
define a UserField (Variables)
insert an InputField for the defined UserField
insert another Inputfield for the same UserField
change one of the InputFields
notice that the other InputField is not updated
You have to update with F9

Works automatically in AOO 3.4.1 and "old" popup InputFields

I have attached two files: 
one created in AOO 4.1, wich is probably corrupted (see Issue 124178)
and another one, created in AOO 4.0.1, wich opens without corruption in AOO 4.1 and fails if you save and reopen it.
Comment 1 jmpoo 2014-02-04 11:13:14 UTC
Created attachment 82496 [details]
UserField AOO 4.0.1
Comment 2 Oliver Brinzing 2014-02-04 11:55:04 UTC
confirming with aoo4.1.0 rev 1560773
Comment 3 Oliver-Rainer Wittmann 2014-02-10 13:20:45 UTC
taking over to work on a solution as I assume my changes causes this defect
Comment 4 Oliver-Rainer Wittmann 2014-02-10 16:19:25 UTC
fix in progress

root cause:
The newly introduced edit action code for a User Variable Input Field misses the corresponding propagation code for the User Variable Fields and further Input Fields.
Comment 5 Oliver-Rainer Wittmann 2014-02-11 10:25:44 UTC
This regression has been introduced by in-place editing of Input Fields enhancement (bug 33737).

It will be fixed for the next release.
Comment 6 SVN Robot 2014-02-11 13:28:05 UTC
"orw" committed SVN revision 1567110 into trunk:
124179: trigger update User Fields and related Input Fields when user directl...
Comment 7 Oliver-Rainer Wittmann 2014-02-11 13:38:38 UTC
fixed on trunk for next release
Comment 8 Shenfeng Liu 2014-02-25 10:15:11 UTC
Verified in windows daily build 1571426. The defect is no longer reproducible.