Issue 124229 - OOO crashes after document recovery
Summary: OOO crashes after document recovery
Alias: None
Product: General
Classification: Code
Component: ui (show other issues)
Version: 4.0.1
Hardware: PC Linux 64-bit
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Keywords: needhelp
Depends on:
Reported: 2014-02-13 14:45 UTC by Dieter
Modified: 2014-02-13 15:38 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Note You need to log in before you can comment on or make changes to this issue.
Description Dieter 2014-02-13 14:45:14 UTC
When starting OO (by clicking on it or from terminal with soffice) "OO Document recovery" opens and wnts to recover some OO Calc document. When clicking okay (there is no other option) then OO crahes. 
From terminal I run with -norecovery and get normal operation, but when I start afterwards again you can see the errors below:

dw@UX31E:~$ soffice -norestore
dw@UX31E:~$ soffice 
GLib:ERROR:/build/buildd/glib2.0-2.38.1/./glib/gmain.c:3068:g_main_dispatch: assertion failed: (current->dispatching_sources == &current_source_link)

Fatal exception: Signal 6
Comment 1 Edwin Sharp 2014-02-13 14:56:31 UTC
What Linux distribution?
Please attach Calc document.
Comment 2 Dieter 2014-02-13 15:36:01 UTC
dw@UX31E:~$ uname -a
Linux UX31E 3.11.0-14-generic #21-Ubuntu SMP Tue Nov 12 17:04:55 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

AKA Ubuntu 13.10 Saucy
Im runnin Gnome 3

Actully it's not a ods or xls-file, it's a simple ASCII *txt tab delimated. And, it's intact, I can open it e.g. in gedit. And, I am sorry, I cannot disclose this file to the community.

BTW: I found a workaround to fix the Problem: Accidently i moved the file to another folder, then in the message box a "do not recover" popped up, this solved the problem. Therefore I cannot reproduce the Error anymore.

But, this workaround dous not fix the bug.
Comment 3 Edwin Sharp 2014-02-13 15:38:37 UTC
OK, thank you.