Issue 124233 - Different text rendering (word/character width) depending on zoom factor
Summary: Different text rendering (word/character width) depending on zoom factor
Status: CLOSED FIXED
Alias: None
Product: Impress
Classification: Application
Component: ui (show other issues)
Version: 4.1.0-dev
Hardware: Mac Mac OS X, all
: P3 Critical (vote)
Target Milestone: 4.1.0
Assignee: hdu@apache.org
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-14 00:27 UTC by Thorsten Wagner
Modified: 2014-05-15 22:43 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---
jsc: 4.1.0_release_blocker+


Attachments
Sample impress presentation (453.46 KB, application/vnd.oasis.opendocument.presentation)
2014-02-14 00:27 UTC, Thorsten Wagner
no flags Details
Screenshot 1: Text rendering at 92% zoom (228.43 KB, image/png)
2014-02-14 00:28 UTC, Thorsten Wagner
no flags Details
Screenshot 2: Text rendering at 94% zoom (232.81 KB, image/png)
2014-02-14 00:28 UTC, Thorsten Wagner
no flags Details
Screenshot 3: Bad cursor placement (237.81 KB, image/png)
2014-02-14 00:28 UTC, Thorsten Wagner
no flags Details
Screenshot 4: Slide sorter (129.59 KB, image/png)
2014-02-14 00:29 UTC, Thorsten Wagner
no flags Details
Screenshot 5: Extra white space (244.07 KB, image/png)
2014-02-18 21:26 UTC, Thorsten Wagner
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Thorsten Wagner 2014-02-14 00:27:16 UTC
Created attachment 82585 [details]
Sample impress presentation

With AOO 4.1 text rendering has been improved using native OS X rendering I assume. Although this improvement is very valuable the current behaviour makes impress nearly useless:

(1) The width of words/characters is changing depending on the zoom factor. This is illustrated on the attached screenshots 1 (zoom factor 92%) and 2 (zoom factor 94%), see red box.

(2) The changing word/character with causes cursor placement issues. Depending on the zoom factor it's no longer possible to select the desired character. This is illustrated on the attached screenshot 3, see red box.

(3) The rendering of slide previews is affected too (see screenshot 4).

The sample file used to take the screenshots is attached.

The behaviour occurs with revision 1567914 from trunk, but the behaviour described still exists on earlier revisions too.
Comment 1 Thorsten Wagner 2014-02-14 00:28:02 UTC
Created attachment 82586 [details]
Screenshot 1: Text rendering at 92% zoom
Comment 2 Thorsten Wagner 2014-02-14 00:28:23 UTC
Created attachment 82587 [details]
Screenshot 2: Text rendering at 94% zoom
Comment 3 Thorsten Wagner 2014-02-14 00:28:54 UTC
Created attachment 82588 [details]
Screenshot 3: Bad cursor placement
Comment 4 Thorsten Wagner 2014-02-14 00:29:40 UTC
Created attachment 82589 [details]
Screenshot 4: Slide sorter
Comment 5 hdu@apache.org 2014-02-17 13:21:36 UTC
Confirmed.
What's interesting is that the new subsystem goes to great lengths to preserve sub-pixel layout accuracy. It is being investigated where this extra accuracy gets chopped. The rounding in line 325 of drawinglayer/source/primitive2d/textlayoutdevice.cxx is a prime suspect.
Comment 6 SVN Robot 2014-02-18 15:36:58 UTC
"hdu" committed SVN revision 1569388 into trunk:
#i124233# fix CoreText justification of text with trailing spaces
Comment 7 Thorsten Wagner 2014-02-18 21:24:51 UTC
Herbert, thank you very much for providing your fix. Text rendering looks very good now. I found an additional issue. I'm not sure wheater the root cause is the same:

(1) Select the title frame on the first slide of the sample presentation

(2) Place the cursor at the beginning of the second line immediately previous to the word "Title"

(3) Delete the space causing the line wrap with backspace, "TitleTitle" appears in the second line now

(4) Insert the space again using the space bar

At the end of the first line a very wide space appears now. Within the area of the wide space the selection of characters is no more possible correctly. The problem disappears after deselecting the title frame.

The behaviour described is illustrated on the newly attached screenshot 5, see red box. It seems to be independent from the zoom factor.
Comment 8 Thorsten Wagner 2014-02-18 21:26:25 UTC
Created attachment 82624 [details]
Screenshot 5: Extra white space
Comment 9 hdu@apache.org 2014-02-20 10:49:15 UTC
Good catch! It was caused by a rounding error. Will be fixed really soon...
Comment 10 SVN Robot 2014-02-20 13:59:59 UTC
"hdu" committed SVN revision 1570188 into trunk:
#i124233# prevent the accumulation of rounding errors in CTLayout::FillDXArry()
Comment 11 Thorsten Wagner 2014-02-20 21:52:06 UTC
The bug still exists with revision 1570362 from trunk.
Comment 12 hdu@apache.org 2014-02-21 08:20:26 UTC
(In reply to Thorsten Wagner from comment #11)
> The bug still exists with revision 1570362 from trunk.

Please check with the latest nightly build at http://people.apache.org/~hdu/
Comment 13 Thorsten Wagner 2014-02-21 16:29:25 UTC
(In reply to hdu@apache.org from comment #12)
> (In reply to Thorsten Wagner from comment #11)
> > The bug still exists with revision 1570362 from trunk.
> 
> Please check with the latest nightly build at http://people.apache.org/~hdu/

On your web site is only a link marked with "AOO for 64 bit Mac OS X" which is broken. I'm unable to download something.
Comment 14 hdu@apache.org 2014-02-24 12:20:16 UTC
> Please check with the latest nightly build at http://people.apache.org/~hdu/

There was a typo in the dev-builds link that is fixed now. That test build has also been updated to todays trunk revision.
Comment 15 Thorsten Wagner 2014-02-24 17:52:01 UTC
Herbert, unfortunately the bug is still present in revision 1571366 from trunk as well as within the version downloaded from your web site.
Comment 16 Thorsten Wagner 2014-02-24 22:24:36 UTC
It seems the problem appears with spaces at the end of a line. After inserting a space at the end of a line, the rest of the text within the line gets shrinked and cursor positioning is lost.

In AOO 4.0.1 the problem is either not present or not very distinct.
Comment 17 SVN Robot 2014-02-27 14:20:54 UTC
"hdu" committed SVN revision 1572587 into trunk:
#i124233# fix CoreText measurements/justification of text with trailing spaces
Comment 18 jsc 2014-02-27 14:57:27 UTC
grant showstopper flag

not usable otherwise
Comment 19 jsc 2014-02-27 16:19:25 UTC
tested the fix and it works now
Comment 20 Thorsten Wagner 2014-02-27 20:57:15 UTC
My retest looks good too. Herbert, thank you very much for providing the fix. I'll set the status of the ticket to "resolved" now.

Unfortunately I discovered another text rendering bug, but I'll file a new ticket "Text disappears on slide preview" for this issue.
Comment 21 hdu@apache.org 2014-02-28 08:07:05 UTC
Thanks for finding, retesting and verifying the problems!
Comment 22 SVN Robot 2014-02-28 08:11:30 UTC
"hdu" committed SVN revision 1572868 into branches/AOO410:
#i124233# fix CoreText measurements/justification of text with trailing spaces