Issue 124243 - Can't enter data into input fields in protected sections
Summary: Can't enter data into input fields in protected sections
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: 4.1.0-dev
Hardware: PC All
: P3 Normal (vote)
Target Milestone: 4.1.0
Assignee: Oliver-Rainer Wittmann
QA Contact:
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2014-02-17 10:35 UTC by Kulo
Modified: 2017-05-20 10:35 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: 4.1.0-dev
Developer Difficulty: ---


Attachments
Writer Document to repoduce the bug (9.09 KB, application/vnd.oasis.opendocument.text)
2014-02-17 10:35 UTC, Kulo
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Kulo 2014-02-17 10:35:46 UTC
Created attachment 82601 [details]
Writer Document to repoduce the bug

AOO410m1(Build:9750)  -  Rev. 1568575

Opening the attached document and trying to change data of the first text input field (located in a protected section) ends up in a dialog "Readonly content cannot be changed ...". But Choosing another item of the input list works also in the protected section.

And if you start the automated input sequence by pressing CTRL+SHIFT+F9 you can input data into all fiels - also in those in protected sections.

The expected behavior should be to allow input in place of input fields also in protected sections. Other doesn't make sense for me.
Comment 1 Edwin Sharp 2014-02-17 16:31:30 UTC
No dialog when double click top text within section. Ctrl+Shift+F9 allows modification.
Top Item1 within section can be modified.
AOO410m1(Build:9750)  -  Rev. 1566800
2014-02-11_04:11:01 - Rev. 1566981
Debian
Comment 2 Oliver-Rainer Wittmann 2014-02-17 19:57:17 UTC
taking over to have a closer look.

It's a regression caused by the in-place editing enhancement.
Comment 3 Oliver-Rainer Wittmann 2014-02-19 09:20:45 UTC
fix in progress
Comment 4 Oliver-Rainer Wittmann 2014-02-20 11:11:16 UTC
fixed on trunk for next release - rev. 1570146
Comment 5 Kulo 2014-02-26 10:11:21 UTC
I verified the fix in version
AOO410m1(Build:9750)  -  Rev. 1571087
Rev.1571087

Everything seems to be OK now.

Oliver, is there a chance to apply the fix to the LibreOffice Project? What should I do for this? I already made a bug entry on LO bugzilla but nothing happens until now.
Comment 6 Oliver-Rainer Wittmann 2014-02-26 10:33:48 UTC
(In reply to Kulo from comment #5)
> I verified the fix in version
> AOO410m1(Build:9750)  -  Rev. 1571087
> Rev.1571087
> 
> Everything seems to be OK now.
> 
> Oliver, is there a chance to apply the fix to the LibreOffice Project? What
> should I do for this? I already made a bug entry on LO bugzilla but nothing
> happens until now.

The LibreOffice project has a clone of the AOO source code repository in their source code repository and in general integrate bug fixes, enhancements and features more or less on a daily schedule. Thus, I assume that the code changes for this issue have been already integrated into the LibreOffice code base.
Comment 7 revolucaojava 2014-04-12 20:30:01 UTC
(In reply to Oliver-Rainer Wittmann from comment #6)
> (In reply to Kulo from comment #5)
> > I verified the fix in version
> > AOO410m1(Build:9750)  -  Rev. 1571087
> > Rev.1571087
> > 
> > Everything seems to be OK now.
> > 
> > Oliver, is there a chance to apply the fix to the LibreOffice Project? What
> > should I do for this? I already made a bug entry on LO bugzilla but nothing
> > happens until now.
> 
> The LibreOffice project has a clone of the AOO source code repository in
> their source code repository and in general integrate bug fixes,
> enhancements and features more or less on a daily schedule. Thus, I assume
> that the code changes for this issue have been already integrated into the
> LibreOffice code base.

Till now, they did not integrate. I don't understand any of that, so i'd like to know: is there a way to make it manually? I mean, can i copy something from the AOO installation folder to the libreoffice one, in order to fix this bug? I guess not, but worth asking.
Sorry for my bad english.
Comment 8 Ariel Constenla-Haile 2014-04-12 23:25:32 UTC
(In reply to revolucaojava from comment #7)
> Till now, they did not integrate. I don't understand any of that, so i'd
> like to know: is there a way to make it manually? I mean, can i copy
> something from the AOO installation folder to the libreoffice one, in order
> to fix this bug? I guess not, but worth asking.

You are right, copying one library from one project to the other won't work.
Anyway they have integrated Oliver's work, see 
http://cgit.freedesktop.org/libreoffice/core/commit/?id=961315f0838197e71e9bd49169afe673466e5eb8