Issue 124318 - Import of csv files does not break at line endings
Summary: Import of csv files does not break at line endings
Status: UNCONFIRMED
Alias: None
Product: Calc
Classification: Application
Component: open-import (show other issues)
Version: 4.0.1
Hardware: PC Linux, all
: P3 Major (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords: needhelp
Depends on:
Blocks:
 
Reported: 2014-02-26 10:19 UTC by hhue13
Modified: 2016-04-03 23:59 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Details of Linux & OO Environment (325.52 KB, application/vnd.oasis.opendocument.text)
2014-02-26 10:21 UTC, hhue13
no flags Details
csv file to be imported (279.90 KB, application/x-gzip)
2014-02-26 10:23 UTC, hhue13
no flags Details
Resulting .ods file from the csv import (798.98 KB, application/x-gzip)
2014-02-26 10:27 UTC, hhue13
no flags Details
screenshot of text import dialog (48.23 KB, image/png)
2014-02-26 11:25 UTC, Edwin Sharp
no flags Details
spreadsheet (836.16 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-02-26 12:55 UTC, Edwin Sharp
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description hhue13 2014-02-26 10:19:24 UTC
The problem here is that importing a csv im OOO calc on Linux obviously does not honor line endings properly as multiple lines of the csv file are concatenated together into one line in calc. Hence the resulting file is not usable at all. I've tried to convert the .csv using unix2dos before importing but the problem did not change. 

This bug seems to be very similar to 82952 however this problem still exists and the 82952 is very old therefore I'm opening a new bug here. Due to this problem it is not possible to import CSV files on Linux into calc what is a major impact to the usability of the application. A fix would be needed as having to use excel as an intermediary it not really an option.

Attaching the following documents:
OOSystemInfo.odt -> Information about Linux installation & OpenOffice details
wp_vmstatlog_2014.02.25.csv.gz --> source csv file for import
wp_vmstatlog_2014.02.25.ods.gz --> resulting ods file (see OOSystemInfo.odt for the import options).
Comment 1 hhue13 2014-02-26 10:21:53 UTC
Created attachment 82709 [details]
Details of Linux & OO Environment
Comment 2 hhue13 2014-02-26 10:23:44 UTC
Created attachment 82710 [details]
csv file to be imported
Comment 3 hhue13 2014-02-26 10:27:51 UTC
Created attachment 82711 [details]
Resulting .ods file from the csv import
Comment 4 Edwin Sharp 2014-02-26 11:25:12 UTC
Created attachment 82713 [details]
screenshot of text import dialog

With these settings import seems ok.
Please advise.
Comment 5 Edwin Sharp 2014-02-26 11:27:01 UTC
AOO410m1(Build:9750)  -  Rev. 1571426
2014-02-25_04:10:58 - Rev. 1571555
Debian
Comment 6 hhue13 2014-02-26 12:27:48 UTC
Comment on attachment 82713 [details]
screenshot of text import dialog

Thanks for your response here. Tried the same settings but I still get the same (wrong) result. Not sure if the OS makes a difference (I'm on RHEL).
Comment 7 Edwin Sharp 2014-02-26 12:55:27 UTC
Created attachment 82717 [details]
spreadsheet

This is how my import looks like
Comment 8 hhue13 2014-02-26 13:10:18 UTC
Comment on attachment 82717 [details]
spreadsheet

Exactly how I'd like the import to look like. Too bad it does not work for me like this.
Comment 9 Edwin Sharp 2014-02-26 13:14:06 UTC
Maybe try newer snapshot:
http://ci.apache.org/projects/openoffice/#linux64
Comment 10 hhue13 2014-02-26 19:47:37 UTC
(In reply to Edwin Sharp from comment #9)
> Maybe try newer snapshot:
> http://ci.apache.org/projects/openoffice/#linux64

Tried the current 4.1.0 version from the download link provided but still the same problem. Whereby here again it's the same as in the 4.0.1 version namely that in the preview the import lools OK but when the csv is finally importet I again get the incorrect result.
Comment 11 damjan 2016-04-03 23:59:26 UTC
I cannot reproduce this. Please test again with a recent version and attach a screenshot of your text import settings dialog.