Issue 124336 - background is different when insert text in a textbox
Summary: background is different when insert text in a textbox
Status: CONFIRMED
Alias: None
Product: Calc
Classification: Application
Component: viewing (show other issues)
Version: 4.0.0
Hardware: All Windows 7
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-28 02:29 UTC by zhaoshzh
Modified: 2014-02-28 08:42 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: 4.1.0-dev
Developer Difficulty: ---


Attachments
background issue (9.58 KB, image/png)
2014-02-28 02:29 UTC, zhaoshzh
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description zhaoshzh 2014-02-28 02:29:16 UTC
Created attachment 82747 [details]
background issue

1. new a spreadsheet
2. create a textbox
3. input text in the textbox

issue:
the background is different in area 1 and area 2.
refer to the attachment.
Comment 1 Edwin Sharp 2014-02-28 07:05:18 UTC
Can not reproduce
AOO410m1(Build:9750)  -  Rev. 1569541
Rev.1569541
Win 7
Comment 2 Rainer Bielefeld 2014-02-28 08:18:58 UTC
Simply  Reproducible with "AOO 4.0.1 Release – German UI / German locale [AOO401m5(Build:9714)  -  Rev. 1524958 2013-09-20 11:40:29]" on German WIN7 Home Premium (64bit)", “historic” 4.0 User Profile used for all predecessor versions:

1. From AOO start Center open new Calc Document
2. If necessary activate Drawing Toolbar from menu 'View -> Toolbars'
3. Insert bit Text box (Area B2:C40 or so)
4. Type 1<enter>2<enter>3<enter>4
5. Click into bottom right area in Text Box
   > Caret starts flashing left from "1"
6. Type a<enter>
   > All numbered lines shifted 1 down
   > Most lines affected by this edit have white background
     EXCEPT last row with "4"                                 :-)

Additional Info
(a) It seems intended that all rows affected by an edit will become
    intransparent
(a1) This rule is broken for last text row for "Insert Line"
(b) Already Reproducible with server installation of " AOO 4.0.0-Dev – 
    English UI / German locale [AOO400m1(Build:9700) - Rev. 1457992 – 
    Rev.1457606 ((2013-03-19))]" on German WIN7 Home Premium (64bit)", 
    own separate user profile
(c) was still ok with server installation of "AOO 3.4.1 – German UI 
   / German locale [AOO341m1(Build:9593) - Rev.1372282]" on 
    German WIN7 Home Premium (64bit)", own separate user profile
(d) Seems effect came up with change of "Text Box Edit Mode Border" from
    hashed to light blue transparent line.

@zhaoshzh:
What's your OS?
Comment 3 zhaoshzh 2014-02-28 08:42:14 UTC
windows 7