Issue 124416 - Get a lot of '=#NAME?' cell values in .xls file; same file works fine in Excel 2007
Summary: Get a lot of '=#NAME?' cell values in .xls file; same file works fine in Exce...
Status: CLOSED DUPLICATE of issue 84878
Alias: None
Product: Calc
Classification: Application
Component: open-import (show other issues)
Version: 4.0.1
Hardware: PC Windows 7
: P3 Normal (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-12 18:10 UTC by alexander.remus
Modified: 2017-05-20 09:53 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: 4.1.0-beta
Developer Difficulty: ---


Attachments
Excel 2010 vs. Calc 4.1 (209.51 KB, image/png)
2014-03-12 19:07 UTC, Edwin Sharp
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description alexander.remus 2014-03-12 18:10:45 UTC
I hope I'm not wasting anybodies time with this, but here's the deal: 
The file in question can be found here:
https://www.dropbox.com/s/nxhxux37ie4jd45/bls3-FINAL.xls
opening it with OO reveals a lot of #NAME? fields. The file opened in Excel does not show such behavior. One example is row 8438. There are a lot of those fields, but there are others, too. I hope I could contribute to making OO a better program, as it is so much in better in many aspects than Excel.
Comment 1 Edwin Sharp 2014-03-12 19:07:19 UTC
Created attachment 82849 [details]
Excel 2010 vs. Calc 4.1
Comment 2 Edwin Sharp 2014-03-12 19:08:32 UTC
Confirmed with
AOO410m14(Build:9760)  -  Rev. 1573601
2014-03-03 17:47:48 (Mo, 03 Mrz 2014)
Win 7

PS time to open: Excel 6 sec, Calc 30 sec
Comment 3 j.nitschke 2014-03-12 20:33:45 UTC
most likely duplicate of Bug 84878 - #NAME? in attached .xls for unknown reason.

see bug 84878, comment 6 and bug 84878, comment 7

formulas stored as share formulas reaches it limit of 2^14 (16384)
bls3-FINAL.xls has very many formulas too

@reporter:
if you think the described behavior does not apply to your problem, feel free to reopen this report

*** This issue has been marked as a duplicate of issue 84878 ***
Comment 4 Edwin Sharp 2014-03-13 07:12:33 UTC
Didn't know about this limit...
A 1,048,576 rows spreadsheet with only 16,384 formulas - that's ridiculous.
Comment 5 Andre 2014-03-13 09:22:34 UTC
This looks like an interesting document that shows more problems:

- Colors of cell backgrounds look different than in Excel.

- Deleting the document takes considerable longer than loading it (at leas on my developer version with debug information).