Issue 124423 - No dictionary is included in 4.1.0 Beta PT
No dictionary is included in 4.1.0 Beta PT
Status: RESOLVED FIXED
Product: Native-Lang
Classification: NLC
Component: pt
4.1.0-dev
All Windows XP
: P3 normal
: 4.1.0
Assigned To: AOO issues mailing list
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-03-14 00:15 UTC by Pedro
Modified: 2014-03-27 12:31 UTC (History)
6 users (show)

See Also:
Issue Type: FEATURE
Latest Confirmation on: ---
Developer Difficulty: ---
jsc: 4.1.0_release_blocker+


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Pedro 2014-03-14 00:15:55 UTC
After installing Apache_OpenOffice_Beta_4.1.0_Win_x86_install_pt.exe there is no Portuguese dictionary installed.

Installing Apache_OpenOffice_Beta_4.1.0_Win_x86_langpack_en-US.exe ontop of the Portuguese version doesn't install the en_US dictionary either.
Comment 1 Andre 2014-03-14 07:50:26 UTC
This is true but not a bug.  OpenOffice is an open source project where the work is done by volunteers.  Apparently nobody volunteered to decide which dictionaries to include for the Portuguese version and adapt main/extensions.lst accordingly.

Maybe you can do that?  Here is what has to be done:

- Provide a list of languages for which dictionaries should be added.
- Optionally discuss this list on the dev mailing list.
- Provide download links.

If you want you can also adapt the main/extensions.lst to include those dictionaries, but I can do that for you, if you want.
Comment 2 Andre 2014-03-14 07:51:49 UTC
*** Issue 124424 has been marked as a duplicate of this issue. ***
Comment 3 Pedro 2014-03-14 10:44:59 UTC
(In reply to Andre from comment #1)
> This is true but not a bug.  OpenOffice is an open source project where the
> work is done by volunteers.  Apparently nobody volunteered to decide which
> dictionaries to include for the Portuguese version and adapt
> main/extensions.lst accordingly.
> 
> Maybe you can do that?  Here is what has to be done:

I'm sorry but I don't have the time to check all languages.

But I can inform you/AOO that OpenOffice always used the Portuguese dictionaries from this source (which is actually on the official AOO Extensions site)
http://extensions.openoffice.org/en/project/european-portuguese-dictionaries

I hope someone has the time/skills to include this both in the PT Installer and PT Language Pack ;)
Comment 4 Rainer Bielefeld 2014-03-20 18:39:00 UTC
Please see "Issue 124473 - No dictionary included in 4.1.0 Beta Language packs"!
Comment 5 Pedro 2014-03-20 23:39:32 UTC
Going back some versions I can see that Portuguese (from Portugal) has never been properly supported in OOo/AOO... In OOo version 3.3.0 the PT installer contained a PT-BR dictionary and there was no PT language pack. In 3.4.1 (couldn't find any server with 3.4.0) there is no PT installer or langpack. Apparently the menus and the help file are translated but the dictionaries/spelling always needed to be installed as a separate extension.
Comment 6 Andrea Pescetti 2014-03-23 23:38:49 UTC
So, should we include version 14.1.1.1 of
http://extensions.openoffice.org/en/project/european-portuguese-dictionaries ? Did you have the occasion to test it?

(note: due to Issue 124473 the integration will apply only to the full version, not to the language pack).
Comment 7 Pedro 2014-03-24 00:38:34 UTC
Hi Andrea

(In reply to Andrea Pescetti from comment #6)
> So, should we include version 14.1.1.1 of
> http://extensions.openoffice.org/en/project/european-portuguese-dictionaries
> ? Did you have the occasion to test it?

Yes, I installed the extension manually and it works perfectly in 4.1.0 Beta.
Please do include it in AOO 4.1.0
 
> (note: due to Issue 124473 the integration will apply only to the full
> version, not to the language pack).

I d0 not understand why... The English language pack includes the English dictionary... How is this different?
Comment 8 Pedro 2014-03-24 01:00:13 UTC
Hi all

(In reply to Pedro from comment #7)
> I do not understand why... The English language pack includes the English
> dictionary... How is this different?

Apologies. The English language pack does NOT install dictionaries either. 

I believe this is a big missing feature. A language pack pack should include dictionaries/spelling tools in the same way that the complete installer includes the dictionaries/spelling tools for the language it is named after.
Comment 9 SVN Robot 2014-03-26 08:46:02 UTC
"pescetti" committed SVN revision 1581746 into trunk:
#i124423# Bundle Portuguese dictionary.
Comment 10 Andrea Pescetti 2014-03-26 08:51:21 UTC
The Portuguese version does not come with a bundled dictionary. This is now fixed in trunk.

Nominating a 4.1.0 stopper like the other dictionary updates. Feel free to integrate into AOO410 and close.
Comment 11 jsc 2014-03-27 08:42:07 UTC
grant showstopper flag
Comment 12 SVN Robot 2014-03-27 12:31:07 UTC
"jsc" committed SVN revision 1582276 into branches/AOO410:
#124423# merge fix from trunk to include Portuguese dictionary in AOO 4.1
Comment 13 jsc 2014-03-27 12:31:57 UTC
merged fix from trunk into aoo410 branch