Issue 124434 - Drag & Drop picture into document opens DRAW instead of showing picture in Writer
Summary: Drag & Drop picture into document opens DRAW instead of showing picture in Wr...
Status: CLOSED DUPLICATE of issue 105098
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: 3.3.0 or older (OOo)
Hardware: Mac OS X 10.9
: P3 Normal with 2 votes (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
: 125562 (view as issue list)
Depends on:
Blocks:
 
Reported: 2014-03-14 14:29 UTC by hadouma
Modified: 2017-05-20 10:11 UTC (History)
7 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description hadouma 2014-03-14 14:29:25 UTC
When I try to drag & Drop e.g. a picture into an existing Writer document, OO will open a new DRAW document instead and copy the picture into that DRAW document. It is NOT possible to drag & drop a picture into the WRITER document. Inserting a picture will only work via the menu Insert>Picture>From file 

I have put this onto the OO forum as a question, but I only get a response from people where drag & drop works. Again: for me it doesn't
Comment 1 Rainer Bielefeld 2014-03-15 15:17:12 UTC
NOT reproducible with "AOO 4.0.1 Release – German UI / German locale [AOO401m5(Build:9714)  -  Rev. 1524958 2013-09-20 11:40:29]" on German WIN7 Home Premium (64bit)", “historic” 4.0 User Profile used for all predecessor versions. Drag and drop from Websites, Files Explorer and other documents works find. MAC related? unknown constraints?	

@reporter:
Thank you for your feedback – unfortunately important information we will 
need to reproduce your problem is missing.
Please add all information requested in following:
a) Write a meaningful Summary describing exactly what the problem is
b) Attach a sample document (not only screenshot) or refer to an existing 
  sample document in an other Bug with a link; to attach a file to this 
  bug report, just click on "Add an attachment" right on this page.
  If you want to attach a test kit with multiple documents zip them into
  a single testkit.zip and attach the  testkit.zip
c) Contribute a document related step by step instruction containing every 
  key press and every mouse click how to reproduce your problem 
d) Attach screenshots with comments if you believe that that might explain the 
  problem better than a text comment. Best way is to insert your screenshots
  into a DRAW document and to add comments that explain what you want to show
f) add information 
  f6) Links to forum discussions
  f7) how you launch AOO and how you opened the sample document
  f8) Whether your problem persists after you have renamed your user profile 
     (Quit Quickstart before!) before you launch AOO (please see
     <http://www.openoffice.org/development/releases
  f9) Whether that worked in former OOO / AOO Versions 
  f10) whether (and how) a competitor's software (MSO, LibreOffice, ...)
       fulfills your needs
 
Please do not cite these hints in your reply, but cite the items like:
f7): Desktop-icon for soffice.exe / AOO File menu -> Open
Comment 2 hadouma 2014-03-15 15:47:41 UTC
Did you actually read what I wrote ?

What do you mean by "write a meaningful summary" ? How more "meaningful" than what I wrote can it be ? Including a sample document is useless, because dragging & dropping a picture into ANY Writer document will NOT put the picture in the Writer document but will create a Draw document. Likewise including keys pressed is irrelevant, because I am referring to drag & drop and not to pressing any keys.
Forum URL is https://forum.openoffice.org/en/forum/viewtopic.php?f=45&t=68100

OO is launched as any other Mac app: from the Dock or by double clicking the app in Finder. In my case via the Dock

The same problem existed in OO version 3

Competitors software is not relevant. I am talking about OO. When I have a problem with my car, I don't care if that problem would exist in any other car make.

i have no idea what you mean by "Renaming user profile". In particular the link you included does not say anything about that, so I can't help you there.
Comment 3 Rainer Bielefeld 2014-03-15 18:15:30 UTC
Modified Version due to Comment 2

Might be related to "Bug 105098 - Image drag & drop doesn't work"
Comment 4 Andre 2014-03-17 08:01:00 UTC
@hadouma: Please, we are trying to help.  For that we need enough information to reproduce the bug on our local machines.  Therefore we have to ask questions that sometimes may sound a little silly.

If, for example, we knew whether the problem exists in other software as well, would be very helpful for finding the root cause and then a solution.

I have one more question: did you try the drop at different locations?  Over the central edit view, over the tool bars?
Comment 5 mroe 2014-03-17 09:11:15 UTC
I would say Bug 105098 is the same.

If you drag any file from finder into _any_ AOO window the file opens in a new window. There is no difference between the different locations of an AOO window where you drop the file.

The bug is not only related to images. On other systems you can insert a link to a file by D&D using the Shift + Ctrl key.

Confirmed with Mac OSX 10.8 on a Mac mini.

*** This issue has been marked as a duplicate of issue 105098 ***
Comment 6 hadouma 2014-03-17 13:50:59 UTC
You ask: "I have one more question: did you try the drop at different locations?  Over the central edit view, over the tool bars?"

It does not make any difference where I try to drop the image. When I select an image and drag the mouse over any Writer document (may be empty of containing text, does not matter) I see a green plus-sign, but no cursor insertion marker, as I should. The only thing that will happen is the image is pasted into a newly opened Draw file.

Where bug 105098 states that nothing happens after dropping the image, in my case something DOES happen: it will create a Draw document. So it is related, but not the same.

This problem is very repeatable. The most minimalistic steps are
- create a new Text document
- drag a picture from Finder into this document
- release the mouse button
- instead of pasting the image into the text document, a Draw document containing the image, is created.

I have looked everywhere in settings and stuff, but nothing seems to be related to dragging & dropping. On the contrary: in the OO wiki it is stated this should work (without any special settings).
Comment 7 Armin Le Grand 2014-03-19 10:59:04 UTC
Checked on mac, indeed opens new read-only draw document containing the pic. Is already the same on AOO4.0.1, though -> no regression.
Comment 8 cdmooo 2014-09-03 11:22:15 UTC
(In reply to Andre from comment #4)
> @hadouma: Please, we are trying to help.  For that we need enough
> information to reproduce the bug on our local machines.  Therefore we have
> to ask questions that sometimes may sound a little silly.
> 
> If, for example, we knew whether the problem exists in other software as
> well, would be very helpful for finding the root cause and then a solution.
> 
> I have one more question: did you try the drop at different locations?  Over
> the central edit view, over the tool bars?

You don't need to ask these questions if you test the bug on a Mac. If you are on a PC/Windows unit you'll never see the issue. The bug is that ANY current (or close to current) version of OpenOffice will not allow you to drag a photo from anywhere on a Mac and drop it into the document without opening that image in Draw.

The expected (and correct/typical) behavior would be to have the image appear inline in the document as if you had selected "Insert > Picture > From file..."

There may be further info needed to track down the cause, but not to understand the issue. Again, if you are on a PC/Windows computer there is no amount of explanation that will suffice. You need to get on a Mac and just drag an image into a Writer document (or assign the bug to someone in the Mac division).
Comment 9 cdmooo 2014-09-03 11:26:29 UTC
(In reply to Armin Le Grand from comment #7)
> Checked on mac, indeed opens new read-only draw document containing the pic.
> Is already the same on AOO4.0.1, though -> no regression.

Thank you! The other issue remaining now is that this bug keeps getting reassigned to an old bug from 2009 (#105098) that no one is voting up in importance (because they are entering the bug as new).

The result is that it is a major bug that is being treated as almost nonexistent or insignificant even though there are no less than 5 separate reports given on it to-date.

Resolving this bug as a duplicate is the equivalent of tossing it into a black hole never to be seen again...because that report has the bug listed as "P3 trivial"
Comment 10 anscgn 2014-09-03 14:20:12 UTC
To narrow this down and avoid confusion: According to my research so far, this occurs on OS X 10.7 and later only.

Apple seem to have changed the drag & drop protocol since 10.7. Investigating the problem on any other platform is a waste of time. It worked for me until OS X 10.6.8 with OO 3.x and only broke since I moved to 10.9 and OO 4.1.1. According to others, OO 3.x exhibits the same issue on OS X 10.9. So the culprit is most likely some change in Apple's frameworks.
Comment 11 cdmooo 2014-09-03 14:23:24 UTC
(In reply to anscgn from comment #10)
> To narrow this down and avoid confusion: According to my research so far,
> this occurs on OS X 10.7 and later only.
> 
> Apple seem to have changed the drag & drop protocol since 10.7.
> Investigating the problem on any other platform is a waste of time. It
> worked for me until OS X 10.6.8 with OO 3.x and only broke since I moved to
> 10.9 and OO 4.1.1. According to others, OO 3.x exhibits the same issue on OS
> X 10.9. So the culprit is most likely some change in Apple's frameworks.

@anscgn 

You'll want to post comments (and vote) in the #105098 issue thread as all of these individual comments/issues get redirected or folded into that one. If we want anything done, it will likely need to be in that thread.

https://issues.apache.org/ooo/show_bug.cgi?id=105098
Comment 12 anscgn 2014-09-03 14:30:56 UTC
Please note that this is NOT a duplicate of issue 105098. Could someone please verify this and change the status accordingly? This issue is original and IMHO needs to be tracked seperately.

I've created issue 125562 today, which can be marked a duplicate of THIS one (124434), though. Please take my apologies for the extra noise, but I could not find it even after 30 minutes of research, so posted a new one.
Comment 13 anscgn 2014-09-03 14:33:52 UTC
*** Issue 125562 has been marked as a duplicate of this issue. ***
Comment 14 anscgn 2014-09-03 14:51:33 UTC
Links to forum discussions that prove this is a relatively new issue introduced in 2012 with OS X 10.7:

https://forum.openoffice.org/en/forum/viewtopic.php?f=7&t=57071
https://forum.openoffice.org/en/forum/viewtopic.php?f=45&t=68100
https://www.libreoffice.org/bugzilla/show_bug.cgi?id=44621