Issue 124564 - Updating TOC content will add TOC's title as one link after exporting the sample MSO doc binary file to an odt
Summary: Updating TOC content will add TOC's title as one link after exporting the sam...
Status: CLOSED DUPLICATE of issue 123599
Alias: None
Product: Writer
Classification: Application
Component: open-import (show other issues)
Version: 3.3.0 or older (OOo)
Hardware: PC All
: P3 Normal (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-31 05:47 UTC by Steve Yin
Modified: 2017-05-20 10:12 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Sample file (42.00 KB, application/msword)
2014-03-31 05:47 UTC, Steve Yin
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Steve Yin 2014-03-31 05:47:15 UTC
Created attachment 83036 [details]
Sample file

Steps:
1. Open the sample file by OpenOffice and save as an odt file.
2. Reopen the odt file, update the TOC content.

Problem:
TOC title "Contents" will be added in the TOC table as the first link.

Platform:
Windows 8 pro. Apache OpenOffice 4.1 Beta revision: 1573601.
Comment 1 Rainer Bielefeld 2014-03-31 06:24:39 UTC
More or less Reproducible   with server installation of "AOO 4.1.0-dev – English UI / German locale - [AOO410m14(Build:9760)  -  Rev. 1582709 2014-03-30]" on German WIN7 Home Premium (64bit)", own separate user profile:

1. Open Sample document
   > TOC Heading "Contents" without link, first TOC item "Heading 1" link leads
     to "Heading 1"
2. 'Save as .odt -> Close document -> reopen document'
   > TOC Heading "Contents" without link, first TOC item "Heading 1" link leads
     to "Heading 1"
3. 'Rightclick on TOC -> Update'
   Bug: TOC totally damaged, one effect of many is that "Contents" becomes 
        a TOC Item.

Additonal info:
(a) no need for step d, effect already visible if you update TOD after having 
    opened the .doc.
(b) DUP of "Issue 123599 - TOC in .doc wrongly includes headings with style
    "TOC Heading""

*** This issue has been marked as a duplicate of issue 123599 ***