Issue 124595 - Font modifications in paragraph style dialog not applied to text
Summary: Font modifications in paragraph style dialog not applied to text
Status: CLOSED IRREPRODUCIBLE
Alias: None
Product: Writer
Classification: Application
Component: formatting (show other issues)
Version: 4.0.1
Hardware: Mac OS X 10.9
: P3 Normal (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords: needmoreinfo
Depends on:
Blocks:
 
Reported: 2014-04-04 09:29 UTC by hadouma
Modified: 2017-05-20 10:11 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description hadouma 2014-04-04 09:29:42 UTC
According to the OO documentation (and common practice) styles are used to make changes to the format of a document easy. Changing the font is one of those changes. However, when I want to do that, it does not work.

Steps to reproduce the problem:
1. Create Writer document
2. Apply a style
3. Modify font of applied style

I expect to see the font change reflected in the document

What actually happens is
- the change is applied to the style definition (recalling the style in the Style/Formatting menu shows the changed font)
- the font change is NOT applied to the text
Comment 1 hadouma 2014-04-04 09:57:18 UTC
It is even worse than described earlier: the font changes are applied to PART OF the text. The first n pages of the document contain the changes, the rest doesn't
Comment 2 Rainer Bielefeld 2014-04-04 11:47:48 UTC
NOT reproducible with "AOO 4.0.1 Release – German UI / German locale [AOO401m5(Build:9714)  -  Rev. 1524958 2013-09-20 11:40:29]" on German WIN7 Home Premium (64bit)", “historic” 4.0 User Profile used for all predecessor versions.

I am pretty sure that it's not a bug, but a user error. Probably manually applied font to selected text or so (days or years) before attempt to change text font via styles.	

@hadouma: 
Please contribute more specific and more precise. The summary tells that it would be impossible to change properties in style dialog, but your comment tells that the changes are possible without problems, but they will not be applied to the text in paragraphs with that style (?).

Please add all information requested in following:
a) Write a meaningful Summary describing exactly what the problem is
b) Attach a sample document (not only screenshot) or refer to an existing 
  sample document in an other Bug with a link; to attach a file to this 
  bug report, just click on "Add an attachment" right on this page.
  Best would be a source document without style changes and a second one
  where you tried to apply changes.
  If you want to attach a test kit with multiple documents zip them into
  a single testkit.zip and attach the  testkit.zip
c) Contribute a document related step by step instruction containing every 
  key press and every mouse click how to reproduce your problem 
  NOT: apply some style, modify font and look what happens .....
  But: Select all Text with <control+a>, with Formatt Toolbar change 
  paragraph style from "Text Body" to EHeading 3",  in sidebar paragraph styles
  dialog modify font from "Times New Roman" to "M+ 3p thin" from font selctor,
  [ok]. ...
d) Attach screenshots with comments if you believe that that might explain the 
  problem better than a text comment. Best way is to insert your screenshots
  into a DRAW document and to add comments that explain what you want to show
e) if possible contribute an instruction how to create a sample document 
  from the scratch
f) add information 
  f1) what EXACTLY is unexpected
  f2) and WHY do you believe it's unexpected (cite Help or Documentation!)
  f5) concerning your AOO version (with Build/revision ID if it's not a 
     public release) and localization (UI language, Locale setting)
  f6) AOO settings that might be related to your problems 
  f7) how you launch AOO and how you opened the sample document
  f8) Whether your problem persists after you have renamed your user profile 
     (Quit Quickstart before!) before you launch AOO (please see
     <https://wiki.openoffice.org/wiki/Documentation/How_Tos/Handling_the_OpenOffice.org_User_Profile>
     <https://wiki.documentfoundation.org/User_Profile#Mac_OS_X>
  f9) Whether that worked in former OOO / AOO Versions 
  f10) whether (and how) a competitor's software (MSO, LibreOffice, ...)
       fulfills your needs
  f11) whether that works for other changes (font effects, ...)
Comment 3 Rainer Bielefeld 2014-05-17 10:53:18 UTC
Closing issue due to reporter's inactivity.

@reporter:
Please feel free to reopen this Bug if you find out that the problem still exists in the latest public release of AOO and if you can provide requested additional information. We need a test kit (Attachment here in the Bug report) and a detailed step by step instruction how to reproduce your problem, for details please see <http://wiki.openoffice.org/wiki/QA/HowToFileIssue>!