Issue 124653 - Single slide selection moves slides around or copies some
Summary: Single slide selection moves slides around or copies some
Alias: None
Product: Impress
Classification: Application
Component: ui (show other issues)
Version: 4.1.0-beta
Hardware: Mac OS X 10.9
: P3 Normal (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Keywords: needhelp
Depends on:
Reported: 2014-04-10 16:19 UTC by John Evans
Modified: 2017-05-20 11:55 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

AOO Impress slide test (14.66 KB, application/vnd.oasis.opendocument.presentation)
2015-04-18 16:47 UTC, Ken Reinert
no flags Details
PowerPoint Slide Test File (205.00 KB, application/
2015-04-18 16:48 UTC, Ken Reinert
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description John Evans 2014-04-10 16:19:58 UTC
I have this problem in AOO 4.01 and 4.1 beta - AOO410m14(Build:9760)  -  Rev. 1573601 2014-03-03 17:49:03 (Mon, 03 Mar 2014) and in LibreOffice (if you care). I don't know about Symphony 3 as most files I open there are crashing that app.

When I click on a slide, it often (maybe half the times) changes the order of the slides.  Often it will copy the slide and rearrange them. I can never be sure of the order of the slides. Usually the file was imported as PPT or PPTX.
Comment 1 Edwin Sharp 2014-04-10 18:06:39 UTC
Please attach example.
Comment 2 Andre 2014-04-11 06:56:59 UTC
@John: Is it possible that you involuntarily active drag&drop when you click on a slide?
Comment 3 John Evans 2014-04-16 14:31:14 UTC
I've tried very hard to simply click on each slide as I select the one I want to look at. I don't believe I'm doing enough movement when I click on a slide to drag & drop it. I'm attaching two presentations, one is the original, mfc_20140407.ppt and the second, mfc_3014_bug.ppt. I carefully clicked on a few slides; now slide 10 has become slide 8. I'm not sure which slide I actually clicked on when I noticed the shift, but I'm sure I didn't move enough to move slide 8 to its new position as slide 10.
Comment 4 Edwin Sharp 2014-04-16 14:51:10 UTC
No attachments...
Comment 5 John Evans 2014-04-16 14:57:03 UTC
(In reply to Edwin Sharp from comment #4)
> No attachments...

Thank you for your prompt reply; I'm working on the attachments.  They are too large to attach here.
Comment 6 John Evans 2014-04-16 18:16:54 UTC
(In reply to John Evans from comment #5)
> (In reply to Edwin Sharp from comment #4)
> > No attachments...
> Thank you for your prompt reply; I'm working on the attachments.  They are
> too large to attach here.

I do not have an FTP server with anonymous access.  May I have an email address of the person who will download the files please?
Comment 7 Edwin Sharp 2014-04-16 18:18:29 UTC
elish AT apache dot org
Comment 8 Edwin Sharp 2014-04-16 18:45:44 UTC
presentations received by email: keywords -needmoreinfo
Comment 9 Edwin Sharp 2014-04-16 19:29:09 UTC
Can not detect error
AOO410m17(Build:9763)  -  Rev. 1586584
2014-04-11 09:13 - Linux x86_64
Comment 10 John Evans 2014-04-30 18:36:27 UTC
It seems to happen mostly with Powerpoint files that I open in AOO, either 4.0.1 or 4.1 beta. I worked with a presentation of about 30 slides yesterday that I created in AOO and don't recall having problems. However, when I'm working in Powerpoint files that I open, it is almost unusable as I'm never sure that the slides have stayed in order or one has been duplicated and the order changes. Note also that I'm on a Mac.
Comment 11 John Evans 2014-05-29 18:24:17 UTC
I'm working in a file that was originally created in MS Powerpoint and saved in pptx format. I was clicking on slides and now have a copy of slide 17 as slide 12. I don't know how to give you steps to reproduce this problem as it is random, but I believe it happens on pptx files originally created in MS Powerpoint. I can usually tell when it happens, but undo doesn't fix it.  I have to reload and not save changes. If I were editing the file, this looses any changes since the last save. If I didn't create the original file, it is hard to know what has changed. This problem makes using AOO, frustrating and questionable.
Comment 12 John Evans 2014-05-30 21:49:17 UTC
Today I started with a template that was created in Powerpoint PPT, but had only two slides, at title page with a picture and a second sample page with sample text. I'm still having the same problem with it moving slides and making copies. Again, I'm on a Mac and most of the pages have screenshots and maybe a little text.
Comment 13 christian legget 2014-06-14 20:50:58 UTC
(Christian Legget  - 14th June 2014)

Thankyou for your efforts in establishing the reproduction steps so far, I have been investigating this on my own environment, without success, namely:

4.1.0(AOO410m18(Build:9764)  -  Rev. 1589052
2014-04-22 11:43:54 (Di, 22 Apr 2014))
on a Win8 Dell Studio XPS 1647 (no Apple kit available)

and 4.0.1 AOO401m5(Build:9714)  -  Rev. 1524958
2013-09-20 11:40:29 (Fr, 20 Sep 2013)
on a Win8 Dell XPS 15 

To aid reproduction I inserted a text label with self-identifying data (eg a slide reference number) in order to validate, no removal/insertion/deletion took place, when slides were clicked, when I ran with different slide templates (but empty presentation template) and different slide views(outline/notes/handout etcc)

Using a competitor product (Office Pro Plus 32 bit 2010 on same Dell Studio XPS WIn8), loading an identical file (pre import to Impress), the slides keep the prescribed order. As they do when creating the same style/layout content into an ODP file.

John - can I trouble you, with asking for a little bit more information?
1-Confirm which Apple Mac product you are using
2-Which version of Powerpoint are you using?
3-Add a reference video (or link to) that captures the problem, so the transition and slide sequence shift can be observed – eg using Jing or perhaps your camera phone
4-Could you also include screenshots from Tools>Options/Impress for all 4 categories
5-Could you confirm which slide view you are using (outline/notes/handout/slideshow) when clicking
6-Could all text be selected when the clicking is taking place and the promotion/demotion/slide hide attributes be selected?
7-As per your last comment on 30th May, which “template” were you using in PPT
8-When the content is added to the slide, is there any other presentation element activity performed (font selection/font size/alignment/indentation)?
9-Could you compress/zip an ODP file that fails for you (Just Edwin has the samples provided)
10-Do you have another device available with Impress installed, to try your ODP and PPT files on?

Comment 14 John Evans 2014-08-13 12:28:02 UTC
Hi Christian, thanks for working on this problem. As a developer myself, I know that finding and fixing non-reproducable bugs is next to impossible. I'll try to answer and help.

1. Apache OpenOffice 4.1.0 AOO410m18(Build:9764) - Rev 1589052
2. I didn't create the PPT or PPTX; it happens on both. It seems to happen in all the powerpoint files I receive to workn on.
3. I tried to use Jing to do that, but it isn't repeatable such that I can do certain steps and it happens.  That would be best of course.
5. I almost always use Normal View
6. I don't beleve anything is selected.
7. Custom templetes; I don't know who created them.
8. I don't believe anything is selected usually.

I just opened a file which I'm viewing as a ppt file.  I used the down arrow to view several of the first slides.  Then I scrolled to what is now slide 13 (slide with two people) and clicked on it.  Then I scrolled to slide 27 an clicked on it. Then I scrolled to slide 12 and clicked on it and slide 27 jumped before 12. I thought I was typing in this form, but was still in AOO and inserted a slide between the two (original 12 and moved in 12); deleted it.  Then trying to determine which where the moved slide was originally, I scrolled and clicked on a slide 26 and the moved slide moved back before where I clicked (it was originally after it).  After saving the result file for you, I tried to open the original file.  AOO showed no recent files and open was disabled.  I clicked on a slide and the options became available again. I'll try to make both files available to you and send you access.  You'll get an invitation from IBM Connections.

Unless we find and fix this bug, I'll have to switch to Powerpoint 2014 when it is out soon, struggling till then.
Comment 15 Ken Reinert 2015-04-18 16:46:07 UTC
Ken Reinert - BBST Bug Advocacy, Spring 2015

Dell Studio 1747
Windows 7 Ultimate (64 bit)
Apache Open Office version - AOO411m6(Build:9775) - Rev. 1617669
                             2014-08-13 09:06:54 (Mi, 13 Aug 2014)

I encountered a similar bug working from the notes view in Impress.  When I clicked on a different slide Impress would occasionally jump to the first slide, and in the process another slide would be copied or moved.  This was a very sporadic bug, and hard to reproduce, but I managed to replicate the duplication behavior with the following procedure:

Initial state: Create a presentation with 20 slides that includes both an auto-slide number in the footer, as well as a self verifying text label of the initial slide number so duplication or movement of slides can be easily detected.  Start from the first slide in this presentation:
1. Hover the mouse over one of the slides in the slide panel on the left and 
   mark the location of the duplicate icon with tape or sticky note.
2. Click on the notes tab, and then switch to another slide that is far enough 
   down the list in the slide panel on the left that slide 1 is no longer 
   visible. Make sure that another slide is present where the mark from step 1 
   is located.
3. Click into the notes text box as if you were going to enter some text, and 
   make sure the cursor changes to a text entry cursor.
4. Next click on the spot marked in step 1.

Bug Behavior: The slide view and slide panel will jump to the first slide.  Occasionally either the slide that was initially selected before the jump, or the slide the cursor ends on after the jump will be moved or copied in the list.  This is a very sporadic behavior, and it may take 10 or more attempts to replicate the duplication bug, but it is more likely to occur if the initial click or end position after the jump is on the duplicate icon.

This behavior seems to be a side effect of the loss of focus bug (125911, 125013, 125707, 125708), and a result of selecting another slide when a jump occurs.  I have seen both moves and copies of either the slide at the initial cursor location or after the jump, but both moves and copies are very rare.  The critical diagnostic feature is the presence of the jump back to slide 1 in the slide panel.

Although this replication took place in the notes view, this same behavior can be replicated in the normal view, but it is much harder to reproduce as the loss of focus bug is much less likely in normal view.  Working with PowerPoint files, or files that have extensive changes (>20) since the last save seem to exacerbate the issue, and make the jump, and the concomitant move or copy much more likely.  As such, immediately saving the imported PowerPoint file to the native .odf format and then reloading, and saving work regularly might both help mitigate this issue.

If the jump to the first slide is not a symptom of the behavior, there are a few follow-up tests that might highlight other causes of this behavior:

1. Try working with the same files on a different computer system.  While I 
   have replicated a similar issue with a file created in AOO, there may be 
   other issues with importing files or the custom templates in those files 
   that are making the bug behavior more likely.  Working with the files on a 
   separate computer will indicate whether the bug is specific to the files or 
   the system.  If the problem proves to be based on the files, saving them as 
   a native .odf format before working with them might solve the problem.
2. In a standard mouse, an electrical or mechanical malfunction in the mouse 
   buttons can cause a sporadic clicking that is not obvious to a user.  
   Alternatively, might be related to advanced features of non-standard 
   pointing devices, like buttons for copying and pasting.  Try changing the 
   mouse used while working with Impress to see if it resolves the issue.
3. The behavior might be due to a corrupted installation of AOO.  The import 
   functionality might be disrupted, leading to odd issues when working with 
   imported files.  Uninstalling and then reinstalling AOO might repair this 

I have attached the .odf and .ppt files used for replicating the duplication issue mentioned above.
Comment 16 Ken Reinert 2015-04-18 16:47:28 UTC
Created attachment 84670 [details]
AOO Impress slide test
Comment 17 Ken Reinert 2015-04-18 16:48:12 UTC
Created attachment 84671 [details]
PowerPoint Slide Test File