Issue 124677 - Saving presentation leads to "format error" on new file due to doubled xml attribute
Summary: Saving presentation leads to "format error" on new file due to doubled xml at...
Alias: None
Product: Impress
Classification: Application
Component: save-export (show other issues)
Version: 4.0.1
Hardware: PC Linux 64-bit
: P3 Normal (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Depends on:
Reported: 2014-04-13 14:17 UTC by Michael
Modified: 2014-05-04 07:25 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: 4.1.0
Developer Difficulty: ---

Slide with format error (12.93 KB, application/vnd.oasis.opendocument.presentation)
2014-04-18 22:26 UTC, Michael
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Michael 2014-04-13 14:17:57 UTC
Hi there,

I have a large presentation that is not readable anymore when I save it. 

Here is the message of the popup:
"format error discovered in the file in sub-document context.xml at ..."

The file was edited wit LibreOffice for several years before I jumped back to OO. Now after creating a new master slide in OO there seems to be a serious problem.

I can open and save the file with LibreOffice Impress Version: Afterwards I can open the file in OO, but when I save it in OO the file is again defective. 

I've tried to investigate on content.xml and tried to format it but got an error there:

$ xmllint --format content.xml
content.xml:2: parser error : Attribute draw:mirror-vertical redefined
rue" draw:type="ooxml-rect" draw:enhanced-path="M 0 0 L ?f3 0 ?f3 ?f2 0 ?f2 Z N"

Near to the above string I found: "draw:mirror-vertical="false""
After deleting the string the file was readable again in OO.
(This also helped to rescue several hours of work :)

Here is the responsible xml snipped:

          <draw:enhanced-geometry draw:mirror-horizontal="false" draw:mirror-vertical="false" svg:viewBox="0 0 0 0" draw:text-areas="0 0 ?f3 ?f2" draw:mirror-vertical="true" draw:type="ooxml-rect" draw:enhanced-path="M 0 0 L ?f3 0 ?f3 ?f2 0 ?f2 Z N">
            <draw:equation draw:name="f0" draw:formula="logwidth/2"/>
            <draw:equation draw:name="f1" draw:formula="logheight/2"/>
            <draw:equation draw:name="f2" draw:formula="logheight"/>
            <draw:equation draw:name="f3" draw:formula="logwidth"/>

draw:mirror-vertical is there twice, once with value true and once with false.

Comment 1 Edwin Sharp 2014-04-13 14:40:27 UTC
Please link presentation.
Comment 2 Michael 2014-04-13 15:12:16 UTC
Hello Edwin, 

Unfortunately, the file is relatively confidential. 
Can I maybe send it via PM?

I have also repoduced the behaviour with

AOO420m1(Build:9800)  -  Rev. 1586681
2014-04-13_04:11:11 - Rev. 1586919

Regards Michael
Comment 3 Regina Henschel 2014-04-13 15:48:29 UTC
Thanks you for testing it in a 'daily' build.

Do you have tested to save it with that newest version? Or only tried to open the already damaged file?

Can you please try to delete as much slides as possible, so that the error is still there, but the wrong element can be found easier? Then please sent the file to me via PM.

We saw already wrong saving by LibreOffice, see issue 124452.
Comment 4 Michael 2014-04-18 22:26:17 UTC
Created attachment 83232 [details]
Slide with format error
Comment 5 Michael 2014-04-18 22:35:52 UTC
Hello Regina,

I also tried to save it with the new version.

Ive tried to reduce the amount of slides with libreoffice (Version:,
Build ID: 70feb7d99726f064edab4605a8ab840c50ec57a) but when I delete a random slide the presentation becomes readable in OO again and the problem seems to disappear. I just see the option to send the whole file via PM. Is this also OK?

I have also managed to identfy a slide with seems to be defect. I deleted everything else with OpenOffice, all the content of the slide and all master slides but one (See previously attached file). When I save the "empty" slide I still get an format error when the file is opened again. 

Regards Michael
Comment 6 Edwin Sharp 2014-05-04 07:25:43 UTC
Confirmed with
AOO410m18(Build:9764)  -  Rev. 1589052
2014-04-22 12:11 - Linux x86_64