Issue 124684 - Export to PDF only shows placeholder for EPS
Summary: Export to PDF only shows placeholder for EPS
Alias: None
Product: Writer
Classification: Application
Component: save-export (show other issues)
Version: 4.1.0-beta
Hardware: All Linux 64-bit
: P3 Normal (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Depends on:
Reported: 2014-04-15 05:59 UTC by szurketestver
Modified: 2014-04-24 07:25 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: 4.1.0-dev
Developer Difficulty: ---

Screenshot of xp.odt in AOO 4.1 beta1 (52.26 KB, image/png)
2014-04-15 08:22 UTC, szurketestver
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description szurketestver 2014-04-15 05:59:46 UTC
It is an ODT with an EPS image. OpenOffice 4.0 exports the image preview to PDF. OpenOffice 4.1 beta exports only the placeholder. It is a regression from revision 1537508 i123500 unified Graphic processing to use GraphicPrimitive2D.
Comment 1 Rainer Bielefeld 2014-04-15 06:47:24 UTC
I tried to reproduce with  Attachment 57833 [details] for Issue 96046 and server installation of "AOO 4.1.0-dev – English UI / German locale - [AOO410m14(Build:9760)  -  Rev. 1583418_2014-04-02]" on German WIN7 Home Premium (64bit)", own separate user profile, but I only see a placeholder "created with inkscape xyz" instead of the picture, so I wonder why reporter expects a correct pdf export.

Thank you for your feedback – unfortunately important information we will 
need to reproduce your problem is missing.
Please add all information requested in following:
a) Write a meaningful Summary describing exactly what the problem is
b) Attach a with screenshot of what you see in AOO and your
  PDF export result
c) Contribute a document related step by step instruction containing every 
   key press and every mouse click how to reproduce your problem 
d) Attach screenshots with comments if you believe that that might explain the 
   problem better than a text comment. Best way is to insert your screenshots
   into a DRAW document and to add comments that explain what you want to show
e) if possible contribute an instruction how to create a sample document 
   from the scratch
f) add information 
   f1) what EXACTLY is unexpected. What is the difference between 
       a placeholder and a preview? It's completely impossible to imagine
       what you see
   f2) and WHY do you believe it's unexpected (cite Help or Documentation!)
   f3) concerning your PC (video card, ...)
   f4) concerning your Operating System (Version, Distribution, Language)
   f5) concerning your AOO version (with Build/revision ID if it's not a 
      public release) and localization (UI language, Locale setting)
   f6) AOO settings that might be related to your problems 
      (video hardware acceleration, ...)
   f7) how you launch AOO and how you opened the sample document
   f9) Whether that worked in former OOO / AOO Versions 
   f10) whether (and how) a competitor's software (MSO, LibreOffice, ...)
        fulfills your needs
   f11) Why do you think we need an additional Bug report besides 
        "Issue 96046 - Regression: EPS pictures incorrectly exported to PDF"

Please do not cite these hints in your reply, but cite the items like:
f7): Desktop-icon for soffice.exe / AOO File menu -> Open
Comment 2 szurketestver 2014-04-15 08:22:40 UTC
Created attachment 83193 [details]
Screenshot of xp.odt in AOO 4.1 beta1

@Rainer: I used AOO410m14(Build:9760)  -  Rev. 1573601 2014-02-28 10:36 - Linux x86_64 and AOO401m5(Build:9714)  -  Rev. 1524958 2013-09-20 11:54 - Linux x86_64 (official releases). The attached screenshot shows, that the image is shown in Writer. 

I use the Export Direcly as PDF button on the toolbar. AOO 4.0 produces a PDF with the image, AOO 4.1 beta1 does not.

It is unrelated to issue 96046 from 2008, because as I tried to explain, it is OK in AOO 4.0, and I even gave you the commit revision that caused the regression.
Comment 3 Rainer Bielefeld 2014-04-15 09:30:54 UTC
(g) This one seems unrelated to Issue 96046

I can't test because of "Issue 124686 - EPS contents in particular.odt not shown"

Please attach your result with AOO 4.0 and 4.1 as a
Do I understand that correctly, Printing works, only a problem with PDF export?
Comment 4 Armin Le Grand 2014-04-15 12:48:04 UTC
I have isolated the EPS as file, it only contains PS commands, there is no preview image AFAICT.
Comment 5 Edwin Sharp 2014-04-15 14:01:31 UTC
Confirmed with
AOO410m17(Build:9763)  -  Rev. 1586584
2014-04-11 09:13 - Linux x86_64