Issue 124755 - Cannot hide the shapes from master page when importing the sample pptx
Summary: Cannot hide the shapes from master page when importing the sample pptx
Status: CLOSED FIXED
Alias: None
Product: Impress
Classification: Application
Component: open-import (show other issues)
Version: 4.1.0-dev
Hardware: All All
: P3 Major (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks: 116796
  Show dependency tree
 
Reported: 2014-04-28 03:27 UTC by Steve Yin
Modified: 2017-05-20 10:35 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
A sample file to reproduce this issue (31.51 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2014-04-28 03:27 UTC, Steve Yin
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Steve Yin 2014-04-28 03:27:52 UTC
Created attachment 83285 [details]
A sample file to reproduce this issue

Open the sample pptx file by AOO.

Issue:
The shape in the master page is displayed in the Normal view.

Expect result:
No shape appears in the Normal view.
Comment 1 Steve Yin 2014-04-28 03:31:28 UTC
Added "IsBackgroundObjectsVisible" property support for sd OOXML importing
Comment 2 Andre 2014-04-28 07:27:34 UTC
Steve: Can you elaborate a bit more?  What is the root cause of the problem, what is the solution?
Comment 3 Steve Yin 2014-04-28 08:34:40 UTC
(In reply to Andre from comment #2)
> Steve: Can you elaborate a bit more?  What is the root cause of the problem,
> what is the solution?

@Andre. Thanks for your reminder.

Root cause:
The attribute "showMasterSp" of OOXML is not supported. So the sample file will be imported with a default value of the slide attribute "Display Objects from Master" which is enabled. It should be disabled in this case.

Solution:
Applying the attribute for slide in pptx filter.