Issue 124784 - insert grafics works confusing
Summary: insert grafics works confusing
Status: CLOSED DUPLICATE of issue 125613
Alias: None
Product: Impress
Classification: Application
Component: editing (show other issues)
Version: 4.1.0
Hardware: All All
: P3 Normal with 3 votes (vote)
Target Milestone: ---
Assignee: Armin Le Grand
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-30 18:19 UTC by zuhansh
Modified: 2015-10-15 09:45 UTC (History)
9 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
an example (413.13 KB, application/vnd.oasis.opendocument.text)
2014-04-30 19:25 UTC, zuhansh
no flags Details
Inserted Grafic becomes Background to the Text-Box (12.37 KB, application/vnd.oasis.opendocument.graphics)
2015-10-15 09:33 UTC, Martin Loewenstein
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description zuhansh 2014-04-30 18:19:28 UTC
Hello,

standing in an impress-folio I want to insert a grafics:
I do Ctrl-C with an internet-grafics and want to Ctrl-V it into the folio.
Surprisingly its found right in a text-part as background-image multiplied all over that object.

I tried several ways, but I couldn't get it (as it was possible in 4.0.1!) into my folio.

I thing this must'nt be that way - it should work straightforward.

Until now I haven't found a solution.

Greetings from Austria
Hans
Comment 1 zuhansh 2014-04-30 19:25:21 UTC
Created attachment 83301 [details]
an example

Hello,

I found out now, that it's "only" a problem in some cases (see attachement):
I had the problem with a presentation I made with 4.0.1.

Now I started a brand new presentation and used a template. Withe te second page I had the problem You can see in the attachment: I right clicked into the heading-text and choose "Insert".

The picture was then as background image in the other text-part of this page.

I hope, this helps.

Greetings
Hans
Comment 2 Regina Henschel 2014-04-30 20:06:53 UTC
I can confirm the error. I copy a picture from browser Seamonkey and insert it to a slide with layout "Titel, Content". The picture is set as background graphic to the Content presentation object. This object was _not_ selected. It makes no difference whether the object has already got text or not.

Workaround: Insert a slide and set its layout to "Empty", paste the clipboard. Then copy the picture from there and insert it into the desired slide.
Comment 3 Armin Le Grand 2014-05-05 08:18:21 UTC
Hi Regina, this sounds as if I forgot/oversaw a case when reorganizing the D&D/CopyPaste stuff. I will have a look...
Comment 4 Jeremy Wilkinson 2014-05-13 12:20:27 UTC
Can confirm this bug. It happens both when pasting an image and using the Insert->Picture->From File dialog.

In addition, when it happens, it strips all formatting from any text in the box it happens to (size, italic, superscript, subscript, etc). The change in formatting can't be undone with the document history; either you have to re-do the formatting or reload the file.

It is possible to get it to insert an image into the slide directly as previously, usually by clicking repeatedly outside the bounds of the slide, but this is not reliable (once the issue has happened once, it will happen repeatedly for many attempts thereafter)
Comment 5 Joe Smith 2014-05-20 12:47:46 UTC
Should be marked as a regression--right?

The workaround for me is to switch to a slide layout that has no content frame.
Comment 6 Jeremy Wilkinson 2014-06-03 15:58:38 UTC
Any news on a fix for this? The workaround mentioned by Regina and Joe works, but is less than ideal (especially the fact that if you forget to do it and the bug triggers, it irreversibly removes some of your formatting)
Comment 7 Armin Le Grand 2014-06-04 14:59:21 UTC
Not yet - had no time, but it's on my list
Comment 8 zuhansh 2014-06-05 18:16:29 UTC
You will have a look (your entry from beginning of May) - now you don't have time (one month later)...

Sounds, that there should be somone else working on this.

This is a really nasty bug that is really bad for this wonderful software-suite. so there should be someone there, who cares!
Comment 9 Keith N. McKenna 2014-06-05 22:18:16 UTC
(In reply to zuhansh from comment #8)
> You will have a look (your entry from beginning of May) - now you don't have
> time (one month later)...
> 
> Sounds, that there should be somone else working on this.
> 
> This is a really nasty bug that is really bad for this wonderful
> software-suite. so there should be someone there, who cares!

Hans;

Please understand that this is an open source project and that most work is done by volunteers who also have full time jobs and personal lives. They do this in there spare time because they believe in the product and in the concept of open source software. 

Keith
Comment 10 Armin Le Grand 2014-06-24 12:23:05 UTC
I have checked again on Win7 AOO420m1(Build:9800)  -  Rev. 1603756
2014-06-19 13:40:50 (Thu, 19 Jun 2014), but could not reproduce. Steps taken:
- New Impress
- Slide layout 'Title, Content' (using sidebar)
- Any page in Mozilla (used https://www.google.de/search?q=openoffice&client=firefox-a&hs=Sh6&rls=org.mozilla:en-US:official&source=lnms&tbm=isch&sa=X&ei=lWupU5XlO9T07Aa_n4GwCQ&ved=0CAgQ_AUoAQ&biw=1630&bih=1049)
- context menu on any graphic, select 'Copy Image'
- Change to Impress, nothing selected, Context menu 'Paste'
-> New graphic object inserted (as expected).

@Regina: If you can reproduce, can I please have a step-by-step description how to get the error?
Comment 11 Regina Henschel 2014-06-24 15:09:09 UTC
For me too the error is not reproducible with AOO420m1(Build:9800)  -  Rev. 1601656. I see the error only in AOO410m18(Build:9764)  -  Rev. 1589052
2014-04-22 11:43:54.

I see no branch for AOO4.1.1. Will AOO4.1.1 be released from trunk? If not, it would be worth to bring the fix (whatever have fixed it) to AOO4.1.1.
Comment 12 Armin Le Grand 2014-06-25 10:52:10 UTC
Hi Regina, I tried with the AOO411 version (which is the branches/AOO410 part, AOO4.1 is a minor release and is developed from AOO410, not from trunk) and I cannot reproduce there. Thus it seems fixed by something elxe (I have no concrete idea), but it's fixed in AOO411, too AFAIK.
-> Unconfirmed?
Comment 13 Frédéric Hoogstoel 2014-09-02 09:39:10 UTC
I can confirm the error with :
- AOO411m6(Build:9775)  -  Rev. 1617669 2014-08-13 09:06:54 (Mi, 13 Aug 2014)
- Windows XP Home Edition up to date
I can't control the place where the image is pasted. Sometimes, it is pasted in the background of the slide, sometimes in a text area
Comment 14 Frédéric Hoogstoel 2014-09-02 09:40:17 UTC
I found a workaround. Instead of copy/paste, I use drag and drop from the file manager to the slide.
Comment 15 Ken Reinert 2015-04-09 03:07:49 UTC
I can also confirm error with:
 - AOO411m6(Build:9775)  -  Rev. 1617669
 - Windows 7 Ultimate

It only seems to happen when a content frame is present in the layout.  If no content frame is present, the image pastes into the slide in its own box.  When inserting an image from the insert menu, if multiple content frames are present, it preferentially picks one of the frames, and additional inserts will simply replace the background image for the same content frame.

I was able to find two additional workarounds for this problem.  If you include the image you want to insert into your gallery, insertions from the gallery appear in their own box regardless of whether or not content frames are present in the layout.  The second workaround is to insert a box (drawn object) and insert the image into that box.  The gallery workaround is probably the more sound and stable of the two.
Comment 16 Regina Henschel 2015-04-09 10:20:29 UTC
This seems to be duplicate to issue 125613, which is fixed already. Please try with a current developer build from http://ci.apache.org/projects/openoffice/install/, if you can still reproduce the error. Otherwise close this issue as duplicate.
Comment 17 Martin Loewenstein 2015-10-15 09:33:07 UTC
Created attachment 85038 [details]
Inserted Grafic becomes Background to the Text-Box
Comment 18 Martin Loewenstein 2015-10-15 09:33:25 UTC
Comment on attachment 85038 [details]
Inserted Grafic becomes Background to the Text-Box

Hallo!

After I updated 4.1.1. I had this problem for the first time. 

It is hard to reproduce the problem. The phenomenon does not occure with any text-field, but sometimes it does and there is no way to undo the insert of the grafic that was not intended to be background to the grafic. 

If it is a help to find the bug, please use the file attached.

Thanks for whoever works on this!

Martin
Comment 19 Regina Henschel 2015-10-15 09:45:30 UTC
Please read comment #16. The fix is not included in 4.1.1., but the upcoming release 4.1.2 will have the fix. You can already test the release candidate from https://dist.apache.org/repos/dist/dev/openoffice/

*** This issue has been marked as a duplicate of issue 125613 ***