Issue 124800 - No multimedia support in MacOSX
No multimedia support in MacOSX
Status: VERIFIED FIXED
Product: Impress
Classification: Application
Component: open-import
4.1.0
Mac Mac OSX, all
: P3 major with 2 votes (vote)
: 4.1.1
Assigned To: hdu@apache.org
: regression
: 124976 (view as issue list)
Depends on:
Blocks: 124985 124875
  Show dependency treegraph
 
Reported: 2014-05-02 11:51 UTC by papayes
Modified: 2014-07-14 07:33 UTC (History)
7 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: 4.1.0
Developer Difficulty: ---
jsc: 4.1.1_release_blocker+


Attachments
Impress sound Applause (14.68 KB, application/vnd.oasis.opendocument.presentation)
2014-05-02 11:51 UTC, papayes
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description papayes 2014-05-02 11:51:38 UTC
Created attachment 83317 [details]
Impress sound Applause

Only with AOO 4.1.0 and mac OsX (10.9.2)
(regression is't OK whith 4.0.1)
No sound play 
Impress-> Slide Transition-> Sound-> "Applause" for example
Sorry,
Comment 1 Edwin Sharp 2014-05-02 11:59:24 UTC
Slide Transition - Sound has no selection.
Do you see "applause" selected in sound list box?
When applause is selected, it is played as expected.
AOO410m18(Build:9764)  -  Rev. 1589052
2014-04-22 12:11 - Linux x86_64
Debian
Comment 2 papayes 2014-05-02 12:32:51 UTC
hello,
Only with 4.1.0 and MAC OS X 10.9.2 
When "applause" is selected, it is not played as expected
as the others sound !!!

It is OK whih Windows and Linux...
Comment 3 tintin60 2014-05-02 14:07:10 UTC
Hello,

Mac OSX 10.9.2 / AOO 4.1.0

I confirm.
No sound played when opening a impress file correctly operating with AOO 4.0.1.
Neither transition sound nor background.

Creating an impress file, it is impossible to insert any sound.

Slts
Comment 4 Edwin Sharp 2014-05-02 14:10:48 UTC
Confirmed per comment 3
Merci beaucoup!
Comment 5 Ariel Constenla-Haile 2014-05-02 14:47:58 UTC
This affects all the application:
- try to play a sound from the Gallery
- try to insert a video o audio in a Writer/Draw/Calc/Impress document

4.0 has a library on /Applications/OpenOffice.app/Contents/MacOS/libavmediaQuickTime.dylib that is missing in 4.1

This library implements the multimedia support in MacOSX:

Sub Main
Dim oMediaManager as Object
oMediaManager = CreateUnoService("com.sun.star.media.Manager_QuickTime")
If IsNull(oMediaManager) Then
MsgBox "No media in MacOSX!", 16, "ERROR"
else
MsgBox "Multimedia support in MacOSX is OK", 64, "OK"
End If
End Sub
Comment 6 Ariel Constenla-Haile 2014-05-02 14:59:42 UTC
See revision 1560309 and Bug 114728
Comment 7 Ariel Constenla-Haile 2014-05-03 20:46:29 UTC
Can you please try the following extension?
https://people.apache.org/~arielch/extensions/avmedia/aoo-avmedia-quicktime-0.0.1-macosx-x86-64.oxt

It's an experiment I've just made with the available source code, so use it at your own risk.
Comment 8 tintin60 2014-05-05 10:22:43 UTC
Hi,

MacOSX 10.9.2 - 2.4 GHz Intel Core 2 Duo - RAM 8 Go

I did it.
1- Opening a .pps including a music => OK
2- Opening a .odp I've created with AOO 4.0.1 including a sound inserted in the first diapo without picture followed by pictures with music => OK
3- Creating an new .odp including a sound inserted in the first diapo without picture followed by pictures with music => OK

In my opinion, except error, your extension operates correctly.

Thanks a lot.
Comment 9 hdu@apache.org 2014-05-06 09:57:20 UTC
The extension works fine, is easy to install and thus a great workaround!

Though the Quicktime API is not available to 64bit clients the related QTKit is still in OSX10.9 even though it has been deprecated there. We'll have to move to the AVFoundation API. There is much more API churn on this platform than on the other platforms and so the rejuvenation of the port was more than overdue. Sorry about this oversight. I'm working on the conversion to the AVFoundation API.
Comment 10 SVN Robot 2014-05-06 11:21:03 UTC
"hdu" committed SVN revision 1592716 into trunk:
#i124800# switch avmedia's QuickTime component to QTKit for now
Comment 11 papayes 2014-05-08 06:35:24 UTC
Sorry for not being able to test the extension instead.
As already stated, it works very well.
It is just unfortunate that the download files can be updated only exceptionally for Os X.
Thank you for the quick response.
Comment 12 SVN Robot 2014-05-13 12:10:20 UTC
"hdu" committed SVN revision 1594206 into trunk:
#i124800# reenable pre-registration of the quicktime component
Comment 13 hdu@apache.org 2014-05-20 13:04:36 UTC
Fixed with the commits above. The extension Ariel provides (in comment 7) is an excellent workaround in the meantime. With the support of the AV Framework (int issue 124875) we'll also be prepared when the deprecated QT* stuff is no longer available.
Comment 14 Ariel Constenla-Haile 2014-06-07 20:31:07 UTC
*** Issue 124976 has been marked as a duplicate of this issue. ***
Comment 15 jsc 2014-06-12 13:24:45 UTC
grant showstopper flag for AOO 4.1.1
Comment 16 SVN Robot 2014-06-13 10:02:05 UTC
"hdu" committed SVN revision 1602357 into branches/AOO410:
#i124800# switch avmedia's QuickTime component to QTKit for now
Comment 17 hdu@apache.org 2014-06-13 10:03:23 UTC
The fixes have been merged for the AOO 4.1.1 target.
Comment 18 fanyuzhen 2014-07-14 07:33:09 UTC
It's verified fixed with build AOO411m2(Build:9771)  -  Rev. 1608452
2014-07-07 15:29:02 (Mon, 07 Jul 2014), on Mac OSX 10.9.3